summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2007-12-05 20:04:42 +0000
committerMike Frysinger <vapier@gentoo.org>2007-12-05 20:04:42 +0000
commitf42c21d5a48a53adbb995696f9c60a47e914f66a (patch)
treed1393d2bea299139c37c142825f5390c27f0f971 /app-arch/p7zip
parentFix download URL, see bug #201339. (diff)
downloadgentoo-2-f42c21d5a48a53adbb995696f9c60a47e914f66a.tar.gz
gentoo-2-f42c21d5a48a53adbb995696f9c60a47e914f66a.tar.bz2
gentoo-2-f42c21d5a48a53adbb995696f9c60a47e914f66a.zip
Do not install /usr/bin/lzma as there are other/dedicated packages that install just the lzma compression utilities #198324.
(Portage version: 2.1.4_rc4)
Diffstat (limited to 'app-arch/p7zip')
-rw-r--r--app-arch/p7zip/ChangeLog8
-rw-r--r--app-arch/p7zip/files/digest-p7zip-4.55-r13
-rw-r--r--app-arch/p7zip/p7zip-4.55-r1.ebuild74
3 files changed, 84 insertions, 1 deletions
diff --git a/app-arch/p7zip/ChangeLog b/app-arch/p7zip/ChangeLog
index 9ce441a7b965..4ea41b7d6f26 100644
--- a/app-arch/p7zip/ChangeLog
+++ b/app-arch/p7zip/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-arch/p7zip
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/p7zip/ChangeLog,v 1.82 2007/12/01 17:06:11 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/p7zip/ChangeLog,v 1.83 2007/12/05 20:04:41 vapier Exp $
+
+*p7zip-4.55-r1 (05 Dec 2007)
+
+ 05 Dec 2007; Mike Frysinger <vapier@gentoo.org> +p7zip-4.55-r1.ebuild:
+ Do not install /usr/bin/lzma as there are other/dedicated packages that
+ install just the lzma compression utilities #198324.
01 Dec 2007; Markus Rothe <corsair@gentoo.org> p7zip-4.55.ebuild:
Stable on ppc64
diff --git a/app-arch/p7zip/files/digest-p7zip-4.55-r1 b/app-arch/p7zip/files/digest-p7zip-4.55-r1
new file mode 100644
index 000000000000..f6a2ea937c2b
--- /dev/null
+++ b/app-arch/p7zip/files/digest-p7zip-4.55-r1
@@ -0,0 +1,3 @@
+MD5 bb141529cf2374a2e15735f155273172 p7zip_4.55_src_all.tar.bz2 1487801
+RMD160 d224572461f04b53976e2e45a6d1c34aabda18d8 p7zip_4.55_src_all.tar.bz2 1487801
+SHA256 5604c21b4fec1b73e6bf8b69b0c3f97a3f269cdd975c3bdc5d961de7ed8a0835 p7zip_4.55_src_all.tar.bz2 1487801
diff --git a/app-arch/p7zip/p7zip-4.55-r1.ebuild b/app-arch/p7zip/p7zip-4.55-r1.ebuild
new file mode 100644
index 000000000000..11495ae0a8c7
--- /dev/null
+++ b/app-arch/p7zip/p7zip-4.55-r1.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/p7zip/p7zip-4.55-r1.ebuild,v 1.1 2007/12/05 20:04:41 vapier Exp $
+
+inherit eutils toolchain-funcs multilib
+
+DESCRIPTION="Port of 7-Zip archiver for Unix"
+HOMEPAGE="http://p7zip.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${PN}_${PV}_src_all.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="static doc"
+
+DEPEND=""
+
+S=${WORKDIR}/${PN}_${PV}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i \
+ -e "/^CXX=/s:g++:$(tc-getCXX):" \
+ -e "/^CC=/s:gcc:$(tc-getCC):" \
+ -e "s:OPTFLAGS=-O:OPTFLAGS=${CXXFLAGS}:" \
+ -e 's:-s ::' \
+ makefile* || die "changing makefiles"
+
+ if use amd64; then
+ ewarn "Using suboptimal -fPIC upstream makefile due to amd64 being detected. See #126722"
+ cp -f makefile.linux_amd64 makefile.machine
+ elif [[ ${CHOST} == *-darwin* ]] ; then
+ # Mac OS X needs this special makefile, because it has a non-GNU linker
+ cp -f makefile.macosx makefile.machine
+ elif use x86-fbsd; then
+ # FreeBSD needs this special makefile, because it hasn't -ldl
+ sed -e 's/-lc_r/-pthread/' makefile.freebsd > makefile.machine
+ fi
+ use static && sed -i -e '/^LOCAL_LIBS=/s/LOCAL_LIBS=/&-static /' makefile.machine
+}
+
+src_compile() {
+ emake all3 || die "compilation error"
+}
+
+src_install() {
+ # this wrappers can not be symlinks, p7zip should be called with full path
+ make_wrapper 7zr "/usr/lib/${PN}/7zr"
+ make_wrapper 7za "/usr/lib/${PN}/7za"
+ make_wrapper 7z "/usr/lib/${PN}/7z"
+
+ dobin "${FILESDIR}/p7zip" || die
+
+ # gzip introduced in 4.42, so beware :)
+ # mv needed just as rename, because dobin installs using old name
+ mv contrib/gzip-like_CLI_wrapper_for_7z/p7zip contrib/gzip-like_CLI_wrapper_for_7z/7zg || die
+ dobin contrib/gzip-like_CLI_wrapper_for_7z/7zg || die
+
+ exeinto /usr/$(get_libdir)/${PN}
+ doexe bin/7z bin/7za bin/7zr bin/7zCon.sfx || die "doexe bins"
+ exeinto /usr/$(get_libdir)/${PN}/Codecs
+ doexe bin/Codecs/* || die "doexe Codecs"
+ exeinto /usr/$(get_libdir)/${PN}
+ doexe bin/*.so || die "doexe *.so files"
+
+ doman man1/7z.1 man1/7za.1 man1/7zr.1
+ dodoc ChangeLog README TODO
+
+ if use doc ; then
+ dodoc DOCS/*.txt
+ dohtml -r DOCS/MANUAL/*
+ fi
+}