summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2007-04-03 21:28:55 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2007-04-03 21:28:55 +0000
commit6e3ff3111f9dff3f7e996ad6a6cefc42ec1a2fba (patch)
treee09b2c799cba0d34747ce7cdf98e0337668c4f57 /app-arch/pbzip2/pbzip2-1.0.1.ebuild
parentStable on sparc (diff)
downloadgentoo-2-6e3ff3111f9dff3f7e996ad6a6cefc42ec1a2fba.tar.gz
gentoo-2-6e3ff3111f9dff3f7e996ad6a6cefc42ec1a2fba.tar.bz2
gentoo-2-6e3ff3111f9dff3f7e996ad6a6cefc42ec1a2fba.zip
Version bump and closing bug #171737.
(Portage version: 2.1.2.2)
Diffstat (limited to 'app-arch/pbzip2/pbzip2-1.0.1.ebuild')
-rw-r--r--app-arch/pbzip2/pbzip2-1.0.1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/app-arch/pbzip2/pbzip2-1.0.1.ebuild b/app-arch/pbzip2/pbzip2-1.0.1.ebuild
new file mode 100644
index 000000000000..56bb3358ea3a
--- /dev/null
+++ b/app-arch/pbzip2/pbzip2-1.0.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/pbzip2/pbzip2-1.0.1.ebuild,v 1.1 2007/04/03 21:28:55 wolf31o2 Exp $
+
+DESCRIPTION="A parallel version of BZIP2"
+HOMEPAGE="http://compression.ca/pbzip2/"
+SRC_URI="http://compression.ca/${PN}/${P}.tar.gz"
+
+LICENSE="PBZIP2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 m68k mips ppc ~ppc-macos ppc64 s390 sh sparc x86"
+IUSE="static"
+
+DEPEND="app-arch/bzip2"
+
+src_unpack() {
+ unpack ${A}
+ sed -i -e 's:-O3:${CFLAGS}:g' ${P}/Makefile || die
+}
+
+src_compile() {
+ if use static ; then
+ cp -f /usr/$(get_libdir)/libbz2.a ${S}
+ emake pbzip2-static || die "Failed to build"
+ else
+ emake pbzip2 || die "Failed to build"
+ fi
+}
+
+src_install() {
+ dobin pbzip2 || die "Failed to install"
+ dodoc AUTHORS ChangeLog README
+ doman pbzip2.1 || die "Failed to install man page"
+}