summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek@gentoo.org>2011-06-14 00:37:13 +0000
committerNirbheek Chauhan <nirbheek@gentoo.org>2011-06-14 00:37:13 +0000
commitf1bb6950b4dd861349996c023f49c54704304fbe (patch)
treeaf04dbe7a84af73de01c39803100003f739e3cf6 /app-arch/snappy
parentAdded ~mips, bug 342513 (diff)
downloadgentoo-2-f1bb6950b4dd861349996c023f49c54704304fbe.tar.gz
gentoo-2-f1bb6950b4dd861349996c023f49c54704304fbe.tar.bz2
gentoo-2-f1bb6950b4dd861349996c023f49c54704304fbe.zip
Add snappy-1.0.3, there seems to be demand for it
(Portage version: 2.2.0_alpha39_p14/cvs/Linux x86_64)
Diffstat (limited to 'app-arch/snappy')
-rw-r--r--app-arch/snappy/ChangeLog10
-rw-r--r--app-arch/snappy/metadata.xml15
-rw-r--r--app-arch/snappy/snappy-1.0.3.ebuild46
3 files changed, 71 insertions, 0 deletions
diff --git a/app-arch/snappy/ChangeLog b/app-arch/snappy/ChangeLog
new file mode 100644
index 000000000000..47ba25502308
--- /dev/null
+++ b/app-arch/snappy/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for app-arch/snappy
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/snappy/ChangeLog,v 1.1 2011/06/14 00:37:13 nirbheek Exp $
+
+*snappy-1.0.3 (14 Jun 2011)
+
+ 14 Jun 2011; Nirbheek Chauhan <nirbheek@gentoo.org> +snappy-1.0.3.ebuild,
+ +metadata.xml:
+ Add snappy-1.0.3, there seems to be demand for it
+
diff --git a/app-arch/snappy/metadata.xml b/app-arch/snappy/metadata.xml
new file mode 100644
index 000000000000..7a1826d296e6
--- /dev/null
+++ b/app-arch/snappy/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>no-herd</herd>
+ <maintainer>
+ <email>nirbheek@gentoo.org</email>
+ <name>Nirbheek Chauhan</name>
+ </maintainer>
+ <longdescription lang="en">
+ Snappy is a compression/decompression library. It does not aim for
+ maximum compression, or compatibility with any other compression
+ library; instead, it aims for very high speeds and reasonable
+ compression.
+ </longdescription>
+</pkgmetadata>
diff --git a/app-arch/snappy/snappy-1.0.3.ebuild b/app-arch/snappy/snappy-1.0.3.ebuild
new file mode 100644
index 000000000000..94b3ee5156da
--- /dev/null
+++ b/app-arch/snappy/snappy-1.0.3.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/snappy/snappy-1.0.3.ebuild,v 1.1 2011/06/14 00:37:13 nirbheek Exp $
+
+EAPI="4"
+
+DESCRIPTION="A high-speed compression/decompression library by Google"
+HOMEPAGE="https://code.google.com/p/snappy/"
+SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs"
+
+RDEPEND=""
+DEPEND="${RDEPEND}"
+
+DOCS="AUTHORS ChangeLog README NEWS format_description.txt"
+
+src_prepare() {
+ default
+ # Avoid automagic lzop and gzip by not checking for it
+ #sed -i -e '/^CHECK_EXT_COMPRESSION_LIB/d' "${S}/configure.ac" || die
+ # Avoid eautoreconf due to the above sed by just removing the expanded lines
+ sed -i -e '15126,15385d' "${S}/configure" || die
+}
+
+src_configure() {
+ econf \
+ --without-gflags \
+ --disable-gtest \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+
+ # Remove docs installed by snappy itself
+ rm -rf "${ED}/usr/share/doc/snappy" || die
+
+ # Remove la files if we're not installing static libraries
+ if ! use static-libs; then
+ find "${ED}" -iname '*.la' -exec rm -f {} + || die
+ fi
+}