summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Harring <ferringb@gentoo.org>2010-08-11 08:30:41 +0000
committerBrian Harring <ferringb@gentoo.org>2010-08-11 08:30:41 +0000
commit634d229daa00b60c355aa6478c95cbc9e662f22b (patch)
treec22c150d824d6b54025b49180ed70151da4ff88e /app-arch/tarsync/tarsync-0.2.1-r1.ebuild
parentAdd doc useflag. (diff)
downloadgentoo-2-634d229daa00b60c355aa6478c95cbc9e662f22b.tar.gz
gentoo-2-634d229daa00b60c355aa6478c95cbc9e662f22b.tar.bz2
gentoo-2-634d229daa00b60c355aa6478c95cbc9e662f22b.zip
fix bug 331855, respecting LDFLAGS
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'app-arch/tarsync/tarsync-0.2.1-r1.ebuild')
-rw-r--r--app-arch/tarsync/tarsync-0.2.1-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-arch/tarsync/tarsync-0.2.1-r1.ebuild b/app-arch/tarsync/tarsync-0.2.1-r1.ebuild
new file mode 100644
index 000000000000..7c89c40e5a12
--- /dev/null
+++ b/app-arch/tarsync/tarsync-0.2.1-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/tarsync/tarsync-0.2.1-r1.ebuild,v 1.1 2010/08/11 08:30:41 ferringb Exp $
+
+EAPI=2
+DESCRIPTION="Delta compression suite for using/generating binary patches"
+HOMEPAGE="http://gentooexperimental.org/~ferringb/tarsync/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~hppa ~ppc ~x86 ~amd64"
+IUSE=""
+
+S="${WORKDIR}/${PN}"
+
+DEPEND=">=dev-util/diffball-0.7"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ sed -i -e 's:gcc \$(CFLAGS):gcc \$(CFLAGS) $(LDFLAGS):' Makefile || die "failed sed'ing to enable LDFLAGS"
+}
+
+src_compile() {
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "failed installing"
+}