summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2014-05-06 02:40:46 +0000
committerTim Harder <radhermit@gentoo.org>2014-05-06 02:40:46 +0000
commit41cda14997d6b204ff248dcfb5e38c804f7ede0e (patch)
treef9248f24474ffa1f37c4f99a0bdb01d106a55b82 /app-arch/unrar
parentVersion bump (bug #505978 by José María Fernández González). (diff)
downloadgentoo-2-41cda14997d6b204ff248dcfb5e38c804f7ede0e.tar.gz
gentoo-2-41cda14997d6b204ff248dcfb5e38c804f7ede0e.tar.bz2
gentoo-2-41cda14997d6b204ff248dcfb5e38c804f7ede0e.zip
Version bump.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'app-arch/unrar')
-rw-r--r--app-arch/unrar/ChangeLog7
-rw-r--r--app-arch/unrar/unrar-5.1.4.ebuild56
2 files changed, 62 insertions, 1 deletions
diff --git a/app-arch/unrar/ChangeLog b/app-arch/unrar/ChangeLog
index e04fe2ceb421..eb7e27bb4d16 100644
--- a/app-arch/unrar/ChangeLog
+++ b/app-arch/unrar/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-arch/unrar
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/unrar/ChangeLog,v 1.219 2014/04/20 11:21:37 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/unrar/ChangeLog,v 1.220 2014/05/06 02:40:46 radhermit Exp $
+
+*unrar-5.1.4 (06 May 2014)
+
+ 06 May 2014; Tim Harder <radhermit@gentoo.org> +unrar-5.1.4.ebuild:
+ Version bump.
20 Apr 2014; Agostino Sarubbo <ago@gentoo.org> unrar-5.0.14.ebuild:
Stable for ppc64, wrt bug #505932
diff --git a/app-arch/unrar/unrar-5.1.4.ebuild b/app-arch/unrar/unrar-5.1.4.ebuild
new file mode 100644
index 000000000000..e55b554cc295
--- /dev/null
+++ b/app-arch/unrar/unrar-5.1.4.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/unrar/unrar-5.1.4.ebuild,v 1.1 2014/05/06 02:40:46 radhermit Exp $
+
+EAPI=5
+inherit eutils flag-o-matic multilib toolchain-funcs
+
+MY_PN=${PN}src
+
+DESCRIPTION="Uncompress rar files"
+HOMEPAGE="http://www.rarlab.com/rar_add.htm"
+SRC_URI="http://www.rarlab.com/rar/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="unRAR"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~arm-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="!<=app-arch/unrar-gpl-0.0.1_p20080417"
+
+S=${WORKDIR}/unrar
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-5.0.2-build.patch
+ sed -i \
+ -e "/libunrar/s:.so:$(get_libname ${PV%.*.*}):" \
+ -e "s:-shared:& -Wl,-soname -Wl,libunrar$(get_libname ${PV%.*.*}):" \
+ makefile || die
+}
+
+src_compile() {
+ unrar_make() {
+ emake CXX="$(tc-getCXX)" CXXFLAGS="${CXXFLAGS}" STRIP=true "$@"
+ }
+
+ unrar_make CXXFLAGS+=" -fPIC" lib
+ ln -s libunrar$(get_libname ${PV%.*.*}) libunrar$(get_libname)
+ ln -s libunrar$(get_libname ${PV%.*.*}) libunrar$(get_libname ${PV})
+
+ # The stupid code compiles a lot of objects differently if
+ # they're going into a lib (-DRARDLL) or into the main app.
+ # So for now, we can't link the main app against the lib.
+ unrar_make clean
+ unrar_make
+}
+
+src_install() {
+ dobin unrar
+ dodoc readme.txt
+
+ dolib.so libunrar*
+
+ insinto /usr/include/libunrar${PV%.*.*}
+ doins *.hpp
+ dosym libunrar${PV%.*.*} /usr/include/libunrar
+}