summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMounir Lamouri <volkmar@gentoo.org>2009-07-31 09:37:03 +0000
committerMounir Lamouri <volkmar@gentoo.org>2009-07-31 09:37:03 +0000
commitbba5b3c6f57c6b7caba065096e51da2a7aaab394 (patch)
tree8db4ce8fbd30df3d7a556e0cacfddb747fdfffb1 /app-arch/upm
parentInvalid headers. (diff)
downloadgentoo-2-bba5b3c6f57c6b7caba065096e51da2a7aaab394.tar.gz
gentoo-2-bba5b3c6f57c6b7caba065096e51da2a7aaab394.tar.bz2
gentoo-2-bba5b3c6f57c6b7caba065096e51da2a7aaab394.zip
Fixing compilation issue.
Bug 264067. Thanks to Robert Lewis. (Portage version: 13856-svn/cvs/Linux i686)
Diffstat (limited to 'app-arch/upm')
-rw-r--r--app-arch/upm/ChangeLog6
-rw-r--r--app-arch/upm/files/upm-0.85-static.patch30
-rw-r--r--app-arch/upm/upm-0.85.ebuild8
3 files changed, 40 insertions, 4 deletions
diff --git a/app-arch/upm/ChangeLog b/app-arch/upm/ChangeLog
index c9b4f2d5eb4b..a780f6358f2f 100644
--- a/app-arch/upm/ChangeLog
+++ b/app-arch/upm/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-arch/upm
# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/upm/ChangeLog,v 1.10 2009/03/28 13:59:08 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/upm/ChangeLog,v 1.11 2009/07/31 09:37:03 volkmar Exp $
+
+ 31 Jul 2009; Mounir Lamouri <volkmar@gentoo.org>
+ +files/upm-0.85-static.patch, upm-0.85.ebuild:
+ Fixing compilation issue. Bug 264067. Thanks to Robert Lewis.
28 Mar 2009; Diego E. Pettenò <flameeyes@gentoo.org> upm-0.85.ebuild:
Die during src_compile if make fails.
diff --git a/app-arch/upm/files/upm-0.85-static.patch b/app-arch/upm/files/upm-0.85-static.patch
new file mode 100644
index 000000000000..52f28f716769
--- /dev/null
+++ b/app-arch/upm/files/upm-0.85-static.patch
@@ -0,0 +1,30 @@
+Fix compilation issue.
+Look at https://bugs.gentoo.org/264067
+Thanks to Robert Lewis
+--- a/upm-0.85/upm.c 2009-04-27 22:48:39.265036979 -0400
++++ b/upm-0.85/upm.c 2009-04-27 22:49:01.724787260 -0400
+@@ -2235,21 +2235,21 @@
+ ************************************************************/
+
+ /* Fast way to read octals */
+-unsigned inline moct(char *s) {
++static unsigned inline moct(char *s) {
+ unsigned int x=0;
+ while (isdigit(*s)) x=x*8+*s++-'0';
+ return x;
+ }
+
+ /* Fast way to read ints */
+-unsigned inline mint(char *s) {
++static unsigned inline mint(char *s) {
+ unsigned int x=0;
+ while (isdigit(*s)) x=x*10+*s++-'0';
+ return x;
+ }
+
+ /* Fast way to read long ints */
+-unsigned long long inline mlong(char *s) {
++static unsigned long long inline mlong(char *s) {
+ unsigned long long x=0;
+ while (isdigit(*s)) x=x*10+*s++-'0';
+ return x;
diff --git a/app-arch/upm/upm-0.85.ebuild b/app-arch/upm/upm-0.85.ebuild
index 44e9a9dac5f5..68b86c670cd7 100644
--- a/app-arch/upm/upm-0.85.ebuild
+++ b/app-arch/upm/upm-0.85.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/upm/upm-0.85.ebuild,v 1.12 2009/03/28 13:59:08 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/upm/upm-0.85.ebuild,v 1.13 2009/07/31 09:37:03 volkmar Exp $
inherit eutils
@@ -14,10 +14,12 @@ KEYWORDS="alpha ~hppa ppc ~sparc x86"
IUSE=""
DEPEND="sys-apps/fakeroot"
+RDEPEND=${DEPEND}
src_unpack() {
unpack ${P}.tar.gz
- epatch ${FILESDIR}/${P}-gentoo.diff
+ epatch "${FILESDIR}"/${P}-gentoo.diff
+ epatch "${FILESDIR}"/${P}-static.patch # bug 264067
}
src_compile() {
@@ -26,7 +28,7 @@ src_compile() {
src_install() {
dodir /bin
- make DESTDIR=${D} install || die
+ make DESTDIR="${D}" install || die "make install failed"
dodir /usr/upm/installed
dodir /var/upm/{binary,cache}
}