summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2011-01-06 03:10:42 +0000
committerMike Frysinger <vapier@gentoo.org>2011-01-06 03:10:42 +0000
commitacd8fc2e47cbd16500cb12303ab36d308ce98bd0 (patch)
tree3095c90c646b2b3f149b4c1de7dd2e467408801a /app-arch/upx-ucl
parentVersion bump. (diff)
downloadgentoo-2-acd8fc2e47cbd16500cb12303ab36d308ce98bd0.tar.gz
gentoo-2-acd8fc2e47cbd16500cb12303ab36d308ce98bd0.tar.bz2
gentoo-2-acd8fc2e47cbd16500cb12303ab36d308ce98bd0.zip
old
Diffstat (limited to 'app-arch/upx-ucl')
-rw-r--r--app-arch/upx-ucl/files/upx-ucl-1.25-pie.patch18
-rw-r--r--app-arch/upx-ucl/files/upx-ucl-glibc210.patch18
-rw-r--r--app-arch/upx-ucl/upx-ucl-1.25-r1.ebuild51
-rw-r--r--app-arch/upx-ucl/upx-ucl-2.02.ebuild35
-rw-r--r--app-arch/upx-ucl/upx-ucl-2.03.ebuild36
-rw-r--r--app-arch/upx-ucl/upx-ucl-3.00.ebuild46
-rw-r--r--app-arch/upx-ucl/upx-ucl-3.02.ebuild48
-rw-r--r--app-arch/upx-ucl/upx-ucl-3.03.ebuild48
8 files changed, 0 insertions, 300 deletions
diff --git a/app-arch/upx-ucl/files/upx-ucl-1.25-pie.patch b/app-arch/upx-ucl/files/upx-ucl-1.25-pie.patch
deleted file mode 100644
index 400f313edeeb..000000000000
--- a/app-arch/upx-ucl/files/upx-ucl-1.25-pie.patch
+++ /dev/null
@@ -1,18 +0,0 @@
---- upx-1.25.orig/src/p_unix.cpp 2005-06-03 13:00:09.000000000 -0400
-+++ upx-1.25/src/p_unix.cpp 2005-06-03 13:51:24.000000000 -0400
-@@ -376,11 +376,12 @@ bool PackLinuxI386::canPack()
- const unsigned l = get_le32(buf);
- if (!memcmp(buf, "\x7f\x45\x4c\x46\x01\x01\x01", 7)) // ELF 32-bit LSB
- {
-+ unsigned int e_type = get_le16(buf+16);
- exetype = 1;
- // now check the ELF header
- if (memcmp(buf+8, "FreeBSD", 7) == 0) // branded
- exetype = 0;
-- if (get_le16(buf+16) != 2) // e_type - executable
-+ if ((e_type > 3) || (e_type < 2)) // e_type - ET_EXEC or ET_DYN
- exetype = 0;
- if (get_le16(buf+18) != 3) // e_machine - Intel 80386
- exetype = 0;
-
-
diff --git a/app-arch/upx-ucl/files/upx-ucl-glibc210.patch b/app-arch/upx-ucl/files/upx-ucl-glibc210.patch
deleted file mode 100644
index 38540bc64a01..000000000000
--- a/app-arch/upx-ucl/files/upx-ucl-glibc210.patch
+++ /dev/null
@@ -1,18 +0,0 @@
-diff -NrU5 src.original/pefile.cpp src/pefile.cpp
---- src.original/pefile.cpp 2009-08-02 23:54:36.000000000 -0600
-+++ src/pefile.cpp 2009-08-02 23:54:18.000000000 -0600
-@@ -1347,12 +1347,12 @@
- };
-
- // FIXME this comparison is not too exact
- while (1)
- {
-- char *delim1 = strchr(keep, '/');
-- char *delim2 = strchr(keep, ',');
-+ const char *delim1 = strchr(keep, '/');
-+ const char *delim2 = strchr(keep, ',');
- if (helper::match(itype, ntype, keep))
- {
- if (!delim1)
- return true;
- if (delim2 && delim2 < delim1)
diff --git a/app-arch/upx-ucl/upx-ucl-1.25-r1.ebuild b/app-arch/upx-ucl/upx-ucl-1.25-r1.ebuild
deleted file mode 100644
index 988dd5c0df48..000000000000
--- a/app-arch/upx-ucl/upx-ucl-1.25-r1.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/upx-ucl/upx-ucl-1.25-r1.ebuild,v 1.4 2009/10/12 17:06:59 halcy0n Exp $
-
-inherit eutils toolchain-funcs
-
-MY_P=${P/-ucl/}
-S=${WORKDIR}/${MY_P}
-DESCRIPTION="upx is the Ultimate Packer for eXecutables."
-HOMEPAGE="http://upx.sourceforge.net"
-SRC_URI="http://upx.sourceforge.net/download/${MY_P}-src.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~x86 ~ppc ~sparc ~amd64"
-
-IUSE=""
-
-DEPEND=">=dev-libs/ucl-1.02
- >=dev-lang/perl-5.6
- !app-arch/upx"
-
-RDEPEND=">=dev-libs/ucl-1.02 !app-arch/upx"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- epatch "${FILESDIR}"/${PN}-${PV}-pie.patch
-
- # used with valgrind
- sed -i -e s/-lmcheck//g src/Makefile.bld || die
-
- # >=gcc-3.4.x
- if [ "`gcc-major-version`" -ge "3" ] && [ "`gcc-minor-version`" -ge "4" ]; then
- sed -i -e s/-mcpu/-mtune/g src/Makefile.bld || die
- fi
-}
-
-src_compile() {
- make -C src UCLDIR=/usr CFLAGS_O="${CFLAGS}" || die "Failed compiling"
- make -C doc || die "Failed making documentation"
-}
-
-src_install() {
- dobin src/upx
-
- dodoc BUGS LOADER.TXT NEWS PROJECTS README* THANKS doc/upx.doc
- dohtml doc/upx.html
- doman doc/upx.1
-}
diff --git a/app-arch/upx-ucl/upx-ucl-2.02.ebuild b/app-arch/upx-ucl/upx-ucl-2.02.ebuild
deleted file mode 100644
index f8a280a093e2..000000000000
--- a/app-arch/upx-ucl/upx-ucl-2.02.ebuild
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/upx-ucl/upx-ucl-2.02.ebuild,v 1.2 2009/10/12 17:06:59 halcy0n Exp $
-
-inherit eutils toolchain-funcs
-
-MY_P="${P/-ucl/}-src"
-DESCRIPTION="upx is the Ultimate Packer for eXecutables."
-HOMEPAGE="http://upx.sourceforge.net"
-SRC_URI="http://upx.sourceforge.net/download/${MY_P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~sparc ~x86"
-
-IUSE=""
-
-DEPEND=">=dev-libs/ucl-1.02
- dev-lang/perl
- !app-arch/upx"
-
-S="${WORKDIR}/${MY_P}"
-
-src_compile() {
- #make -C src UPX_UCLDIR=/usr || die "Failed compiling"
- make all || die
-}
-
-src_install() {
- newbin src/upx.out upx
-
- dodoc BUGS NEWS PROJECTS README* THANKS TODO doc/upx.doc
- dohtml doc/upx.html
- doman doc/upx.1
-}
diff --git a/app-arch/upx-ucl/upx-ucl-2.03.ebuild b/app-arch/upx-ucl/upx-ucl-2.03.ebuild
deleted file mode 100644
index 0770b9510046..000000000000
--- a/app-arch/upx-ucl/upx-ucl-2.03.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/upx-ucl/upx-ucl-2.03.ebuild,v 1.2 2009/10/12 17:06:59 halcy0n Exp $
-
-inherit eutils toolchain-funcs
-
-MY_P="${P/-ucl/}-src"
-DESCRIPTION="upx is the Ultimate Packer for eXecutables."
-HOMEPAGE="http://upx.sourceforge.net"
-SRC_URI="http://upx.sourceforge.net/download/${MY_P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~sparc ~x86"
-
-IUSE=""
-
-DEPEND=">=dev-libs/ucl-1.02
- dev-lang/perl
- !app-arch/upx"
-
-S="${WORKDIR}/${MY_P}"
-
-src_compile() {
- tc-export CXX
- #make -C src UPX_UCLDIR=/usr || die "Failed compiling"
- emake all || die
-}
-
-src_install() {
- newbin src/upx.out upx
-
- dodoc BUGS NEWS PROJECTS README* THANKS TODO doc/upx.doc doc/*.txt
- dohtml doc/upx.html
- doman doc/upx.1
-}
diff --git a/app-arch/upx-ucl/upx-ucl-3.00.ebuild b/app-arch/upx-ucl/upx-ucl-3.00.ebuild
deleted file mode 100644
index fb7de5e49f42..000000000000
--- a/app-arch/upx-ucl/upx-ucl-3.00.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/upx-ucl/upx-ucl-3.00.ebuild,v 1.3 2009/10/12 17:06:59 halcy0n Exp $
-
-inherit eutils toolchain-funcs
-
-LZMA_VER=4.43
-MY_P="${P/-ucl/}-src"
-DESCRIPTION="upx is the Ultimate Packer for eXecutables."
-HOMEPAGE="http://upx.sourceforge.net"
-SRC_URI="http://upx.sourceforge.net/download/${MY_P}.tar.bz2
- mirror://sourceforge/sevenzip/lzma${LZMA_VER/.}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~sparc ~x86"
-
-IUSE=""
-
-DEPEND=">=dev-libs/ucl-1.02
- dev-lang/perl
- !app-arch/upx"
-
-S="${WORKDIR}/${MY_P}"
-
-src_unpack() {
- unpack ${MY_P}.tar.bz2
- cd "${S}"
- epatch "${FILESDIR}"/${PN}-glibc210.patch
- mkdir "${WORKDIR}"/lzma-${LZMA_VER}
- cd "${WORKDIR}"/lzma-${LZMA_VER}
- unpack lzma${LZMA_VER/.}.tar.bz2
-}
-
-src_compile() {
- tc-export CXX
- emake UPX_LZMADIR="${WORKDIR}"/lzma-${LZMA_VER} all || die
-}
-
-src_install() {
- newbin src/upx.out upx
-
- dodoc BUGS NEWS PROJECTS README* THANKS TODO doc/upx.doc doc/*.txt
- dohtml doc/upx.html
- doman doc/upx.1
-}
diff --git a/app-arch/upx-ucl/upx-ucl-3.02.ebuild b/app-arch/upx-ucl/upx-ucl-3.02.ebuild
deleted file mode 100644
index 6b6cb6a1a869..000000000000
--- a/app-arch/upx-ucl/upx-ucl-3.02.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/upx-ucl/upx-ucl-3.02.ebuild,v 1.4 2009/10/12 17:06:59 halcy0n Exp $
-
-inherit eutils toolchain-funcs flag-o-matic
-
-LZMA_VER=4.57
-MY_P="${P/-ucl/}-src"
-DESCRIPTION="upx is the Ultimate Packer for eXecutables."
-HOMEPAGE="http://upx.sourceforge.net"
-SRC_URI="http://upx.sourceforge.net/download/${MY_P}.tar.bz2
- mirror://sourceforge/sevenzip/lzma${LZMA_VER/.}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~sparc ~x86"
-
-IUSE=""
-
-DEPEND=">=dev-libs/ucl-1.02
- dev-lang/perl
- !app-arch/upx"
-
-S="${WORKDIR}/${MY_P}"
-
-src_unpack() {
- unpack ${MY_P}.tar.bz2
- cd "${S}"
- epatch "${FILESDIR}"/${PN}-glibc210.patch
- mkdir "${WORKDIR}"/lzma-${LZMA_VER}
- cd "${WORKDIR}"/lzma-${LZMA_VER}
- unpack lzma${LZMA_VER/.}.tar.bz2
-}
-
-src_compile() {
- use sparc && append-flags "-D__BIG_ENDIAN__"
-
- tc-export CXX
- emake UPX_LZMADIR="${WORKDIR}"/lzma-${LZMA_VER} all || die
-}
-
-src_install() {
- newbin src/upx.out upx
-
- dodoc BUGS NEWS PROJECTS README* THANKS TODO doc/upx.doc doc/*.txt
- dohtml doc/upx.html
- doman doc/upx.1
-}
diff --git a/app-arch/upx-ucl/upx-ucl-3.03.ebuild b/app-arch/upx-ucl/upx-ucl-3.03.ebuild
deleted file mode 100644
index ab964184ea15..000000000000
--- a/app-arch/upx-ucl/upx-ucl-3.03.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/upx-ucl/upx-ucl-3.03.ebuild,v 1.4 2009/10/12 17:06:59 halcy0n Exp $
-
-inherit eutils toolchain-funcs flag-o-matic
-
-LZMA_VER=4.57
-MY_P="${P/-ucl/}-src"
-DESCRIPTION="upx is the Ultimate Packer for eXecutables."
-HOMEPAGE="http://upx.sourceforge.net"
-SRC_URI="http://upx.sourceforge.net/download/${MY_P}.tar.bz2
- mirror://sourceforge/sevenzip/lzma${LZMA_VER/.}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~x86-fbsd"
-
-IUSE=""
-
-DEPEND=">=dev-libs/ucl-1.02
- dev-lang/perl
- !app-arch/upx"
-
-S="${WORKDIR}/${MY_P}"
-
-src_unpack() {
- unpack ${MY_P}.tar.bz2
- cd "${S}"
- epatch "${FILESDIR}"/${PN}-glibc210.patch
- mkdir "${WORKDIR}"/lzma-${LZMA_VER}
- cd "${WORKDIR}"/lzma-${LZMA_VER}
- unpack lzma${LZMA_VER/.}.tar.bz2
-}
-
-src_compile() {
- use sparc && append-flags "-D__BIG_ENDIAN__"
-
- tc-export CXX
- emake UPX_LZMADIR="${WORKDIR}"/lzma-${LZMA_VER} all || die
-}
-
-src_install() {
- newbin src/upx.out upx
-
- dodoc BUGS NEWS PROJECTS README* THANKS TODO doc/upx.doc doc/*.txt
- dohtml doc/upx.html
- doman doc/upx.1
-}