summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVictor Ostorga <vostorga@gentoo.org>2009-08-03 00:02:55 +0000
committerVictor Ostorga <vostorga@gentoo.org>2009-08-03 00:02:55 +0000
commite98e54680c3e748169b20ab5748f84376e56dc0c (patch)
tree7ec65da9001a71f59427ab79f1c38fc0657e3b4e /app-arch/upx-ucl
parentVersion bumped. (diff)
downloadgentoo-2-e98e54680c3e748169b20ab5748f84376e56dc0c.tar.gz
gentoo-2-e98e54680c3e748169b20ab5748f84376e56dc0c.tar.bz2
gentoo-2-e98e54680c3e748169b20ab5748f84376e56dc0c.zip
Fixing build against glibc 2.10. Bug #279911
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'app-arch/upx-ucl')
-rw-r--r--app-arch/upx-ucl/ChangeLog9
-rw-r--r--app-arch/upx-ucl/files/upx-ucl-glibc210.patch18
-rw-r--r--app-arch/upx-ucl/upx-ucl-3.00.ebuild6
-rw-r--r--app-arch/upx-ucl/upx-ucl-3.02.ebuild6
-rw-r--r--app-arch/upx-ucl/upx-ucl-3.03.ebuild4
5 files changed, 36 insertions, 7 deletions
diff --git a/app-arch/upx-ucl/ChangeLog b/app-arch/upx-ucl/ChangeLog
index 0c693bb20366..c01a025cd25c 100644
--- a/app-arch/upx-ucl/ChangeLog
+++ b/app-arch/upx-ucl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-arch/upx-ucl
-# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/upx-ucl/ChangeLog,v 1.16 2009/02/25 12:17:26 drizzt Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/upx-ucl/ChangeLog,v 1.17 2009/08/03 00:02:55 vostorga Exp $
+
+ 02 Aug 2009; Víctor Ostorga <vostorga@gentoo.org>
+ +files/upx-ucl-glibc210.patch, upx-ucl-3.00.ebuild, upx-ucl-3.02.ebuild,
+ upx-ucl-3.03.ebuild:
+ Fixing build against glibc 2.10. Bug #279911
25 Feb 2009; Timothy Redaelli <drizzt@gentoo.org> upx-ucl-3.03.ebuild:
Add ~x86-fbsd keyword to upx-ucl (and deps)
diff --git a/app-arch/upx-ucl/files/upx-ucl-glibc210.patch b/app-arch/upx-ucl/files/upx-ucl-glibc210.patch
new file mode 100644
index 000000000000..38540bc64a01
--- /dev/null
+++ b/app-arch/upx-ucl/files/upx-ucl-glibc210.patch
@@ -0,0 +1,18 @@
+diff -NrU5 src.original/pefile.cpp src/pefile.cpp
+--- src.original/pefile.cpp 2009-08-02 23:54:36.000000000 -0600
++++ src/pefile.cpp 2009-08-02 23:54:18.000000000 -0600
+@@ -1347,12 +1347,12 @@
+ };
+
+ // FIXME this comparison is not too exact
+ while (1)
+ {
+- char *delim1 = strchr(keep, '/');
+- char *delim2 = strchr(keep, ',');
++ const char *delim1 = strchr(keep, '/');
++ const char *delim2 = strchr(keep, ',');
+ if (helper::match(itype, ntype, keep))
+ {
+ if (!delim1)
+ return true;
+ if (delim2 && delim2 < delim1)
diff --git a/app-arch/upx-ucl/upx-ucl-3.00.ebuild b/app-arch/upx-ucl/upx-ucl-3.00.ebuild
index 78445378074f..96d9bae3f48c 100644
--- a/app-arch/upx-ucl/upx-ucl-3.00.ebuild
+++ b/app-arch/upx-ucl/upx-ucl-3.00.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/upx-ucl/upx-ucl-3.00.ebuild,v 1.1 2007/06/21 16:34:08 drizzt Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/upx-ucl/upx-ucl-3.00.ebuild,v 1.2 2009/08/03 00:02:55 vostorga Exp $
inherit eutils toolchain-funcs
@@ -25,6 +25,8 @@ S="${WORKDIR}/${MY_P}"
src_unpack() {
unpack ${MY_P}.tar.bz2
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-glibc210.patch
mkdir "${WORKDIR}"/lzma-${LZMA_VER}
cd "${WORKDIR}"/lzma-${LZMA_VER}
unpack lzma${LZMA_VER/.}.tar.bz2
diff --git a/app-arch/upx-ucl/upx-ucl-3.02.ebuild b/app-arch/upx-ucl/upx-ucl-3.02.ebuild
index ac9c4c1b469d..faf975bcb24f 100644
--- a/app-arch/upx-ucl/upx-ucl-3.02.ebuild
+++ b/app-arch/upx-ucl/upx-ucl-3.02.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/upx-ucl/upx-ucl-3.02.ebuild,v 1.2 2008/05/16 09:43:44 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/upx-ucl/upx-ucl-3.02.ebuild,v 1.3 2009/08/03 00:02:55 vostorga Exp $
inherit eutils toolchain-funcs flag-o-matic
@@ -25,6 +25,8 @@ S="${WORKDIR}/${MY_P}"
src_unpack() {
unpack ${MY_P}.tar.bz2
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-glibc210.patch
mkdir "${WORKDIR}"/lzma-${LZMA_VER}
cd "${WORKDIR}"/lzma-${LZMA_VER}
unpack lzma${LZMA_VER/.}.tar.bz2
diff --git a/app-arch/upx-ucl/upx-ucl-3.03.ebuild b/app-arch/upx-ucl/upx-ucl-3.03.ebuild
index 1c0352b39b3e..35e1c1134fc9 100644
--- a/app-arch/upx-ucl/upx-ucl-3.03.ebuild
+++ b/app-arch/upx-ucl/upx-ucl-3.03.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/upx-ucl/upx-ucl-3.03.ebuild,v 1.2 2009/02/25 12:17:26 drizzt Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/upx-ucl/upx-ucl-3.03.ebuild,v 1.3 2009/08/03 00:02:55 vostorga Exp $
inherit eutils toolchain-funcs flag-o-matic
@@ -25,6 +25,8 @@ S="${WORKDIR}/${MY_P}"
src_unpack() {
unpack ${MY_P}.tar.bz2
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-glibc210.patch
mkdir "${WORKDIR}"/lzma-${LZMA_VER}
cd "${WORKDIR}"/lzma-${LZMA_VER}
unpack lzma${LZMA_VER/.}.tar.bz2