summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2009-08-28 07:40:25 +0000
committerMike Frysinger <vapier@gentoo.org>2009-08-28 07:40:25 +0000
commit859dd948e0829048f97ceef8be4aba0ea745e408 (patch)
tree0aa1709749c3f95610b9d8bc7f9683a255371c6a /app-arch/xz-utils
parentVersion bump (diff)
downloadgentoo-2-859dd948e0829048f97ceef8be4aba0ea745e408.tar.gz
gentoo-2-859dd948e0829048f97ceef8be4aba0ea745e408.tar.bz2
gentoo-2-859dd948e0829048f97ceef8be4aba0ea745e408.zip
Version bump.
(Portage version: 2.2_rc40/cvs/Linux x86_64)
Diffstat (limited to 'app-arch/xz-utils')
-rw-r--r--app-arch/xz-utils/ChangeLog8
-rw-r--r--app-arch/xz-utils/xz-utils-4.999.9_beta.ebuild51
2 files changed, 58 insertions, 1 deletions
diff --git a/app-arch/xz-utils/ChangeLog b/app-arch/xz-utils/ChangeLog
index fa76fe71d247..365c70859670 100644
--- a/app-arch/xz-utils/ChangeLog
+++ b/app-arch/xz-utils/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-arch/xz-utils
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/xz-utils/ChangeLog,v 1.3 2009/07/05 20:30:10 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/xz-utils/ChangeLog,v 1.4 2009/08/28 07:40:25 vapier Exp $
+
+*xz-utils-4.999.9_beta (28 Aug 2009)
+
+ 28 Aug 2009; Mike Frysinger <vapier@gentoo.org>
+ +xz-utils-4.999.9_beta.ebuild:
+ Version bump.
*xz-utils-4.999.8_beta (05 Jul 2009)
diff --git a/app-arch/xz-utils/xz-utils-4.999.9_beta.ebuild b/app-arch/xz-utils/xz-utils-4.999.9_beta.ebuild
new file mode 100644
index 000000000000..c4a77b505f73
--- /dev/null
+++ b/app-arch/xz-utils/xz-utils-4.999.9_beta.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/xz-utils/xz-utils-4.999.9_beta.ebuild,v 1.1 2009/08/28 07:40:25 vapier Exp $
+
+# Remember: we cannot leverage autotools in this ebuild in order
+# to avoid circular deps with autotools
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="git://ctrl.tukaani.org/xz.git"
+ inherit git autotools
+ SRC_URI=""
+ EXTRA_DEPEND="sys-devel/gettext dev-util/cvs" #272880
+else
+ MY_P="${PN/-utils}-${PV/_}"
+ SRC_URI="http://tukaani.org/xz/${MY_P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+ S=${WORKDIR}/${MY_P}
+ EXTRA_DEPEND=
+fi
+
+inherit eutils
+
+DESCRIPTION="utils for managing LZMA compressed files"
+HOMEPAGE="http://tukaani.org/xz/"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE=""
+
+RDEPEND="!app-arch/lzma
+ !app-arch/lzma-utils
+ !<app-arch/p7zip-4.57"
+DEPEND="${RDEPEND}
+ ${EXTRA_DEPEND}"
+
+src_unpack() {
+ if [[ ${PV} == "9999" ]] ; then
+ git_src_unpack
+ cd "${S}"
+ ./autogen.sh || die
+ else
+ unpack ${A}
+ cd "${S}"
+ sed -i 's:-static::' $(find -name Makefile.in)
+ fi
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+ dodoc AUTHORS ChangeLog NEWS README THANKS
+}