summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimothy Redaelli <drizzt@gentoo.org>2007-07-14 15:07:59 +0000
committerTimothy Redaelli <drizzt@gentoo.org>2007-07-14 15:07:59 +0000
commitd467f8bee6ed1b230ad7d1e59928ae0ee57dd31d (patch)
tree50970bfbf041b51f493ccfb6c22d0d1bd6a178dd /app-arch/zoo
parentalpha/ia64/x86 stable (diff)
downloadgentoo-2-d467f8bee6ed1b230ad7d1e59928ae0ee57dd31d.tar.gz
gentoo-2-d467f8bee6ed1b230ad7d1e59928ae0ee57dd31d.tar.bz2
gentoo-2-d467f8bee6ed1b230ad7d1e59928ae0ee57dd31d.zip
Revision bump:
Add ~x86-fbsd keyword with a patch by gechi.it (Portage version: 2.1.3_rc7)
Diffstat (limited to 'app-arch/zoo')
-rw-r--r--app-arch/zoo/ChangeLog9
-rw-r--r--app-arch/zoo/files/digest-zoo-2.10-r46
-rw-r--r--app-arch/zoo/files/zoo-2.10-gentoo-fbsd.patch25
-rw-r--r--app-arch/zoo/zoo-2.10-r4.ebuild36
4 files changed, 75 insertions, 1 deletions
diff --git a/app-arch/zoo/ChangeLog b/app-arch/zoo/ChangeLog
index 33d435eee59c..13791928debb 100644
--- a/app-arch/zoo/ChangeLog
+++ b/app-arch/zoo/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-arch/zoo
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/zoo/ChangeLog,v 1.37 2007/05/25 17:50:52 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/zoo/ChangeLog,v 1.38 2007/07/14 15:07:59 drizzt Exp $
+
+*zoo-2.10-r4 (14 Jul 2007)
+
+ 14 Jul 2007; Timothy Redaelli <drizzt@gentoo.org>
+ +files/zoo-2.10-gentoo-fbsd.patch, +zoo-2.10-r4.ebuild:
+ Revision bump:
+ Add ~x86-fbsd keyword with a patch by gechi.it
25 May 2007; Tobias Scherbaum <dertobi123@gentoo.org> zoo-2.10-r3.ebuild:
ppc stable, bug #178986
diff --git a/app-arch/zoo/files/digest-zoo-2.10-r4 b/app-arch/zoo/files/digest-zoo-2.10-r4
new file mode 100644
index 000000000000..f0934af7ed78
--- /dev/null
+++ b/app-arch/zoo/files/digest-zoo-2.10-r4
@@ -0,0 +1,6 @@
+MD5 5de8e6d16ab168ef2f4e8db412068054 zoo-2.10-gcc-issues-fix.patch 19467
+RMD160 c58595ae3d5744b0d8dc38b6b0e1c66c370dd086 zoo-2.10-gcc-issues-fix.patch 19467
+SHA256 0215efd7aa218048f5f8bc085810f89cad6a9f710234f0d0e93be959a02f582b zoo-2.10-gcc-issues-fix.patch 19467
+MD5 70a0a785ecc8f7f747be1421e495d837 zoo-2.10pl1.tar.gz 172096
+RMD160 971d388b8cb29def1e4e31011463563e91c3d700 zoo-2.10pl1.tar.gz 172096
+SHA256 ad8d8fee5e524aca0e1e9a1e431c21cd59943d8373d5dffe4edca03a7e4284f4 zoo-2.10pl1.tar.gz 172096
diff --git a/app-arch/zoo/files/zoo-2.10-gentoo-fbsd.patch b/app-arch/zoo/files/zoo-2.10-gentoo-fbsd.patch
new file mode 100644
index 000000000000..64eabaf40586
--- /dev/null
+++ b/app-arch/zoo/files/zoo-2.10-gentoo-fbsd.patch
@@ -0,0 +1,25 @@
+--- sysv.c 2007-06-16 15:01:53 +0200
++++ sysv.c.new 2007-06-16 14:38:38 +0200
+@@ -63,8 +63,8 @@
+ return (fname); /* default is no-op */
+ }
+
+-extern long timezone; /* defined by library routine */
+-long time ();
++/*extern long timezone; defined by library routine */
++/* long time (); */
+ struct tm *localtime ();
+
+ /* Function gettz(), returns the offset from GMT in seconds of the
+--- zoo.h 2007-06-16 15:01:53 +0200
++++ zoo.h.new 2007-06-16 14:57:58 +0200
+@@ -95,6 +95,9 @@
+ #endif
+
+ typedef unsigned char uchar;
++typedef unsigned int uint;
++typedef unsigned long ulong;
++typedef unsigned short ushort;
+
+ /* WARNING: Static initialization in zooadd.c or zooext.c depends on the
+ order of fields in struct zoo_header */ \ No newline at end of file
diff --git a/app-arch/zoo/zoo-2.10-r4.ebuild b/app-arch/zoo/zoo-2.10-r4.ebuild
new file mode 100644
index 000000000000..e6d727f1b2ab
--- /dev/null
+++ b/app-arch/zoo/zoo-2.10-r4.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/zoo/zoo-2.10-r4.ebuild,v 1.1 2007/07/14 15:07:59 drizzt Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Manipulate archives of files in compressed form."
+HOMEPAGE="ftp://ftp.kiarchive.ru/pub/unix/arcers"
+SRC_URI="ftp://ftp.kiarchive.ru/pub/unix/arcers/${P}pl1.tar.gz
+ mirror://gentoo/${P}-gcc-issues-fix.patch"
+
+LICENSE="zoo"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+S=${WORKDIR}
+
+src_unpack() {
+ unpack ${A}
+ epatch "${DISTDIR}"/${P}-gcc-issues-fix.patch
+ epatch "${FILESDIR}"/${P}-CAN-2005-2349.patch
+ epatch "${FILESDIR}"/${P}-febz-183426.patch
+ epatch "${FILESDIR}"/${P}-security_pathsize.patch
+ epatch "${FILESDIR}"/${P}-multiple-dos-fix.patch
+ epatch "${FILESDIR}"/${P}-gentoo-fbsd.patch
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" linux || die
+}
+
+src_install() {
+ dobin zoo fiz || die
+ doman zoo.1 fiz.1
+}