summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2013-12-16 20:27:22 +0000
committerSergey Popov <pinkbyte@gentoo.org>2013-12-16 20:27:22 +0000
commite6abb9d2f8af08ac5f76678cf2578a2f2a658b45 (patch)
tree2c13955f0470d6a267c13f0677a9b06df1c4aed1 /app-arch/zopfli
parentAdd ~arm/~amd64-linux/~x86-linux keywords (diff)
downloadgentoo-2-e6abb9d2f8af08ac5f76678cf2578a2f2a658b45.tar.gz
gentoo-2-e6abb9d2f8af08ac5f76678cf2578a2f2a658b45.tar.bz2
gentoo-2-e6abb9d2f8af08ac5f76678cf2578a2f2a658b45.zip
New upstream snapshot, wrt bug #492608: epatch_user, simplify ebuild cause fixes went directly into buildsystem. Thanks to Alex Xu <alex_y_xu AT yahoo.ca> for fixes
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 0x1F357D42)
Diffstat (limited to 'app-arch/zopfli')
-rw-r--r--app-arch/zopfli/ChangeLog10
-rw-r--r--app-arch/zopfli/zopfli-1.0.0_p20131216.ebuild29
2 files changed, 38 insertions, 1 deletions
diff --git a/app-arch/zopfli/ChangeLog b/app-arch/zopfli/ChangeLog
index 80ec3ebc1275..c4863e89bea8 100644
--- a/app-arch/zopfli/ChangeLog
+++ b/app-arch/zopfli/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-arch/zopfli
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/zopfli/ChangeLog,v 1.3 2013/11/06 18:43:39 pinkbyte Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/zopfli/ChangeLog,v 1.4 2013/12/16 20:27:22 pinkbyte Exp $
+
+*zopfli-1.0.0_p20131216 (16 Dec 2013)
+
+ 16 Dec 2013; Sergey Popov <pinkbyte@gentoo.org>
+ +zopfli-1.0.0_p20131216.ebuild:
+ New upstream snapshot, wrt bug #492608: epatch_user, simplify ebuild cause
+ fixes went directly into buildsystem. Thanks to Alex Xu <alex_y_xu AT
+ yahoo.ca> for fixes
06 Nov 2013; Sergey Popov <pinkbyte@gentoo.org> zopfli-1.0.0.ebuild,
zopfli-1.0.0_p20130508-r1.ebuild:
diff --git a/app-arch/zopfli/zopfli-1.0.0_p20131216.ebuild b/app-arch/zopfli/zopfli-1.0.0_p20131216.ebuild
new file mode 100644
index 000000000000..a37663a67d37
--- /dev/null
+++ b/app-arch/zopfli/zopfli-1.0.0_p20131216.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/zopfli/zopfli-1.0.0_p20131216.ebuild,v 1.1 2013/12/16 20:27:22 pinkbyte Exp $
+
+EAPI="5"
+
+inherit eutils multilib toolchain-funcs
+
+DESCRIPTION="Compression library programmed in C to perform very good, but slow, deflate or zlib compression"
+HOMEPAGE="https://github.com/Hello71/zopfli/"
+SRC_URI="https://dev.gentoo.org/~pinkbyte/distfiles/snapshots/${P}.tar.bz2"
+
+LICENSE="Apache-2.0"
+SLOT="0/1"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ # Respect compiler
+ tc-export CC CXX
+
+ epatch_user
+}
+
+src_install() {
+ emake DESTDIR="${D}" prefix="${EPREFIX}/usr" libdir="${EPREFIX}/usr/$(get_libdir)" install
+ dodoc CONTRIBUTORS README README.${PN}png
+}