summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Vasilevski <yvasilev@gentoo.org>2009-11-25 14:14:22 +0000
committerYuri Vasilevski <yvasilev@gentoo.org>2009-11-25 14:14:22 +0000
commit4469e637c3907c78303854963fae3e0b34e35e60 (patch)
treee9738acd07920fbfa5b16feccda5f56979dd0568 /app-arch
parentamd64/x86 stable, bug #294404 (diff)
downloadgentoo-2-4469e637c3907c78303854963fae3e0b34e35e60.tar.gz
gentoo-2-4469e637c3907c78303854963fae3e0b34e35e60.tar.bz2
gentoo-2-4469e637c3907c78303854963fae3e0b34e35e60.zip
Replaced useless dpkg-1.15.1-nls patch with one that allows to select specific LINGUAS and fixed unicode flag support (previously was building with wide headers and linking with normal ncurces lib when USE=-unicode). Thanks to guillem@d.o for pointing some of this problems.
(Portage version: 2.1.7.5/cvs/Linux i686)
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/dpkg/ChangeLog12
-rw-r--r--app-arch/dpkg/dpkg-1.15.5.2-r1.ebuild61
-rw-r--r--app-arch/dpkg/files/dpkg-1.15.5-nls.patch12
-rw-r--r--app-arch/dpkg/files/dpkg-1.15.5-unicode.patch59
4 files changed, 143 insertions, 1 deletions
diff --git a/app-arch/dpkg/ChangeLog b/app-arch/dpkg/ChangeLog
index 52e66dfa6119..9d17f98e1551 100644
--- a/app-arch/dpkg/ChangeLog
+++ b/app-arch/dpkg/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for app-arch/dpkg
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/dpkg/ChangeLog,v 1.108 2009/11/18 15:52:14 yvasilev Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/dpkg/ChangeLog,v 1.109 2009/11/25 14:14:22 yvasilev Exp $
+
+*dpkg-1.15.5.2-r1 (25 Nov 2009)
+
+ 25 Nov 2009; Yuri Vasilevski <yvasilev@gentoo.org>
+ +dpkg-1.15.5.2-r1.ebuild, +files/dpkg-1.15.5-nls.patch,
+ +files/dpkg-1.15.5-unicode.patch:
+ Replaced useless dpkg-1.15.1-nls patch with one that allows to select
+ specific LINGUAS and fixed unicode flag support (previously was building
+ with wide headers and linking with normal ncurces lib when USE=-unicode).
+ Thanks to guillem@d.o for pointing some of this problems.
18 Nov 2009; Yuri Vasilevski <yvasilev@gentoo.org> -dpkg-1.15.5.1.ebuild:
Removed broken (due to lack of perl 5.10) version.
diff --git a/app-arch/dpkg/dpkg-1.15.5.2-r1.ebuild b/app-arch/dpkg/dpkg-1.15.5.2-r1.ebuild
new file mode 100644
index 000000000000..71a22112ff0f
--- /dev/null
+++ b/app-arch/dpkg/dpkg-1.15.5.2-r1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/dpkg/dpkg-1.15.5.2-r1.ebuild,v 1.1 2009/11/25 14:14:22 yvasilev Exp $
+
+inherit eutils multilib autotools
+
+DESCRIPTION="Package maintenance system for Debian"
+HOMEPAGE="http://packages.qa.debian.org/dpkg"
+SRC_URI="mirror://debian/pool/main/d/dpkg/${P/-/_}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~ppc ~s390 ~sh ~sparc ~x86"
+IUSE="bzip2 nls test unicode zlib"
+
+LANGS="de es fr hu ja pl pt_BR ru sv"
+for X in ${LANGS} ; do
+ IUSE="${IUSE} linguas_${X}"
+done
+
+RDEPEND=">=dev-lang/perl-5.6.0
+ dev-perl/TimeDate
+ >=sys-libs/ncurses-5.2-r7
+ zlib? ( >=sys-libs/zlib-1.1.4 )
+ bzip2? ( app-arch/bzip2 )"
+DEPEND="${RDEPEND}
+ nls? ( app-text/po4a )
+ test? ( dev-perl/Test-Pod dev-perl/IO-String )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-1.15.5-nls.patch
+ epatch "${FILESDIR}"/${PN}-1.15.5-unicode.patch
+ eautoreconf
+}
+
+src_compile() {
+ econf \
+ $(use_with bzip2 bz2) \
+ $(use_enable nls) \
+ $(use_enable unicode) \
+ $(use_with zlib) \
+ --without-selinux \
+ --without-start-stop-daemon \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ strip-linguas ${LANGS}
+ if [ -z "${LINGUAS}" ] ; then
+ LINGUAS=none
+ fi
+
+ emake DESTDIR="${D}" LINGUAS="${LINGUAS}" install || die "emake install failed"
+ rm "${D}"/usr/sbin/install-info || die "rm install-info failed"
+ dodoc ChangeLog INSTALL THANKS TODO
+ keepdir /usr/$(get_libdir)/db/methods/{mnt,floppy,disk}
+ keepdir /usr/$(get_libdir)/db/{alternatives,info,methods,parts,updates}
+}
diff --git a/app-arch/dpkg/files/dpkg-1.15.5-nls.patch b/app-arch/dpkg/files/dpkg-1.15.5-nls.patch
new file mode 100644
index 000000000000..88e7b79e3d55
--- /dev/null
+++ b/app-arch/dpkg/files/dpkg-1.15.5-nls.patch
@@ -0,0 +1,12 @@
+diff -Naurp dpkg-1.15.5.2.orig/man/Makefile.am dpkg-1.15.5.2/man/Makefile.am
+--- dpkg-1.15.5.2.orig/man/Makefile.am 2009-11-18 07:28:44.000000000 +0000
++++ dpkg-1.15.5.2/man/Makefile.am 2009-11-21 07:14:37.000000000 +0000
+@@ -36,7 +36,7 @@ update-po:
+ $(PO4A) $(PO4A_BUILD_OPTS) --force po/po4a.cfg
+
+ # Extract the list of languages from the po4a config file.
+-LINGUAS = `sed -ne 's/^.*\[po4a_langs\] \(.*\)$$/\1/p' $(srcdir)/po/po4a.cfg`
++LINGUAS := `sed -ne 's/^.*\[po4a_langs\] \(.*\)$$/\1/p' $(srcdir)/po/po4a.cfg`
+
+ install-data-local: install-data-local-@USE_PO4A@
+
diff --git a/app-arch/dpkg/files/dpkg-1.15.5-unicode.patch b/app-arch/dpkg/files/dpkg-1.15.5-unicode.patch
new file mode 100644
index 000000000000..1d257c036f1f
--- /dev/null
+++ b/app-arch/dpkg/files/dpkg-1.15.5-unicode.patch
@@ -0,0 +1,59 @@
+diff -Naurp dpkg-1.15.5.2.orig/m4/dpkg-libs.m4 dpkg-1.15.5.2/m4/dpkg-libs.m4
+--- dpkg-1.15.5.2.orig/m4/dpkg-libs.m4 2009-11-21 09:40:57.000000000 +0000
++++ dpkg-1.15.5.2/m4/dpkg-libs.m4 2009-11-21 09:37:55.000000000 +0000
+@@ -100,14 +100,23 @@ fi
+ # DPKG_LIB_CURSES
+ # ---------------
+ # Check for curses library.
+-AC_DEFUN([DPKG_LIB_CURSES],
+-[AC_ARG_VAR([CURSES_LIBS], [linker flags for curses library])dnl
+-AC_CHECK_HEADERS([ncursesw/ncurses.h ncurses/ncurses.h ncurses.h curses.h \
+- ncursesw/term.h ncurses/term.h term.h])
+-AC_CHECK_LIB([ncursesw], [initscr], [CURSES_LIBS="${CURSES_LIBS:+$CURSES_LIBS }-lncursesw"],
+- [AC_CHECK_LIB([ncurses], [initscr], [CURSES_LIBS="${CURSES_LIBS:+$CURSES_LIBS }-lncurses"],
++AC_DEFUN([DPKG_LIB_CURSES], [
++AC_REQUIRE([AM_UNICODE])
++AC_ARG_VAR([CURSES_LIBS], [linker flags for curses library])dnl
++if test "x$USE_UNICODE" = "xyes"; then
++ AC_CHECK_HEADERS([ncursesw/ncurses.h ncurses/ncurses.h ncurses.h curses.h \
++ ncursesw/term.h ncurses/term.h term.h])
++ AC_CHECK_LIB([ncursesw], [initscr], [CURSES_LIBS="${CURSES_LIBS:+$CURSES_LIBS }-lncursesw"],
++ [AC_CHECK_LIB([ncurses], [initscr], [CURSES_LIBS="${CURSES_LIBS:+$CURSES_LIBS }-lncurses"],
++ [AC_CHECK_LIB([curses], [initscr], [CURSES_LIBS="${CURSES_LIBS:+$CURSES_LIBS }-lcurses"],
++ [AC_MSG_WARN([no curses library found])])])])
++else
++ AC_CHECK_HEADERS([ncurses/ncurses.h ncurses.h curses.h \
++ ncurses/term.h term.h])
++ AC_CHECK_LIB([ncurses], [initscr], [CURSES_LIBS="${CURSES_LIBS:+$CURSES_LIBS }-lncurses"],
+ [AC_CHECK_LIB([curses], [initscr], [CURSES_LIBS="${CURSES_LIBS:+$CURSES_LIBS }-lcurses"],
+- [AC_MSG_WARN([no curses library found])])])])
++ [AC_MSG_WARN([no curses library found])])])
++fi
+ ])# DPKG_LIB_CURSES
+
+ # DPKG_LIB_SSD
+diff -Naurp dpkg-1.15.5.2.orig/m4/unicode.m4 dpkg-1.15.5.2/m4/unicode.m4
+--- dpkg-1.15.5.2.orig/m4/unicode.m4 1970-01-01 00:00:00.000000000 +0000
++++ dpkg-1.15.5.2/m4/unicode.m4 2009-11-21 09:46:53.000000000 +0000
+@@ -0,0 +1,21 @@
++# unicode.m4
++dnl Copyright (C) 2009 Free Software Foundation, Inc.
++dnl This file is free software; the Free Software Foundation
++dnl gives unlimited permission to copy and/or distribute it,
++dnl with or without modifications, as long as this notice is preserved.
++dnl
++dnl Author:
++dnl Yuri Vasilevski <yvasilev@gentoo.org>, 2009
++
++AC_PREREQ(2.50)
++
++AC_DEFUN([AM_UNICODE],
++[
++ AC_MSG_CHECKING([whether UNICODE is requested])
++ dnl Default: UNICODE is enabled
++ AC_ARG_ENABLE(unicode,
++ [ --disable-unicode do not use Unicode (wide characters) support],
++ USE_UNICODE=$enableval, USE_UNICODE=yes)
++ AC_MSG_RESULT($USE_UNICODE)
++ AC_SUBST(USE_UNICODE)
++])