summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-05-13 02:25:39 +0000
committerMike Frysinger <vapier@gentoo.org>2005-05-13 02:25:39 +0000
commit5f87b9b0100ced2a7e1cc1ef6ad5dba0f577d700 (patch)
treeea8f046f1b45252b2b4426747d96385eb4cb7584 /app-arch
parentmake sure we fix the symlinked binaries (diff)
downloadgentoo-2-5f87b9b0100ced2a7e1cc1ef6ad5dba0f577d700.tar.gz
gentoo-2-5f87b9b0100ced2a7e1cc1ef6ad5dba0f577d700.tar.bz2
gentoo-2-5f87b9b0100ced2a7e1cc1ef6ad5dba0f577d700.zip
Install the shared version of bzip into / along with libbz2.so.
(Portage version: 2.0.51.21-r1)
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/bzip2/ChangeLog7
-rw-r--r--app-arch/bzip2/bzip2-1.0.3-r1.ebuild76
-rw-r--r--app-arch/bzip2/files/digest-bzip2-1.0.3-r11
3 files changed, 83 insertions, 1 deletions
diff --git a/app-arch/bzip2/ChangeLog b/app-arch/bzip2/ChangeLog
index bdeabbff68b9..ff173f37c9ab 100644
--- a/app-arch/bzip2/ChangeLog
+++ b/app-arch/bzip2/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-arch/bzip2
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/bzip2/ChangeLog,v 1.22 2005/04/06 23:04:03 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/bzip2/ChangeLog,v 1.23 2005/05/13 02:25:39 vapier Exp $
+
+*bzip2-1.0.3-r1 (13 May 2005)
+
+ 13 May 2005; Mike Frysinger <vapier@gentoo.org> +bzip2-1.0.3-r1.ebuild:
+ Install the shared version of bzip into / along with libbz2.so.
*bzip2-1.0.3 (06 Apr 2005)
diff --git a/app-arch/bzip2/bzip2-1.0.3-r1.ebuild b/app-arch/bzip2/bzip2-1.0.3-r1.ebuild
new file mode 100644
index 000000000000..2b446e667679
--- /dev/null
+++ b/app-arch/bzip2/bzip2-1.0.3-r1.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/bzip2/bzip2-1.0.3-r1.ebuild,v 1.1 2005/05/13 02:25:39 vapier Exp $
+
+inherit multilib toolchain-funcs flag-o-matic
+
+DESCRIPTION="A high-quality data compressor used extensively by Gentoo Linux"
+HOMEPAGE="http://www.bzip.org/"
+SRC_URI="http://www.bzip.org/${PV}/${P}.tar.gz"
+
+LICENSE="BZIP2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="build static"
+
+DEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-1.0.2-NULL-ptr-check.patch
+ epatch "${FILESDIR}"/${P}-makefile-CFLAGS.patch
+ epatch "${FILESDIR}"/${P}-saneso.patch
+ epatch "${FILESDIR}"/${PN}-1.0.2-progress.patch
+ sed -i -e 's:\$(PREFIX)/man:\$(PREFIX)/share/man:g' Makefile || die "sed manpath"
+
+ use static && append-flags -static
+
+ # - Generate symlinks instead of hardlinks
+ # - pass custom variables to control libdir
+ sed -i \
+ -e 's:ln $(PREFIX)/bin/:ln -s :' \
+ -e 's:$(PREFIX)/lib:$(PREFIX)/$(LIBDIR):g' \
+ Makefile || die "sed links"
+
+ # bzip2 will to run itself after it has built itself which we
+ # can't do if we are cross compiling. -solar
+ if [[ -x /bin/bzip2 ]] && tc-is-cross-compiler ; then
+ sed -i -e 's:./bzip2 -:bzip2 -:g' Makefile || die "sed cross-compile"
+ fi
+}
+
+src_compile() {
+ local makeopts="
+ CC=$(tc-getCC)
+ AR=$(tc-getAR)
+ RANLIB=$(tc-getRANLIB)
+ "
+ if ! use build ; then
+ emake ${makeopts} -f Makefile-libbz2_so all || die "Make failed libbz2"
+ fi
+ emake ${makeopts} all || die "Make failed"
+}
+
+src_install() {
+ if ! use build ; then
+ make PREFIX="${D}"/usr LIBDIR=$(get_libdir) install || die
+
+ # move bzip2 binaries to / and use the shared libbz2.so
+ mv "${D}"/usr/bin "${D}"/
+ into /
+ newbin bzip2-shared bzip2 || die "dobin shared"
+ dolib.so "${S}"/libbz2.so.${PV} || die "dolib shared"
+ for v in ${PV%%.*} ${PV%.*} ; do
+ dosym libbz2.so.${PV} /$(get_libdir)/libbz2.so.${v}
+ done
+
+ dodoc README* CHANGES Y2K_INFO bzip2.txt manual.*
+ else
+ into /
+ dobin bzip2 || die "dobin bzip2"
+ fi
+
+ dosym bzip2 /bin/bzcat
+ dosym bzip2 /bin/bunzip2
+}
diff --git a/app-arch/bzip2/files/digest-bzip2-1.0.3-r1 b/app-arch/bzip2/files/digest-bzip2-1.0.3-r1
new file mode 100644
index 000000000000..24bf9c7e285a
--- /dev/null
+++ b/app-arch/bzip2/files/digest-bzip2-1.0.3-r1
@@ -0,0 +1 @@
+MD5 8a716bebecb6e647d2e8a29ea5d8447f bzip2-1.0.3.tar.gz 669075