summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2008-11-17 07:43:54 +0000
committerJeroen Roovers <jer@gentoo.org>2008-11-17 07:43:54 +0000
commit79cbef1da8ac67dc46773745a25af272575eaca9 (patch)
treeb1701247a1bfa00e2491da1fa0aae3064053ce02 /app-arch
parentSay thanks. (diff)
downloadgentoo-2-79cbef1da8ac67dc46773745a25af272575eaca9.tar.gz
gentoo-2-79cbef1da8ac67dc46773745a25af272575eaca9.tar.bz2
gentoo-2-79cbef1da8ac67dc46773745a25af272575eaca9.zip
Version bump (bug #246810 comment #4).
(Portage version: 2.2_rc14/cvs/Linux 2.6.25-gentoo-r7-JeR i686)
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/pbzip2/ChangeLog8
-rw-r--r--app-arch/pbzip2/files/pbzip2-1.0.3-uclibc.patch23
-rw-r--r--app-arch/pbzip2/pbzip2-1.0.3.ebuild40
3 files changed, 70 insertions, 1 deletions
diff --git a/app-arch/pbzip2/ChangeLog b/app-arch/pbzip2/ChangeLog
index 50c29febb6ef..66435e2919cf 100644
--- a/app-arch/pbzip2/ChangeLog
+++ b/app-arch/pbzip2/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-arch/pbzip2
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/pbzip2/ChangeLog,v 1.51 2008/11/17 07:23:00 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/pbzip2/ChangeLog,v 1.52 2008/11/17 07:43:54 jer Exp $
+
+*pbzip2-1.0.3 (17 Nov 2008)
+
+ 17 Nov 2008; Jeroen Roovers <jer@gentoo.org>
+ +files/pbzip2-1.0.3-uclibc.patch, +pbzip2-1.0.3.ebuild:
+ Version bump (bug #246810 comment #4).
17 Nov 2008; Jeroen Roovers <jer@gentoo.org>
+files/pbzip2-1.0.2-uclibc.patch, pbzip2-1.0.2-r1.ebuild:
diff --git a/app-arch/pbzip2/files/pbzip2-1.0.3-uclibc.patch b/app-arch/pbzip2/files/pbzip2-1.0.3-uclibc.patch
new file mode 100644
index 000000000000..522dc54da1a4
--- /dev/null
+++ b/app-arch/pbzip2/files/pbzip2-1.0.3-uclibc.patch
@@ -0,0 +1,23 @@
+--- pbzip2-1.0.3/pbzip2.cpp.orig 2008-10-31 16:43:33.000000000 +0100
++++ pbzip2-1.0.3/pbzip2.cpp 2008-11-17 08:31:25.000000000 +0100
+@@ -136,7 +136,7 @@
+ //#define PBZIP_NO_LOADAVG
+
+ // detect systems that are known not to support load average code
+-#if defined (WIN32) || defined (__CYGWIN32__) || defined (__MINGW32__) || defined (__BORLANDC__) || defined (__hpux) || defined (__osf__)
++#if defined (WIN32) || defined (__CYGWIN32__) || defined (__MINGW32__) || defined (__BORLANDC__) || defined (__hpux) || defined (__osf__) || defined(__UCLIBC__)
+ #define PBZIP_NO_LOADAVG
+ #endif
+
+@@ -1917,7 +1917,11 @@
+ {
+ banner();
+ fprintf(stderr, "\nInvalid command line: %s. Aborting...\n\n", reason);
++#ifndef PBZIP_NO_LOADAVG
+ fprintf(stderr, "Usage: %s [-1 .. -9] [-b#cdfklp#qrtV] <filename> <filename2> <filenameN>\n", progname);
++#else
++ fprintf(stderr, "Usage: %s [-1 .. -9] [-b#cdfkp#qrtV] <filename> <filename2> <filenameN>\n", progname);
++#endif
+ fprintf(stderr, " -b# : where # is the file block size in 100k (default 9 = 900k)\n");
+ fprintf(stderr, " -c : output to standard out (stdout)\n");
+ fprintf(stderr, " -d : decompress file\n");
diff --git a/app-arch/pbzip2/pbzip2-1.0.3.ebuild b/app-arch/pbzip2/pbzip2-1.0.3.ebuild
new file mode 100644
index 000000000000..3a9938c8026e
--- /dev/null
+++ b/app-arch/pbzip2/pbzip2-1.0.3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/pbzip2/pbzip2-1.0.3.ebuild,v 1.1 2008/11/17 07:43:54 jer Exp $
+
+inherit multilib eutils
+
+DESCRIPTION="parallel bzip2 (de)compressor using libbz2"
+HOMEPAGE="http://compression.ca/pbzip2/"
+SRC_URI="http://compression.ca/${PN}/${P}.tar.gz"
+
+LICENSE="PBZIP2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="static"
+
+DEPEND="app-arch/bzip2"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ sed -e 's:^CFLAGS = .*$:#&:g' -e 's:g++:$(CXX):g' -i ${P}/Makefile || die
+ epatch "${FILESDIR}"/${P}-uclibc.patch
+}
+
+src_compile() {
+ tc-export CXX
+ if use static ; then
+ cp -f /usr/$(get_libdir)/libbz2.a "${S}"
+ emake pbzip2-static || die "Failed to build"
+ else
+ emake pbzip2 || die "Failed to build"
+ fi
+}
+
+src_install() {
+ dobin pbzip2 || die "Failed to install"
+ dodoc AUTHORS ChangeLog README
+ doman pbzip2.1 || die "Failed to install man page"
+ dosym /usr/bin/pbzip2 /usr/bin/pbunzip2
+}