summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Callen <abcd@gentoo.org>2010-02-19 22:18:01 +0000
committerJonathan Callen <abcd@gentoo.org>2010-02-19 22:18:01 +0000
commit99c157e1041d79027601da86df4905579304932e (patch)
tree4e38c6a794d0fa02e534aa1f83bf2a3e3381a532 /app-arch
parentFix up bug 297146 for documentation location. And add new revision for the pe... (diff)
downloadgentoo-2-99c157e1041d79027601da86df4905579304932e.tar.gz
gentoo-2-99c157e1041d79027601da86df4905579304932e.tar.bz2
gentoo-2-99c157e1041d79027601da86df4905579304932e.zip
Add prefix keywords, bump to EAPI-3, prefix fixes
(Portage version: -svn/cvs/Linux i686)
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/dpkg/ChangeLog5
-rw-r--r--app-arch/dpkg/dpkg-1.15.5.6-r1.ebuild26
2 files changed, 20 insertions, 11 deletions
diff --git a/app-arch/dpkg/ChangeLog b/app-arch/dpkg/ChangeLog
index deb49b156e2b..d55179a4593e 100644
--- a/app-arch/dpkg/ChangeLog
+++ b/app-arch/dpkg/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-arch/dpkg
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/dpkg/ChangeLog,v 1.117 2010/02/05 08:18:47 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/dpkg/ChangeLog,v 1.118 2010/02/19 22:18:01 abcd Exp $
+
+ 19 Feb 2010; Jonathan Callen <abcd@gentoo.org> dpkg-1.15.5.6-r1.ebuild:
+ Add prefix keywords, bump to EAPI-3, prefix fixes
05 Feb 2010; Jeroen Roovers <jer@gentoo.org> -dpkg-1.15.3.ebuild,
-dpkg-1.15.3.1.ebuild, -dpkg-1.15.4.ebuild, -dpkg-1.15.4.1.ebuild,
diff --git a/app-arch/dpkg/dpkg-1.15.5.6-r1.ebuild b/app-arch/dpkg/dpkg-1.15.5.6-r1.ebuild
index e59d48419722..63d8276b5b72 100644
--- a/app-arch/dpkg/dpkg-1.15.5.6-r1.ebuild
+++ b/app-arch/dpkg/dpkg-1.15.5.6-r1.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/dpkg/dpkg-1.15.5.6-r1.ebuild,v 1.1 2010/02/05 08:14:53 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/dpkg/dpkg-1.15.5.6-r1.ebuild,v 1.2 2010/02/19 22:18:01 abcd Exp $
+
+EAPI=3
inherit eutils multilib autotools
@@ -10,7 +12,7 @@ SRC_URI="mirror://debian/pool/main/d/${PN}/${P/-/_}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-solaris ~x86-solaris"
IUSE="bzip2 nls test unicode zlib"
LANGS="de es fr hu ja pl pt_BR ru sv"
@@ -27,25 +29,29 @@ DEPEND="${RDEPEND}
nls? ( app-text/po4a )
test? ( dev-perl/Test-Pod dev-perl/IO-String )"
-src_unpack() {
- unpack ${A}
- cd "${S}"
+src_prepare() {
epatch "${FILESDIR}"/${PN}-1.15.5-nls.patch
epatch "${FILESDIR}"/${PN}-1.15.5-unicode.patch
epatch "${FILESDIR}"/${PN}-1.15.5.6-bootstrap.patch
+
+ # don't mess with linker optimisation, respect user's flags (don't break!)
+ sed -i -e '/DPKG_LINKER_OPTIMISATIONS/d' configure.ac || die
+
+ # Force the use of the running bash for get-version (this file is never
+ # installed, so no need to worry about hardcoding a temporary bash)
+ sed -i -e '1c\#!'"${BASH}" get-version || die
+
eautoreconf
}
-src_compile() {
+src_configure() {
econf \
$(use_with bzip2 bz2) \
$(use_enable nls) \
$(use_enable unicode) \
$(use_with zlib) \
--without-selinux \
- --without-start-stop-daemon \
- || die "econf failed"
- emake || die "emake failed"
+ --without-start-stop-daemon
}
src_install() {
@@ -55,7 +61,7 @@ src_install() {
fi
emake DESTDIR="${D}" LINGUAS="${LINGUAS}" install || die "emake install failed"
- rm "${D}"/usr/sbin/install-info || die "rm install-info failed"
+ rm "${ED}"/usr/sbin/install-info || die "rm install-info failed"
dodoc ChangeLog INSTALL THANKS TODO
keepdir /usr/$(get_libdir)/db/methods/{mnt,floppy,disk}
keepdir /usr/$(get_libdir)/db/{alternatives,info,methods,parts,updates}