summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2014-12-26 18:13:08 +0000
committerMichał Górny <mgorny@gentoo.org>2014-12-26 18:13:08 +0000
commitaa215c8331ee9ca6c25d30561c56fcd5b9566da9 (patch)
treed5ebce8e4832c553e7577a498d36b26f8210ec03 /app-arch
parentarm stable, bug #532636 (diff)
downloadgentoo-2-aa215c8331ee9ca6c25d30561c56fcd5b9566da9.tar.gz
gentoo-2-aa215c8331ee9ca6c25d30561c56fcd5b9566da9.tar.bz2
gentoo-2-aa215c8331ee9ca6c25d30561c56fcd5b9566da9.zip
Convert to distutils-r1.
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/ipkg-utils/ChangeLog10
-rw-r--r--app-arch/ipkg-utils/ipkg-utils-1.7.050831-r2.ebuild64
2 files changed, 72 insertions, 2 deletions
diff --git a/app-arch/ipkg-utils/ChangeLog b/app-arch/ipkg-utils/ChangeLog
index 8928fb46ffe6..a3bcea20bbd9 100644
--- a/app-arch/ipkg-utils/ChangeLog
+++ b/app-arch/ipkg-utils/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-arch/ipkg-utils
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/ipkg-utils/ChangeLog,v 1.18 2013/03/17 15:18:37 hwoarang Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/ipkg-utils/ChangeLog,v 1.19 2014/12/26 18:13:08 mgorny Exp $
+
+*ipkg-utils-1.7.050831-r2 (26 Dec 2014)
+
+ 26 Dec 2014; Michał Górny <mgorny@gentoo.org>
+ +ipkg-utils-1.7.050831-r2.ebuild:
+ Convert to distutils-r1.
17 Mar 2013; Markos Chandras <hwoarang@gentoo.org> metadata.xml:
Add proxy-maintainers to metadata.xml
diff --git a/app-arch/ipkg-utils/ipkg-utils-1.7.050831-r2.ebuild b/app-arch/ipkg-utils/ipkg-utils-1.7.050831-r2.ebuild
new file mode 100644
index 000000000000..45d00e467acd
--- /dev/null
+++ b/app-arch/ipkg-utils/ipkg-utils-1.7.050831-r2.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/ipkg-utils/ipkg-utils-1.7.050831-r2.ebuild,v 1.1 2014/12/26 18:13:08 mgorny Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 eutils toolchain-funcs versionator
+
+MY_P="${PN}-$(get_version_component_range 3)"
+
+DESCRIPTION="Tools for working with the ipkg binary package format"
+HOMEPAGE="http://www.openembedded.org/"
+SRC_URI="http://handhelds.org/download/packages/ipkg-utils/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~mips ~ppc ~x86"
+IUSE="minimal"
+
+DEPEND="
+ !minimal? (
+ app-crypt/gnupg
+ net-misc/curl
+ )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-tar_call_fixes.patch"
+ epatch "${FILESDIR}/${P}-hashlib.patch"
+
+ sed '/python setup.py build/d' -i Makefile
+
+ if use minimal; then
+ elog "ipkg-upload is not installed when the \`minimal' USE flag is set. If you"
+ elog "need ipkg-upload then rebuild this package without the \`minimal' USE flag."
+ fi
+}
+
+src_compile() {
+ distutils-r1_src_compile
+ emake CC="$(tc-getCC)" || die "emake failed"
+}
+
+python_install() {
+ distutils-r1_python_install
+
+ if use minimal; then
+ rm "${ED}usr/bin/ipkg-upload" \
+ "${D}$(python_get_scriptdir)/ipkg-upload" || die
+ fi
+}
+
+src_install() {
+ distutils-r1_src_install
+}
+
+pkg_postinst() {
+ elog "Consider installing sys-apps/fakeroot for use with the ipkg-build command,"
+ elog "that makes it possible to build packages as a normal user."
+}