summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimothy Redaelli <drizzt@gentoo.org>2007-10-04 09:53:45 +0000
committerTimothy Redaelli <drizzt@gentoo.org>2007-10-04 09:53:45 +0000
commitd9d37d60e692573760443bec47a760119bbac9eb (patch)
treed27a26b706c5686c22733e480b2291d5e328f765 /app-arch
parentFixed typo. (diff)
downloadgentoo-2-d9d37d60e692573760443bec47a760119bbac9eb.tar.gz
gentoo-2-d9d37d60e692573760443bec47a760119bbac9eb.tar.bz2
gentoo-2-d9d37d60e692573760443bec47a760119bbac9eb.zip
Version bump
(Portage version: 2.1.3.11)
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/libarchive/ChangeLog7
-rw-r--r--app-arch/libarchive/files/digest-libarchive-2.3.33
-rw-r--r--app-arch/libarchive/libarchive-2.3.3.ebuild81
3 files changed, 90 insertions, 1 deletions
diff --git a/app-arch/libarchive/ChangeLog b/app-arch/libarchive/ChangeLog
index 117584da7bae..8bcf441af5b8 100644
--- a/app-arch/libarchive/ChangeLog
+++ b/app-arch/libarchive/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-arch/libarchive
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/libarchive/ChangeLog,v 1.2 2007/07/14 13:24:41 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/libarchive/ChangeLog,v 1.3 2007/10/04 09:53:45 drizzt Exp $
+
+*libarchive-2.3.3 (04 Oct 2007)
+
+ 04 Oct 2007; <drizzt@gentoo.org> +libarchive-2.3.3.ebuild:
+ Version bump
*libarchive-2.2.5 (14 Jul 2007)
diff --git a/app-arch/libarchive/files/digest-libarchive-2.3.3 b/app-arch/libarchive/files/digest-libarchive-2.3.3
new file mode 100644
index 000000000000..847a38b57de4
--- /dev/null
+++ b/app-arch/libarchive/files/digest-libarchive-2.3.3
@@ -0,0 +1,3 @@
+MD5 309db348a2274db8ba2bb7a2578cf998 libarchive-2.3.3.tar.gz 673965
+RMD160 0e764b36b26fafac763d059b49f44749b44b9dfa libarchive-2.3.3.tar.gz 673965
+SHA256 30abee01050fd46048537f3ad689a88a460de6b0108736fd197392669feaa898 libarchive-2.3.3.tar.gz 673965
diff --git a/app-arch/libarchive/libarchive-2.3.3.ebuild b/app-arch/libarchive/libarchive-2.3.3.ebuild
new file mode 100644
index 000000000000..e5c763d5d275
--- /dev/null
+++ b/app-arch/libarchive/libarchive-2.3.3.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/libarchive/libarchive-2.3.3.ebuild,v 1.1 2007/10/04 09:53:45 drizzt Exp $
+
+inherit eutils autotools toolchain-funcs flag-o-matic
+
+MY_P="${P/_beta/b}"
+
+DESCRIPTION="BSD tar command"
+HOMEPAGE="http://people.freebsd.org/~kientzle/libarchive/"
+SRC_URI="http://people.freebsd.org/~kientzle/libarchive/src/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="build static acl xattr"
+
+RDEPEND="!dev-libs/libarchive
+ kernel_linux? (
+ acl? ( sys-apps/acl )
+ xattr? ( sys-apps/attr )
+ )
+ !static? ( !build? (
+ app-arch/bzip2
+ sys-libs/zlib ) )"
+DEPEND="${RDEPEND}
+ kernel_linux? ( sys-fs/e2fsprogs
+ virtual/os-headers )"
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${PN}-2.1.5-acl.patch
+
+ eautoreconf
+ epunt_cxx
+}
+
+src_compile() {
+ local myconf
+
+ if use static || use build ; then
+ myconf="${myconf} --enable-static-bsdtar"
+ else
+ myconf="${myconf} --disable-static-bsdtar"
+ fi
+
+ # Upstream doesn't seem to care to fix the problems
+ # and I don't want to continue running after them.
+ #append-flags -fno-strict-aliasing
+
+ econf \
+ --bindir=/bin \
+ $(use_enable acl) \
+ $(use_enable xattr) \
+ ${myconf} || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake -j1 DESTDIR="${D}" install || die "emake install failed"
+
+ # Create tar symlink for FreeBSD
+ if [[ ${CHOST} == *-freebsd* ]]; then
+ dosym bsdtar /bin/tar
+ dosym bsdtar.1 /usr/share/man/man1/tar.1
+ fi
+
+ if use build; then
+ rm -rf "${D}"/usr
+ rm -rf "${D}"/lib/*.so*
+ return 0
+ fi
+
+ dodir /$(get_libdir)
+ mv "${D}"/usr/$(get_libdir)/*.so* "${D}"/$(get_libdir)
+ gen_usr_ldscript libarchive.so
+}