summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-03-20 03:37:00 +0000
committerMike Frysinger <vapier@gentoo.org>2006-03-20 03:37:00 +0000
commitedc4f04ead2da8fba6ee26d8a5d0571bc4590396 (patch)
treeea7165ff2ae08c170f542ff779276b9b80026999 /app-arch
parenttouchup style (diff)
downloadgentoo-2-edc4f04ead2da8fba6ee26d8a5d0571bc4590396.tar.gz
gentoo-2-edc4f04ead2da8fba6ee26d8a5d0571bc4590396.tar.bz2
gentoo-2-edc4f04ead2da8fba6ee26d8a5d0571bc4590396.zip
fix by Diego Pettenò to respect custom LDFLAGS #126831
(Portage version: 2.1_pre6-r3)
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/unzip/unzip-5.52-r1.ebuild13
1 files changed, 8 insertions, 5 deletions
diff --git a/app-arch/unzip/unzip-5.52-r1.ebuild b/app-arch/unzip/unzip-5.52-r1.ebuild
index 866ba25dc6bc..e780bc71a739 100644
--- a/app-arch/unzip/unzip-5.52-r1.ebuild
+++ b/app-arch/unzip/unzip-5.52-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/unzip/unzip-5.52-r1.ebuild,v 1.5 2006/02/15 05:29:16 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/unzip/unzip-5.52-r1.ebuild,v 1.6 2006/03/20 03:37:00 vapier Exp $
inherit eutils toolchain-funcs flag-o-matic
@@ -19,13 +19,15 @@ src_unpack() {
unpack ${A}
cd "${S}"
epatch "${FILESDIR}"/${P}-no-exec-stack.patch
- append-lfs-flags #104315
sed -i \
- -e "s:-O3:${CFLAGS}:" \
+ -e 's:-O3:$(CFLAGS):' \
+ -e 's:-O :$(CFLAGS) :' \
-e "s:CC=gcc :CC=$(tc-getCC) :" \
-e "s:LD=gcc :LD=$(tc-getCC) :" \
- -e "s:-O :${CFLAGS} :" \
- -e "s:LF2 = -s:LF2 = :" \
+ -e 's:LF2 = -s:LF2 = :' \
+ -e 's:LF = :LF = $(LDFLAGS) :' \
+ -e 's:SL = :SL = $(LDFLAGS) :' \
+ -e 's:FL = :FL = $(LDFLAGS) :' \
unix/Makefile \
|| die "sed unix/Makefile failed"
}
@@ -41,6 +43,7 @@ src_compile() {
*-darwin*) TARGET=macosx ;;
*) die "Unknown target, you suck" ;;
esac
+ append-lfs-flags #104315
emake -f unix/Makefile ${TARGET} || die "emake failed"
}