summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Gaffney <agaffney@gentoo.org>2009-09-05 18:30:49 +0000
committerAndrew Gaffney <agaffney@gentoo.org>2009-09-05 18:30:49 +0000
commitef68b1b0b2f0f914103cf37955a0d0e791262739 (patch)
treeb9220eb27474e6ec2b2fcde088d41d0ca23de28d /app-arch
parentFix QA notice per bug #283311, replace $(use_with exif) by $(use_with exif li... (diff)
downloadgentoo-2-ef68b1b0b2f0f914103cf37955a0d0e791262739.tar.gz
gentoo-2-ef68b1b0b2f0f914103cf37955a0d0e791262739.tar.bz2
gentoo-2-ef68b1b0b2f0f914103cf37955a0d0e791262739.zip
Revbump app-arch/pbzip2 to apply patch from bug #277539 for USE=symlink
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/pbzip2/ChangeLog7
-rw-r--r--app-arch/pbzip2/pbzip2-1.0.5-r2.ebuild47
2 files changed, 53 insertions, 1 deletions
diff --git a/app-arch/pbzip2/ChangeLog b/app-arch/pbzip2/ChangeLog
index be5d8faaa3e5..1c41dcdf0f21 100644
--- a/app-arch/pbzip2/ChangeLog
+++ b/app-arch/pbzip2/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-arch/pbzip2
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/pbzip2/ChangeLog,v 1.73 2009/08/09 18:13:06 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/pbzip2/ChangeLog,v 1.74 2009/09/05 18:30:49 agaffney Exp $
+
+*pbzip2-1.0.5-r2 (05 Sep 2009)
+
+ 05 Sep 2009; Andrew Gaffney <agaffney@gentoo.org> +pbzip2-1.0.5-r2.ebuild:
+ Revbump app-arch/pbzip2 to apply patch from bug #277539 for USE=symlink
09 Aug 2009; Jeroen Roovers <jer@gentoo.org> -pbzip2-1.0.5.ebuild:
Remove old.
diff --git a/app-arch/pbzip2/pbzip2-1.0.5-r2.ebuild b/app-arch/pbzip2/pbzip2-1.0.5-r2.ebuild
new file mode 100644
index 000000000000..c6c484fa5f53
--- /dev/null
+++ b/app-arch/pbzip2/pbzip2-1.0.5-r2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/pbzip2/pbzip2-1.0.5-r2.ebuild,v 1.1 2009/09/05 18:30:49 agaffney Exp $
+
+EAPI=2
+
+inherit multilib eutils
+
+DESCRIPTION="parallel bzip2 (de)compressor using libbz2"
+HOMEPAGE="http://compression.ca/pbzip2/"
+SRC_URI="http://compression.ca/${PN}/${P}.tar.gz"
+
+LICENSE="PBZIP2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="static symlink"
+
+DEPEND="app-arch/bzip2"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ sed -e 's:^CFLAGS = .*$:#&:g' -e 's:g++:$(CXX):g' -i Makefile || die 'sed failed'
+ epatch "${FILESDIR}"/${P}-ldflags.patch
+}
+
+src_compile() {
+ tc-export CXX
+ if use static ; then
+ cp -f /usr/$(get_libdir)/libbz2.a "${S}"
+ emake pbzip2-static || die "Failed to build"
+ else
+ emake pbzip2 || die "Failed to build"
+ fi
+}
+
+src_install() {
+ dobin pbzip2 || die "Failed to install"
+ dodoc AUTHORS ChangeLog README
+ doman pbzip2.1 || die "Failed to install man page"
+ dosym /usr/bin/pbzip2 /usr/bin/pbunzip2
+
+ if use symlink; then
+ dosym /usr/bin/pbzip2 /usr/bin/bzip2
+ dosym /usr/bin/pbzip2 /usr/bin/bunzip2
+ dosym /usr/bin/pbzip2 /usr/bin/bzcat
+ fi
+}