summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2011-01-05 16:17:30 +0000
committerMichał Górny <mgorny@gentoo.org>2011-01-05 16:17:30 +0000
commitfcf06bb65be4fbd9c6aafad8e30b88207123a640 (patch)
tree7332d1cbbb38297d609677f66475a112a8041368 /app-arch
parentStable on amd64 wrt bug #346189 (diff)
downloadgentoo-2-fcf06bb65be4fbd9c6aafad8e30b88207123a640.tar.gz
gentoo-2-fcf06bb65be4fbd9c6aafad8e30b88207123a640.tar.bz2
gentoo-2-fcf06bb65be4fbd9c6aafad8e30b88207123a640.zip
New ebuild for zpipe (ZPAQ pipe compressor) per bug #350631.
(Portage version: 2.2.0_alpha12_p8/cvs/Linux x86_64)
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/zpipe/ChangeLog10
-rw-r--r--app-arch/zpipe/metadata.xml9
-rw-r--r--app-arch/zpipe/zpipe-2.01.ebuild28
3 files changed, 47 insertions, 0 deletions
diff --git a/app-arch/zpipe/ChangeLog b/app-arch/zpipe/ChangeLog
new file mode 100644
index 000000000000..e80e22905ea7
--- /dev/null
+++ b/app-arch/zpipe/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for app-arch/zpipe
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/zpipe/ChangeLog,v 1.1 2011/01/05 16:17:30 mgorny Exp $
+
+*zpipe-2.01 (05 Jan 2011)
+
+ 05 Jan 2011; Michał Górny <mgorny@gentoo.org> +zpipe-2.01.ebuild,
+ +metadata.xml:
+ New ebuild for zpipe (ZPAQ pipe compressor) per bug #350631.
+
diff --git a/app-arch/zpipe/metadata.xml b/app-arch/zpipe/metadata.xml
new file mode 100644
index 000000000000..af81389004c1
--- /dev/null
+++ b/app-arch/zpipe/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>no-herd</herd>
+ <maintainer>
+ <email>mgorny@gentoo.org</email>
+ <name>Michał Górny</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/app-arch/zpipe/zpipe-2.01.ebuild b/app-arch/zpipe/zpipe-2.01.ebuild
new file mode 100644
index 000000000000..cb5b48378584
--- /dev/null
+++ b/app-arch/zpipe/zpipe-2.01.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/zpipe/zpipe-2.01.ebuild,v 1.1 2011/01/05 16:17:30 mgorny Exp $
+
+EAPI=3
+inherit toolchain-funcs
+
+MY_P=${PN}.${PV/./}
+DESCRIPTION="Pipe compressor/decompressor for ZPAQ"
+HOMEPAGE="http://mattmahoney.net/dc/zpaq.html"
+SRC_URI="http://mattmahoney.net/dc/${MY_P}.zip"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="app-arch/libzpaq"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+src_compile() {
+ emake CXX=$(tc-getCXX) LDLIBS=-lzpaq ${PN} || die
+}
+
+src_install() {
+ dobin ${PN} || die
+}