summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2013-02-26 23:00:38 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2013-02-26 23:00:38 +0000
commit6efa67c7258f1f4cb29ee8dfb62fecf0a509e5f3 (patch)
tree284a1b358d9afb3a035dded3a0d02a4fc961db2a /app-backup/amanda/amanda-3.3.1.ebuild
parentIntroduce a meta-package using multilib-capable ebuilds. (diff)
downloadgentoo-2-6efa67c7258f1f4cb29ee8dfb62fecf0a509e5f3.tar.gz
gentoo-2-6efa67c7258f1f4cb29ee8dfb62fecf0a509e5f3.tar.bz2
gentoo-2-6efa67c7258f1f4cb29ee8dfb62fecf0a509e5f3.zip
Bug #376169: avoid blkid writes from /usr/sbin/dump testing.
(Portage version: 2.2.0_alpha163/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'app-backup/amanda/amanda-3.3.1.ebuild')
-rw-r--r--app-backup/amanda/amanda-3.3.1.ebuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/app-backup/amanda/amanda-3.3.1.ebuild b/app-backup/amanda/amanda-3.3.1.ebuild
index c7afef32c423..721e77994472 100644
--- a/app-backup/amanda/amanda-3.3.1.ebuild
+++ b/app-backup/amanda/amanda-3.3.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-backup/amanda/amanda-3.3.1.ebuild,v 1.7 2013/02/26 22:38:33 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-backup/amanda/amanda-3.3.1.ebuild,v 1.8 2013/02/26 23:00:38 robbat2 Exp $
EAPI=3
inherit autotools eutils perl-module user
@@ -191,6 +191,9 @@ src_prepare() {
src_configure() {
# fix bug #36316
addpredict /var/cache/samba/gencache.tdb
+ # fix bug #376169
+ addpredict /run/blkid
+ addpredict /etc/blkid.tab
[ ! -f "${TMPENVFILE}" ] && die "Variable setting file (${TMPENVFILE}) should exist!"
source "${TMPENVFILE}"