summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2007-09-12 23:30:57 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2007-09-12 23:30:57 +0000
commit06aac1733a996e42448f5ea65ecb2979ffa4cdb2 (patch)
treed1fc07e0c97eef9b325f62edc70811ef02803117 /app-backup/dar
parentAdded two security patches for konqueror. Fixes bug 185603. (diff)
downloadgentoo-2-06aac1733a996e42448f5ea65ecb2979ffa4cdb2.tar.gz
gentoo-2-06aac1733a996e42448f5ea65ecb2979ffa4cdb2.tar.bz2
gentoo-2-06aac1733a996e42448f5ea65ecb2979ffa4cdb2.zip
Version bumped, bug #192336.
(Portage version: 2.1.2.12)
Diffstat (limited to 'app-backup/dar')
-rw-r--r--app-backup/dar/ChangeLog7
-rw-r--r--app-backup/dar/dar-2.3.5.ebuild61
-rw-r--r--app-backup/dar/files/digest-dar-2.3.53
3 files changed, 70 insertions, 1 deletions
diff --git a/app-backup/dar/ChangeLog b/app-backup/dar/ChangeLog
index b3557434311c..03325cf0415a 100644
--- a/app-backup/dar/ChangeLog
+++ b/app-backup/dar/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-backup/dar
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-backup/dar/ChangeLog,v 1.25 2007/07/12 16:42:09 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-backup/dar/ChangeLog,v 1.26 2007/09/12 23:30:56 matsuu Exp $
+
+*dar-2.3.5 (12 Sep 2007)
+
+ 12 Sep 2007; MATSUU Takuto <matsuu@gentoo.org> +dar-2.3.5.ebuild:
+ Version bumped, bug #192336.
*dar-2.3.4 (12 Jul 2007)
diff --git a/app-backup/dar/dar-2.3.5.ebuild b/app-backup/dar/dar-2.3.5.ebuild
new file mode 100644
index 000000000000..2e8891f21c78
--- /dev/null
+++ b/app-backup/dar/dar-2.3.5.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-backup/dar/dar-2.3.5.ebuild,v 1.1 2007/09/12 23:30:57 matsuu Exp $
+
+inherit flag-o-matic
+
+DESCRIPTION="A full featured backup tool, aimed for disks (floppy,CDR(W),DVDR(W),zip,jazz etc.)"
+HOMEPAGE="http://dar.linux.free.fr/"
+SRC_URI="mirror://sourceforge/dar/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="acl dar32 dar64 doc nls ssl"
+
+DEPEND=">=sys-libs/zlib-1.2.3
+ >=app-arch/bzip2-1.0.2
+ acl? ( sys-apps/attr )
+ doc? ( app-doc/doxygen )
+ nls? ( sys-devel/gettext )
+ ssl? ( dev-libs/openssl )"
+
+pkg_setup() {
+ if use dar32 && use dar64 ; then
+ eerror "dar32 and dar64 cannot be enabled together."
+ eerror "Please remove one of them and try the emerge again."
+ die "Please remove dar32 or dar64."
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i -e '/^dist_noinst_DATA/s/$/ macro_tools.hpp/' \
+ -e '/^noinst_HEADERS/s/macro_tools.hpp//' \
+ src/libdar/Makefile* || die
+}
+
+src_compile() {
+ local myconf="--disable-upx"
+
+ # Bug 103741
+ filter-flags -fomit-frame-pointer
+
+ use acl || myconf="${myconf} --disable-ea-support"
+ use dar32 && myconf="${myconf} --enable-mode=32"
+ use dar64 && myconf="${myconf} --enable-mode=64"
+ use doc || myconf="${myconf} --disable-build-html"
+ # use examples && myconf="${myconf} --enable-examples"
+ use nls || myconf="${myconf} --disable-nls"
+ use ssl || myconf="${myconf} --disable-libcrypto-linking"
+
+ econf ${myconf} || die
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" pkgdatadir=/usr/share/doc/${PF}/html install || die
+
+ dodoc AUTHORS ChangeLog NEWS README THANKS TODO
+}
diff --git a/app-backup/dar/files/digest-dar-2.3.5 b/app-backup/dar/files/digest-dar-2.3.5
new file mode 100644
index 000000000000..c30d0a7f0294
--- /dev/null
+++ b/app-backup/dar/files/digest-dar-2.3.5
@@ -0,0 +1,3 @@
+MD5 948288bcde5671bd690fdd398f665bb7 dar-2.3.5.tar.gz 1190027
+RMD160 9a0a3c41dbbb2e182b11227d29c3220c471682b4 dar-2.3.5.tar.gz 1190027
+SHA256 650cbd2e904a83cbd33c6775a9b757df7f1bbca6b068afdfad8a9bab350f3d70 dar-2.3.5.tar.gz 1190027