summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2006-02-11 15:48:51 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2006-02-11 15:48:51 +0000
commit5dbe832f43f9d2a2dbf377946ede0ce26d2aaa62 (patch)
treefe72aebbdaa5829b5876c53209ec383eeb335b01 /app-backup/dar
parentAdd modular X dependencies (bug #121130, Moshe Kaminsky). (diff)
downloadgentoo-2-5dbe832f43f9d2a2dbf377946ede0ce26d2aaa62.tar.gz
gentoo-2-5dbe832f43f9d2a2dbf377946ede0ce26d2aaa62.tar.bz2
gentoo-2-5dbe832f43f9d2a2dbf377946ede0ce26d2aaa62.zip
Version bumped. Added some USE flags.
(Portage version: 2.0.54)
Diffstat (limited to 'app-backup/dar')
-rw-r--r--app-backup/dar/ChangeLog11
-rw-r--r--app-backup/dar/Manifest2
-rw-r--r--app-backup/dar/dar-2.2.6.ebuild55
-rw-r--r--app-backup/dar/files/digest-dar-2.2.61
4 files changed, 67 insertions, 2 deletions
diff --git a/app-backup/dar/ChangeLog b/app-backup/dar/ChangeLog
index 639e2caecfa3..70fc8f5ce624 100644
--- a/app-backup/dar/ChangeLog
+++ b/app-backup/dar/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-backup/dar
-# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-backup/dar/ChangeLog,v 1.11 2005/12/24 15:34:32 matsuu Exp $
+# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-backup/dar/ChangeLog,v 1.12 2006/02/11 15:48:51 matsuu Exp $
+
+*dar-2.2.6 (11 Feb 2006)
+
+ 11 Feb 2006; MATSUU Takuto <matsuu@gentoo.org> +dar-2.2.6.ebuild:
+ Version bumped.
+ Added some USE flags.
+ Clean up ebuild.
*dar-2.2.5 (24 Dec 2005)
diff --git a/app-backup/dar/Manifest b/app-backup/dar/Manifest
index b1abc17a7dc8..9c72e9458fa0 100644
--- a/app-backup/dar/Manifest
+++ b/app-backup/dar/Manifest
@@ -4,9 +4,11 @@ MD5 2c2e07921cdc827bb7a64dd8cbcfd6f1 dar-2.2.2.ebuild 1141
MD5 dbbf0d7df46edad5bed2b5dca4f61536 dar-2.2.3.ebuild 1145
MD5 b92eb4b3d83dbeb61fdb2a6c9813c212 dar-2.2.4.ebuild 1145
MD5 358c05036c69a8e0969c7cd5b8be7ca7 dar-2.2.5.ebuild 1145
+MD5 18bc5a0b587e8340686458b55154f0cb dar-2.2.6.ebuild 1619
MD5 386d1068d568e85b87309a279da188c4 files/digest-dar-2.1.6 61
MD5 a08cb65f15e68f63e8ad0d30f060d3d2 files/digest-dar-2.2.2 62
MD5 215cc41777cf38cbd5e8973467199fee files/digest-dar-2.2.3 62
MD5 9ec92eb91a511d72b956660cc7df1316 files/digest-dar-2.2.4 62
MD5 d0ba8118888a829b0feb24799f759da3 files/digest-dar-2.2.5 62
+MD5 f97a32b761f1cc3ff6654cd524ccedf3 files/digest-dar-2.2.6 62
MD5 ae8f2b13b9e79b5760aa8c08f84bebe8 metadata.xml 468
diff --git a/app-backup/dar/dar-2.2.6.ebuild b/app-backup/dar/dar-2.2.6.ebuild
new file mode 100644
index 000000000000..3077bd35ee05
--- /dev/null
+++ b/app-backup/dar/dar-2.2.6.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-backup/dar/dar-2.2.6.ebuild,v 1.1 2006/02/11 15:48:51 matsuu Exp $
+
+inherit flag-o-matic
+
+DESCRIPTION="A full featured backup tool, aimed for disks (floppy,CDR(W),DVDR(W),zip,jazz etc.)"
+HOMEPAGE="http://dar.linux.free.fr/"
+SRC_URI="mirror://sourceforge/dar/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="acl dar32 dar64 doc examples nls ssl static"
+
+DEPEND=">=sys-libs/zlib-1.2.3
+ >=app-arch/bzip2-1.0.2
+ acl? ( sys-apps/attr )
+ doc? ( app-doc/doxygen )
+ nls? ( sys-devel/gettext )
+ ssl? ( dev-libs/openssl )"
+
+src_compile() {
+ local myconf="--disable-upx"
+
+ # Bug 103741
+ filter-flags -fomit-frame-pointer
+
+ use acl || myconf="${myconf} --disable-ea-support"
+ use dar32 && myconf="${myconf} --enable-mode=32"
+ use dar64 && myconf="${myconf} --enable-mode=64"
+ use doc || myconf="${myconf} --disable-build-html"
+ use examples && myconf="${myconf} --enable-examples"
+ use nls || myconf="${myconf} --disable-nls"
+ use ssl || myconf="${myconf} --disable-libcrypto-linking"
+ use static || myconf="${myconf} --enable-static=no --disable-dar-static"
+
+ econf ${myconf} || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+
+ rm "${D}"/usr/share/dar/{[A-Z]*,*.html}
+
+ dodoc AUTHORS BUGS ChangeLog NEWS README THANKS TODO
+ dodoc doc/{COMMAND_LINE,FAQ,FEATURES,GOOD_BACKUP_PRACTICE,LIMITATIONS}
+ dodoc doc/{LINKS,NOTES,TUTORIAL}
+ dohtml doc/api_tutorial.html doc/mini-howto/*.html
+
+ if use doc ; then
+ dohtml doc/html/*
+ fi
+}
diff --git a/app-backup/dar/files/digest-dar-2.2.6 b/app-backup/dar/files/digest-dar-2.2.6
new file mode 100644
index 000000000000..fcb404697646
--- /dev/null
+++ b/app-backup/dar/files/digest-dar-2.2.6
@@ -0,0 +1 @@
+MD5 4cc1befb9052783b30819102cbd505d2 dar-2.2.6.tar.gz 1089148