summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2011-09-06 19:33:01 +0000
committerPatrick Lauer <patrick@gentoo.org>2011-09-06 19:33:01 +0000
commitdadf18bbc2d72d768d0f4d8a4513c2a28921a90b (patch)
tree1df9737c5c59e0c9cddbef054eaf588489439413 /app-backup/duplicity
parentDie when there is no such dir with translations/help. (diff)
downloadgentoo-2-dadf18bbc2d72d768d0f4d8a4513c2a28921a90b.tar.gz
gentoo-2-dadf18bbc2d72d768d0f4d8a4513c2a28921a90b.tar.bz2
gentoo-2-dadf18bbc2d72d768d0f4d8a4513c2a28921a90b.zip
Bump, thanks to Hanno for reminding me
(Portage version: 2.2.0_alpha53/cvs/Linux x86_64)
Diffstat (limited to 'app-backup/duplicity')
-rw-r--r--app-backup/duplicity/ChangeLog7
-rw-r--r--app-backup/duplicity/duplicity-0.6.15.ebuild35
2 files changed, 41 insertions, 1 deletions
diff --git a/app-backup/duplicity/ChangeLog b/app-backup/duplicity/ChangeLog
index c0d7ba400dd3..85afe94a87bf 100644
--- a/app-backup/duplicity/ChangeLog
+++ b/app-backup/duplicity/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-backup/duplicity
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-backup/duplicity/ChangeLog,v 1.54 2011/08/30 07:32:19 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-backup/duplicity/ChangeLog,v 1.55 2011/09/06 19:33:01 patrick Exp $
+
+*duplicity-0.6.15 (06 Sep 2011)
+
+ 06 Sep 2011; Patrick Lauer <patrick@gentoo.org> +duplicity-0.6.15.ebuild:
+ Bump, thanks to Hanno for reminding me
*duplicity-0.6.14 (29 Aug 2011)
diff --git a/app-backup/duplicity/duplicity-0.6.15.ebuild b/app-backup/duplicity/duplicity-0.6.15.ebuild
new file mode 100644
index 000000000000..ed6ef8ce640b
--- /dev/null
+++ b/app-backup/duplicity/duplicity-0.6.15.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-backup/duplicity/duplicity-0.6.15.ebuild,v 1.1 2011/09/06 19:33:01 patrick Exp $
+
+EAPI="3"
+
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython"
+
+inherit distutils
+
+DESCRIPTION="duplicity is a secure backup system using gnupg to encrypt data"
+HOMEPAGE="http://www.nongnu.org/duplicity/"
+SRC_URI="http://code.launchpad.net/${PN}/0.6-series/${PV}/+download/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE="s3"
+
+DEPEND="
+ >=net-libs/librsync-0.9.6
+ app-crypt/gnupg
+"
+RDEPEND="${DEPEND}
+ >=dev-python/py-gnupg-0.3.2
+ >=dev-python/pexpect-2.1
+ s3? ( dev-python/boto )
+"
+
+src_prepare() {
+ distutils_src_prepare
+ sed -i -r "s/'COPYING',//" setup.py || die "Couldn't remove unnecessary COPYING file."
+}