summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2010-08-14 08:44:41 +0000
committerHans de Graaff <graaff@gentoo.org>2010-08-14 08:44:41 +0000
commit4a0c7b6fbb6fc800797350920d0567647a72a11c (patch)
treec57877599f054933842a59bb2cc3a33641463a20 /app-backup
parentRespect LDFLAGS wrt bug 332475. Thanks to Diego for report. (diff)
downloadgentoo-2-4a0c7b6fbb6fc800797350920d0567647a72a11c.tar.gz
gentoo-2-4a0c7b6fbb6fc800797350920d0567647a72a11c.tar.bz2
gentoo-2-4a0c7b6fbb6fc800797350920d0567647a72a11c.zip
Fix perl 5.12 deprecation warnings, thanks to John R. Graham for providing a patch in bug 331673.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'app-backup')
-rw-r--r--app-backup/flexbackup/ChangeLog12
-rw-r--r--app-backup/flexbackup/files/flexbackup-1.2.1-perl-5.12-deprecation-warning.patch22
-rw-r--r--app-backup/flexbackup/flexbackup-1.2.1-r9.ebuild82
3 files changed, 114 insertions, 2 deletions
diff --git a/app-backup/flexbackup/ChangeLog b/app-backup/flexbackup/ChangeLog
index 0f0464af317b..112694b74f95 100644
--- a/app-backup/flexbackup/ChangeLog
+++ b/app-backup/flexbackup/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-backup/flexbackup
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-backup/flexbackup/ChangeLog,v 1.30 2009/08/08 14:16:51 graaff Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-backup/flexbackup/ChangeLog,v 1.31 2010/08/14 08:44:41 graaff Exp $
+
+*flexbackup-1.2.1-r9 (14 Aug 2010)
+
+ 14 Aug 2010; Hans de Graaff <graaff@gentoo.org>
+ +flexbackup-1.2.1-r9.ebuild,
+ +files/flexbackup-1.2.1-perl-5.12-deprecation-warning.patch:
+ Fix perl 5.12 deprecation warnings, thanks to John R. Graham for providing
+ a patch in bug 331673.
08 Aug 2009; Hans de Graaff <graaff@gentoo.org>
-flexbackup-1.2.1-r7.ebuild:
diff --git a/app-backup/flexbackup/files/flexbackup-1.2.1-perl-5.12-deprecation-warning.patch b/app-backup/flexbackup/files/flexbackup-1.2.1-perl-5.12-deprecation-warning.patch
new file mode 100644
index 000000000000..760331c4ba6b
--- /dev/null
+++ b/app-backup/flexbackup/files/flexbackup-1.2.1-perl-5.12-deprecation-warning.patch
@@ -0,0 +1,22 @@
+diff -ubB old/flexbackup new/flexbackup
+--- old/flexbackup 2010-07-30 11:44:34.000000000 -0400
++++ new/flexbackup 2010-07-30 11:46:03.000000000 -0400
+@@ -1050,7 +1050,7 @@
+ } else {
+ $prunekey = $dir;
+ }
+- if (defined(%{$::prune{$prunekey}})) {
++ if (%{$::prune{$prunekey}}) {
+ &log("| NOTE: \$prune is ignored for type=dump");
+ }
+
+@@ -4882,7 +4882,7 @@
+ $prunekey = $dir;
+ }
+
+- if (defined(%{$::prune{$prunekey}})) {
++ if (%{$::prune{$prunekey}}) {
+ my $rex;
+ # FreeBSD needs -E (above) and no backslashes around the (|) chars
+ if ($::uname =~ /FreeBSD/) {
+Only in new/: flexbackup~
diff --git a/app-backup/flexbackup/flexbackup-1.2.1-r9.ebuild b/app-backup/flexbackup/flexbackup-1.2.1-r9.ebuild
new file mode 100644
index 000000000000..1843e28579ab
--- /dev/null
+++ b/app-backup/flexbackup/flexbackup-1.2.1-r9.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-backup/flexbackup/flexbackup-1.2.1-r9.ebuild,v 1.1 2010/08/14 08:44:41 graaff Exp $
+
+inherit eutils versionator
+
+DESCRIPTION="Flexible backup script using perl"
+HOMEPAGE="http://flexbackup.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~x86"
+IUSE=""
+
+RDEPEND="app-arch/mt-st"
+DEPEND="${RDEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Patch from upstream adds optional lzma compression mode.
+ epatch "${FILESDIR}"/${P}-lzma.patch
+
+ # Fix bug #116510: cannot back up remote machines after patch CAN-2005-2965
+ epatch "${FILESDIR}"/${P}-secure-tempfile.patch
+
+ # Fix bug #96334: incorrectly determines bash 3.x to be bash 1.x
+ epatch "${FILESDIR}"/${P}-bash.patch
+
+ # Fix bug #171205: specifies wrong command line option for mbuffer / other small enhancements
+ epatch "${FILESDIR}"/${P}-mbuffer-switch.patch
+
+ # Fix bug #173672: remote host buffer test is broken
+ epatch "${FILESDIR}"/${P}-remote-bufftest.patch
+
+ # Fix bug #178126: subtle subtree pruning issue / other small issues
+ epatch "${FILESDIR}"/${P}-prune.patch
+
+ # Fix bug #184560: fails to back up targets with spaces in their names in some modes
+ epatch "${FILESDIR}"/${P}-spaces-in-filenames.patch
+
+ # Fix bug #190357: fails on very large files with afio back end
+ epatch "${FILESDIR}"/${P}-afio-large-files.patch
+
+ # Fix bug #235416: prevent normal status message during conf file read from going to stderr
+ epatch "${FILESDIR}"/${P}-quieten.patch
+
+ # Fix bug #331673: perl 5.12 deprecation warnings.
+ epatch "${FILESDIR}"/${P}-perl-5.12-deprecation-warning.patch
+
+ sed -i \
+ -e '/^\$type = /s:afio:tar:' \
+ -e "/^\$buffer = /s:'buffer':'false':" \
+ flexbackup.conf \
+ || die "Failed to set modified configuration defaults."
+
+ MY_PV=$(replace_all_version_separators '_')
+ sed -i \
+ -e "/^[[:blank:]]*my \$ver = /s:${MY_PV}:&-${PR}:" \
+ flexbackup \
+ || die "Failed to apply ebuild revision to internal version string."
+}
+
+src_install() {
+ dodir /etc /usr/bin /usr/share/man/man{1,5}
+ emake install \
+ PREFIX="${D}"/usr \
+ CONFFILE="${D}"/etc/flexbackup.conf \
+ || die "emake install failed"
+
+ dodoc CHANGES CREDITS README TODO
+ dohtml faq.html
+}
+
+pkg_postinst() {
+ elog "Please edit your /etc/flexbackup.conf file to suit your"
+ elog "needs. If you are using devfs, the tape device should"
+ elog "be set to /dev/tapes/tape0/mtn. If you need to use any"
+ elog "archiver other than tar, please emerge it separately."
+}