summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Beierlein <tomjbe@gentoo.org>2012-09-22 19:30:47 +0000
committerThomas Beierlein <tomjbe@gentoo.org>2012-09-22 19:30:47 +0000
commit6a1b0bd329005391ebefa876ac59f328d2bc99d4 (patch)
tree891b076fa0d451683b340f895e03bde513efbd15 /app-backup
parentPut 64bits libraries into lib as this is what vanilla FreeBSD does and also o... (diff)
downloadgentoo-2-6a1b0bd329005391ebefa876ac59f328d2bc99d4.tar.gz
gentoo-2-6a1b0bd329005391ebefa876ac59f328d2bc99d4.tar.bz2
gentoo-2-6a1b0bd329005391ebefa876ac59f328d2bc99d4.zip
Fix build with USE=static (bug #435798). Thanks peratu
(Portage version: 2.1.11.20/cvs/Linux x86_64)
Diffstat (limited to 'app-backup')
-rw-r--r--app-backup/bacula/ChangeLog6
-rw-r--r--app-backup/bacula/bacula-5.2.12.ebuild27
-rw-r--r--app-backup/bacula/files/5.2.10/bacula-5.2.10-fix-static.patch2
3 files changed, 27 insertions, 8 deletions
diff --git a/app-backup/bacula/ChangeLog b/app-backup/bacula/ChangeLog
index 5ee8aa147296..cf9231980207 100644
--- a/app-backup/bacula/ChangeLog
+++ b/app-backup/bacula/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-backup/bacula
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-backup/bacula/ChangeLog,v 1.138 2012/09/22 14:55:16 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-backup/bacula/ChangeLog,v 1.139 2012/09/22 19:30:46 tomjbe Exp $
+
+ 22 Sep 2012; Thomas Beierlein <tomjbe@gentoo.org>
+ files/5.2.10/bacula-5.2.10-fix-static.patch, bacula-5.2.12.ebuild:
+ Fix build with USE=static (bug #435798). Thanks peratu
22 Sep 2012; Anthony G. Basile <blueness@gentoo.org> bacula-5.2.12.ebuild:
stable ppc, bug #434878
diff --git a/app-backup/bacula/bacula-5.2.12.ebuild b/app-backup/bacula/bacula-5.2.12.ebuild
index 5df026fa7da7..1c2194f0e0d7 100644
--- a/app-backup/bacula/bacula-5.2.12.ebuild
+++ b/app-backup/bacula/bacula-5.2.12.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-backup/bacula/bacula-5.2.12.ebuild,v 1.3 2012/09/22 14:55:16 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-backup/bacula/bacula-5.2.12.ebuild,v 1.4 2012/09/22 19:30:46 tomjbe Exp $
EAPI="4"
PYTHON_DEPEND="python? 2"
@@ -19,10 +19,9 @@ SRC_URI="mirror://sourceforge/bacula/${MY_P}.tar.gz"
LICENSE="AGPL-3"
SLOT="0"
KEYWORDS="~amd64 ~hppa ppc ~sparc ~x86"
-IUSE="bacula-clientonly bacula-nodir bacula-nosd ipv6 logwatch mysql postgres python qt4 readline +sqlite3 ssl static tcpd vim-syntax X"
+IUSE="acl bacula-clientonly bacula-nodir bacula-nosd ipv6 logwatch mysql postgres python qt4 readline +sqlite3 ssl static tcpd vim-syntax X"
DEPEND="
- >=sys-libs/zlib-1.1.4
dev-libs/gmp
!bacula-clientonly? (
postgres? ( dev-db/postgresql-base[threads] )
@@ -34,12 +33,23 @@ DEPEND="
x11-libs/qt-svg:4
x11-libs/qwt:5
)
- ssl? ( dev-libs/openssl )
logwatch? ( sys-apps/logwatch )
tcpd? ( >=sys-apps/tcp-wrappers-7.6 )
readline? ( >=sys-libs/readline-4.1 )
- dev-libs/lzo
- sys-libs/ncurses"
+ static? (
+ acl? ( virtual/acl[static-libs] )
+ sys-libs/zlib[static-libs]
+ dev-libs/lzo[static-libs]
+ sys-libs/ncurses[static-libs]
+ ssl? ( dev-libs/openssl[static-libs] )
+ )
+ !static? (
+ acl? ( virtual/acl )
+ sys-libs/zlib
+ dev-libs/lzo
+ sys-libs/ncurses
+ ssl? ( dev-libs/openssl )
+ )"
RDEPEND="${DEPEND}
!bacula-clientonly? (
!bacula-nosd? (
@@ -125,6 +135,10 @@ src_prepare() {
epatch "${FILESDIR}"/5.2.10/${PN}-5.2.10-fix-static.patch
+ # do not strip binaries
+ sed -i -e "s/strip /# strip /" src/filed/Makefile.in || die
+ sed -i -e "s/strip /# strip /" src/console/Makefile.in || die
+
# fix file not found error during make depend
epatch "${FILESDIR}"/5.2.12/${P}-depend.patch
}
@@ -167,6 +181,7 @@ src_configure() {
$(use_with readline readline /usr) \
$(use_with ssl openssl) \
$(use_enable ipv6) \
+ $(use_enable acl) \
$(use_with tcpd tcp-wrappers)"
econf \
diff --git a/app-backup/bacula/files/5.2.10/bacula-5.2.10-fix-static.patch b/app-backup/bacula/files/5.2.10/bacula-5.2.10-fix-static.patch
index 5c831416b0d0..458c188733a4 100644
--- a/app-backup/bacula/files/5.2.10/bacula-5.2.10-fix-static.patch
+++ b/app-backup/bacula/files/5.2.10/bacula-5.2.10-fix-static.patch
@@ -28,7 +28,7 @@
- $(DLIB) $(CONS_LIBS) -lbaccfg -lbac -lm $(LIBS) $(GETTEXT_LIBS) \
- $(OPENSSL_LIBS)
+ $(DLIB) $(CONS_LIBS) -lbaccfg -lbac -lm $(ZLIBS) $(GETTEXT_LIBS) \
-+ $(OPENSSL_LIBS) $(LIBS)
++ $(OPENSSL_LIBS) $(LIBS) $(ZLIBS)
strip $@