summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYixun Lan <dlan@gentoo.org>2014-05-30 09:59:55 +0000
committerYixun Lan <dlan@gentoo.org>2014-05-30 09:59:55 +0000
commit6bd04ef7bd1f9466c88ea85d0c282064932c701c (patch)
treea2206c6c04148f42efe97b9ff08699a901da1337 /app-backup
parentadd py3.4 support (diff)
downloadgentoo-2-6bd04ef7bd1f9466c88ea85d0c282064932c701c.tar.gz
gentoo-2-6bd04ef7bd1f9466c88ea85d0c282064932c701c.tar.bz2
gentoo-2-6bd04ef7bd1f9466c88ea85d0c282064932c701c.zip
fix bug #511410, thanks Dainius Masiliūnas,holgersson; combine minor improvement suggested by @jlec
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0xAABEFD55)
Diffstat (limited to 'app-backup')
-rw-r--r--app-backup/snapper/ChangeLog7
-rw-r--r--app-backup/snapper/snapper-0.2.2-r1.ebuild35
-rw-r--r--app-backup/snapper/snapper-9999.ebuild44
3 files changed, 44 insertions, 42 deletions
diff --git a/app-backup/snapper/ChangeLog b/app-backup/snapper/ChangeLog
index 3f9f3213d138..4e65883c989f 100644
--- a/app-backup/snapper/ChangeLog
+++ b/app-backup/snapper/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-backup/snapper
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-backup/snapper/ChangeLog,v 1.2 2014/05/22 09:56:05 dlan Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-backup/snapper/ChangeLog,v 1.3 2014/05/30 09:59:55 dlan Exp $
+
+ 30 May 2014; Yixun Lan <dlan@gentoo.org> snapper-0.2.2-r1.ebuild,
+ snapper-9999.ebuild:
+ fix bug #511410, thanks Dainius Masiliūnas,holgersson; combine minor
+ improvement suggested by @jlec
*snapper-0.2.2-r1 (22 May 2014)
diff --git a/app-backup/snapper/snapper-0.2.2-r1.ebuild b/app-backup/snapper/snapper-0.2.2-r1.ebuild
index 377f07278b74..309da7744b9c 100644
--- a/app-backup/snapper/snapper-0.2.2-r1.ebuild
+++ b/app-backup/snapper/snapper-0.2.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-backup/snapper/snapper-0.2.2-r1.ebuild,v 1.1 2014/05/22 09:56:05 dlan Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-backup/snapper/snapper-0.2.2-r1.ebuild,v 1.2 2014/05/30 09:59:55 dlan Exp $
EAPI=5
@@ -40,15 +40,18 @@ src_prepare() {
}
src_configure() {
- econf \
- --with-conf="/etc/conf.d" \
- --docdir="/usr/share/doc/${PF}" \
- $(use_enable btrfs) \
- $(use_enable ext4) \
- $(use_enable lvm) \
- $(use_enable pam) \
- $(use_enable xattr xattrs) \
- --disable-zypp
+ local myeconfargs=(
+ --with-conf="/etc/conf.d"
+ --docdir="/usr/share/doc/${PF}"
+ --disable-zypp
+ $(use_enable btrfs)
+ $(use_enable ext4)
+ $(use_enable lvm)
+ $(use_enable pam)
+ $(use_enable xattr xattrs)
+ )
+
+ econf "${myeconfargs[@]}"
}
src_install() {
@@ -59,11 +62,9 @@ src_install() {
}
pkg_postinst() {
- elog "In order to use Snapper, you need to set up at least one config"
- elog "manually, or else the tool will get confused. Typically you should"
- elog "create a '/.snapshots' directory, then copy the file"
- elog "'/etc/snapper/config-templates/default' into '/etc/snapper/configs/',"
- elog "rename the file to 'root', and add its name into '/etc/conf.d/snapper'."
- elog "That will instruct Snapper to snapshot the root of the filesystem by"
- elog "default. For more information, see the snapper(8) manual page."
+ elog "In order to use Snapper, you need to set up"
+ elog "at least one config first. To do this, run:"
+ elog "snapper create-config <subvolume>"
+ elog "For more information, see man (8) snapper or"
+ elog "http://snapper.io/documentation.html"
}
diff --git a/app-backup/snapper/snapper-9999.ebuild b/app-backup/snapper/snapper-9999.ebuild
index bc4be552a20d..93ecd624e033 100644
--- a/app-backup/snapper/snapper-9999.ebuild
+++ b/app-backup/snapper/snapper-9999.ebuild
@@ -1,13 +1,13 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-backup/snapper/snapper-9999.ebuild,v 1.2 2014/05/22 09:56:05 dlan Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-backup/snapper/snapper-9999.ebuild,v 1.3 2014/05/30 09:59:55 dlan Exp $
EAPI=5
EGIT_REPO_URI="git://github.com/openSUSE/snapper.git"
AUTOTOOLS_AUTORECONF=1
AUTOTOOLS_IN_SOURCE_BUILD=1
-inherit eutils autotools-utils git-2
+inherit eutils autotools-utils git-r3
DESCRIPTION="Command-line program for btrfs and ext4 snapshot management"
HOMEPAGE="http://snapper.io/"
@@ -38,36 +38,32 @@ DEPEND="${RDEPEND}
DOCS=( AUTHORS README package/snapper.changes )
-src_prepare() {
- epatch "${FILESDIR}"/cron-confd.patch
- autotools-utils_src_prepare
-}
+PATCHES=( "${FILESDIR}"/cron-confd.patch )
src_configure() {
- econf \
- --with-conf="/etc/conf.d" \
- --docdir="/usr/share/doc/${PF}" \
- $(use_enable btrfs) \
- $(use_enable ext4) \
- $(use_enable lvm) \
- $(use_enable pam) \
- $(use_enable xattr xattrs) \
- --disable-zypp
+ local myeconfargs=(
+ --with-conf="/etc/conf.d"
+ --docdir="/usr/share/doc/${PF}"
+ --disable-zypp
+ $(use_enable btrfs)
+ $(use_enable ext4)
+ $(use_enable lvm)
+ $(use_enable pam)
+ $(use_enable xattr xattrs)
+ )
+ autotools-utils_src_configure
}
src_install() {
- default
+ autotools-utils_src_install
# Existing configuration file required to function
newconfd data/sysconfig.snapper snapper
- prune_libtool_files
}
pkg_postinst() {
- elog "In order to use Snapper, you need to set up at least one config"
- elog "manually, or else the tool will get confused. Typically you should"
- elog "create a '/.snapshots' directory, then copy the file"
- elog "'/etc/snapper/config-templates/default' into '/etc/snapper/configs/',"
- elog "rename the file to 'root', and add its name into '/etc/conf.d/snapper'."
- elog "That will instruct Snapper to snapshot the root of the filesystem by"
- elog "default. For more information, see the snapper(8) manual page."
+ elog "In order to use Snapper, you need to set up"
+ elog "at least one config first. To do this, run:"
+ elog "snapper create-config <subvolume>"
+ elog "For more information, see man (8) snapper or"
+ elog "http://snapper.io/documentation.html"
}