summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2010-01-15 23:24:06 +0000
committerPatrick Lauer <patrick@gentoo.org>2010-01-15 23:24:06 +0000
commit960cc7c7655b9941c9eb1b5a3eba73814b2a170f (patch)
treec0f8f1f182c72779ec220712609f4400d618e09f /app-benchmarks/httperf
parentstable x86, bug 299705 (diff)
downloadgentoo-2-960cc7c7655b9941c9eb1b5a3eba73814b2a170f.tar.gz
gentoo-2-960cc7c7655b9941c9eb1b5a3eba73814b2a170f.tar.bz2
gentoo-2-960cc7c7655b9941c9eb1b5a3eba73814b2a170f.zip
Bump, new homepage, fixes #300991
(Portage version: 2.2_rc61/cvs/Linux x86_64)
Diffstat (limited to 'app-benchmarks/httperf')
-rw-r--r--app-benchmarks/httperf/ChangeLog9
-rw-r--r--app-benchmarks/httperf/httperf-0.9.0.ebuild37
2 files changed, 44 insertions, 2 deletions
diff --git a/app-benchmarks/httperf/ChangeLog b/app-benchmarks/httperf/ChangeLog
index 3b6ae1294a63..b706c2489b37 100644
--- a/app-benchmarks/httperf/ChangeLog
+++ b/app-benchmarks/httperf/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-benchmarks/httperf
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/httperf/ChangeLog,v 1.12 2009/10/12 19:03:10 halcy0n Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/httperf/ChangeLog,v 1.13 2010/01/15 23:24:06 patrick Exp $
+
+*httperf-0.9.0 (15 Jan 2010)
+
+ 15 Jan 2010; Patrick Lauer <patrick@gentoo.org> +httperf-0.9.0.ebuild:
+ Bump, new homepage, fixes #300991
12 Oct 2009; Mark Loeser <halcy0n@gentoo.org> httperf-0.8.ebuild:
QA fixes; unquoted variables
diff --git a/app-benchmarks/httperf/httperf-0.9.0.ebuild b/app-benchmarks/httperf/httperf-0.9.0.ebuild
new file mode 100644
index 000000000000..caae6b755a9b
--- /dev/null
+++ b/app-benchmarks/httperf/httperf-0.9.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/httperf/httperf-0.9.0.ebuild,v 1.1 2010/01/15 23:24:06 patrick Exp $
+
+EAPI=2
+
+inherit eutils autotools toolchain-funcs
+
+DESCRIPTION="A tool from HP for measuring web server performance."
+HOMEPAGE="http://code.google.com/p/httperf/"
+SRC_URI="http://httperf.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~sparc ~x86"
+IUSE="debug ssl"
+
+DEPEND=""
+RDEPEND=""
+
+src_prepare() {
+ eautoconf || die "autoconf failed"
+}
+src_configure() {
+ econf --bindir=/usr/bin \
+ $(use_enable debug) \
+ $(use_enable ssl) \
+ || die "econf failed"
+}
+src_compile() {
+ emake CC=$(tc-getCC) -j1 || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS ChangeLog NEWS README TODO
+}