summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2012-08-27 03:35:48 +0000
committerPatrick Lauer <patrick@gentoo.org>2012-08-27 03:35:48 +0000
commitccb2048ca5e0bb121421503b89b7e4b8b357bf7c (patch)
treee712c122d49ddc219e3d4069be69c557beff6424 /app-benchmarks/phoronix-test-suite
parentClarify comment, thanks to Arfrever on IRC. (diff)
downloadgentoo-2-ccb2048ca5e0bb121421503b89b7e4b8b357bf7c.tar.gz
gentoo-2-ccb2048ca5e0bb121421503b89b7e4b8b357bf7c.tar.bz2
gentoo-2-ccb2048ca5e0bb121421503b89b7e4b8b357bf7c.zip
Bump for #427724
(Portage version: 2.2.0_alpha123/cvs/Linux x86_64)
Diffstat (limited to 'app-benchmarks/phoronix-test-suite')
-rw-r--r--app-benchmarks/phoronix-test-suite/ChangeLog9
-rw-r--r--app-benchmarks/phoronix-test-suite/phoronix-test-suite-4.0.1.ebuild110
2 files changed, 117 insertions, 2 deletions
diff --git a/app-benchmarks/phoronix-test-suite/ChangeLog b/app-benchmarks/phoronix-test-suite/ChangeLog
index e19ba833a71e..43bea8169b84 100644
--- a/app-benchmarks/phoronix-test-suite/ChangeLog
+++ b/app-benchmarks/phoronix-test-suite/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-benchmarks/phoronix-test-suite
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/phoronix-test-suite/ChangeLog,v 1.18 2012/03/22 06:31:23 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/phoronix-test-suite/ChangeLog,v 1.19 2012/08/27 03:35:48 patrick Exp $
+
+*phoronix-test-suite-4.0.1 (27 Aug 2012)
+
+ 27 Aug 2012; Patrick Lauer <patrick@gentoo.org>
+ +phoronix-test-suite-4.0.1.ebuild:
+ Bump for #427724
*phoronix-test-suite-3.8.0 (22 Mar 2012)
@@ -99,4 +105,3 @@
19 Apr 2009; Doug Goldstein <cardoe@gentoo.org>
+phoronix-test-suite-1.8.0.ebuild:
add developmental ebuild
-
diff --git a/app-benchmarks/phoronix-test-suite/phoronix-test-suite-4.0.1.ebuild b/app-benchmarks/phoronix-test-suite/phoronix-test-suite-4.0.1.ebuild
new file mode 100644
index 000000000000..335ff4dc956b
--- /dev/null
+++ b/app-benchmarks/phoronix-test-suite/phoronix-test-suite-4.0.1.ebuild
@@ -0,0 +1,110 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/phoronix-test-suite/phoronix-test-suite-4.0.1.ebuild,v 1.1 2012/08/27 03:35:48 patrick Exp $
+
+EAPI=4
+
+inherit eutils bash-completion
+
+DESCRIPTION="Phoronix's comprehensive, cross-platform testing and benchmark suite"
+HOMEPAGE="http://www.phoronix-test-suite.com"
+SRC_URI="http://www.phoronix-test-suite.com/download.php?file=${P} -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+
+# php 5.3 doesn't have pcre and reflection useflags anymore
+RDEPEND="dev-lang/php[cli,curl,gd,json,posix,pcntl,truetype,zip]
+ dev-php/pecl-ps"
+
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ sed -i -e "s,export PTS_DIR=\`pwd\`,export PTS_DIR=\"/usr/share/${PN}\"," \
+ phoronix-test-suite
+}
+
+src_configure() {
+ :
+}
+
+src_compile() {
+ :
+}
+
+src_install() {
+ dodir /usr/share/${PN}
+ insinto /usr/share/${PN}
+
+ doman documentation/man-pages/phoronix-test-suite.1
+ dodoc AUTHORS CHANGE-LOG
+ dohtml -r documentation/
+ doicon pts-core/static/images/phoronix-test-suite.png
+ doicon pts-core/static/images/openbenchmarking.png
+ domenu pts-core/static/phoronix-test-suite.desktop
+ rm -f pts-core/static/phoronix-test-suite.desktop
+
+ doins -r pts-core
+ exeinto /usr/bin
+ doexe phoronix-test-suite
+
+ fperms a+x /usr/share/${PN}/pts-core/static/scripts/root-access.sh
+ fperms a+x /usr/share/${PN}/pts-core/external-test-dependencies/scripts/install-gentoo-packages.sh
+
+ dobashcompletion pts-core/static/bash_completion ${PN}
+
+ # Need to fix the cli-php config for downloading to work. Very naughty!
+ local slots
+ local slot
+ if [[ "x${PHP_TARGETS}" == "x" ]] ; then
+ ewarn
+ ewarn "PHP_TARGETS seems empty, php.ini file can't be configure."
+ ewarn "Make sure that PHP_TARGETS in /etc/make.conf is set."
+ ewarn "phoronix-test-suite needs the 'allow_url_fopen' option set to \"On\""
+ ewarn "for downloading to work properly."
+ ewarn
+ else
+ for slot in ${PHP_TARGETS}; do
+ slots+=" ${slot/-/.}"
+ done
+ fi
+
+ for slot in ${slots}; do
+ local PHP_INI_FILE="/etc/php/cli-${slot}/php.ini"
+ if [[ -f ${PHP_INI_FILE} ]] ; then
+ dodir $(dirname ${PHP_INI_FILE})
+ cp ${PHP_INI_FILE} "${D}${PHP_INI_FILE}"
+ sed -e 's|^allow_url_fopen .*|allow_url_fopen = On|g' -i "${D}${PHP_INI_FILE}"
+ else
+ if [[ "x$(eselect php show cli)" == "x${slot}" ]] ; then
+ ewarn
+ ewarn "${slot} hasn't a php.ini file."
+ ewarn "phoronix-test-suite needs the 'allow_url_fopen' option set to \"On\""
+ ewarn "for downloading to work properly."
+ ewarn "Check that your PHP_INI_VERSION is set during ${slot} merge"
+ ewarn
+ else
+ elog
+ elog "${slot} hasn't a php.ini file."
+ elog "phoronix-test-suite may need the 'allow_url_fopen' option set to \"On\""
+ elog "for downloading to work properly if you switch to ${slot}"
+ elog "Check that your PHP_INI_VERSION is set during ${slot} merge"
+ elog
+ fi
+ fi
+ done
+
+ ewarn
+ ewarn "If you upgrade from phoronix-test-suite-2*, you should reinstall all"
+ ewarn "your tests because"
+ ewarn " \$HOME/.phoronix-test-suite/installed-tests/\$TEST_NAME/"
+ ewarn "moves to"
+ ewarn " \$HOME/.phoronix-test-suite/installed-tests/pts/\$TEST_NAME-\$TEST_VERSION/"
+ ewarn "in phoronix-test-suite-3* version. The \$TEST_VERSION can be find in"
+ ewarn "pts-install.xml file."
+ ewarn
+}