summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Holzer <mholzer@gentoo.org>2003-08-11 20:11:53 +0000
committerMartin Holzer <mholzer@gentoo.org>2003-08-11 20:11:53 +0000
commit900d58bdb0f1291ff9ed4ef685c196150e342d0f (patch)
tree5a6fb802d8cbad604d05bfa9b33bb48ae288d18b /app-benchmarks/piozone
parentInitial version. (diff)
downloadgentoo-2-900d58bdb0f1291ff9ed4ef685c196150e342d0f.tar.gz
gentoo-2-900d58bdb0f1291ff9ed4ef685c196150e342d0f.tar.bz2
gentoo-2-900d58bdb0f1291ff9ed4ef685c196150e342d0f.zip
Initial version.
Diffstat (limited to 'app-benchmarks/piozone')
-rw-r--r--app-benchmarks/piozone/ChangeLog10
-rw-r--r--app-benchmarks/piozone/Manifest4
-rw-r--r--app-benchmarks/piozone/files/digest-piozone-1.0-r21
-rw-r--r--app-benchmarks/piozone/files/piozone-1.0-gentoo.diff49
-rw-r--r--app-benchmarks/piozone/piozone-1.0-r2.ebuild29
5 files changed, 91 insertions, 2 deletions
diff --git a/app-benchmarks/piozone/ChangeLog b/app-benchmarks/piozone/ChangeLog
new file mode 100644
index 000000000000..73fc31cfd78b
--- /dev/null
+++ b/app-benchmarks/piozone/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for app-benchmarks/piozone
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/piozone/ChangeLog,v 1.1 2003/08/11 20:11:43 mholzer Exp $
+
+*piozone-1.0-r2 (12 Aug 2003)
+
+ 12 Aug 2003; Martin Holzer <mholzer@gentoo.org> piozone-1.0-r2.ebuild,
+ files/piozone-1.0-gentoo.diff:
+ Initial version. Submitted by Marcelo Góes <blueboard@terra.com.br> in #24250
+
diff --git a/app-benchmarks/piozone/Manifest b/app-benchmarks/piozone/Manifest
index 4f6aa1679ad9..411d66f66a5d 100644
--- a/app-benchmarks/piozone/Manifest
+++ b/app-benchmarks/piozone/Manifest
@@ -1,4 +1,4 @@
-MD5 aae42527f0ae00ce65073446cf3fd499 piozone-1.0-r2.ebuild 516
-MD5 730e8f5bd3177b22bffc176313cf448e piozone/Manifest 203
+MD5 070545e985f0543a1f8458690e03e4cf ChangeLog 445
+MD5 3e1f65f4331b2e5cbde4d5c8fa6bea34 piozone-1.0-r2.ebuild 536
MD5 73b1ff1f26935da8082864a001906694 files/digest-piozone-1.0-r2 61
MD5 56e97e8f7a92632f15dc043ee01225f9 files/piozone-1.0-gentoo.diff 1495
diff --git a/app-benchmarks/piozone/files/digest-piozone-1.0-r2 b/app-benchmarks/piozone/files/digest-piozone-1.0-r2
new file mode 100644
index 000000000000..3f657ccdc012
--- /dev/null
+++ b/app-benchmarks/piozone/files/digest-piozone-1.0-r2
@@ -0,0 +1 @@
+MD5 e48370a9aa80aed212b18e16c08b9056 piozone-1.0.tar.gz 2228
diff --git a/app-benchmarks/piozone/files/piozone-1.0-gentoo.diff b/app-benchmarks/piozone/files/piozone-1.0-gentoo.diff
new file mode 100644
index 000000000000..aa9a91d5ea35
--- /dev/null
+++ b/app-benchmarks/piozone/files/piozone-1.0-gentoo.diff
@@ -0,0 +1,49 @@
+diff -Naur piozone-1.0.orig/Makefile piozone-1.0/Makefile
+--- piozone-1.0.orig/Makefile 2003-07-10 18:54:51.000000000 -0300
++++ piozone-1.0/Makefile 2003-07-10 19:02:41.000000000 -0300
+@@ -19,3 +19,6 @@
+
+ dist: version distclean
+ (PACKNAME=`basename \`pwd\`` ; cd .. ; $(TAR) cf - $$PACKNAME | $(GZIP) -9 >$$PACKNAME.tar.gz)
++
++install:
++ install -D piozone /usr/bin/piozone
+diff -Naur piozone-1.0.orig/piozone.c piozone-1.0/piozone.c
+--- piozone-1.0.orig/piozone.c 2003-07-10 18:54:51.000000000 -0300
++++ piozone-1.0/piozone.c 2003-07-10 14:48:44.000000000 -0300
+@@ -20,7 +20,7 @@
+ #include <fcntl.h>
+ #include <time.h>
+ #include <signal.h>
+-
++#define uint64_t u_int64_t
+ #define KiB ((uint64_t) 1024)
+ #define MiB ((uint64_t) 1024*KiB)
+ #define GiB ((uint64_t) 1024*MiB)
+@@ -73,7 +73,7 @@
+ int count = 0;
+ int nr = 0;
+
+- llseek(fd, off, SEEK_SET);
++ lseek64(fd, off, SEEK_SET);
+ signal(SIGALRM, sigalrm_handler);
+ stopf = 0;
+ printf("Testing... ");
+@@ -121,7 +121,7 @@
+ printf("Testing... ");
+ alarm(ts);
+ while (!stopf &&
+- llseek(fd, off+((rand()&area)*MiB), SEEK_SET) != -1 &&
++ lseek64(fd, off+((rand()&area)*MiB), SEEK_SET) != -1 &&
+ (nr = read(fd, iobuf, len)) == len)
+ {
+ print_dial();
+@@ -159,7 +159,7 @@
+ off = 0;
+ del = 64*GiB;
+
+- while (del > 8*KiB && llseek(fd, off+del, SEEK_SET) != -1)
++ while (del > 8*KiB && lseek64(fd, off+del, SEEK_SET) != -1)
+ {
+ if (read(fd, buf, 8*KiB) < 0)
+ del >>= 1;
diff --git a/app-benchmarks/piozone/piozone-1.0-r2.ebuild b/app-benchmarks/piozone/piozone-1.0-r2.ebuild
new file mode 100644
index 000000000000..2f1a3bb8c467
--- /dev/null
+++ b/app-benchmarks/piozone/piozone-1.0-r2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header :$
+
+DESCRIPTION="A hard-disk benchmarking tool."
+HOMEPAGE="http://www2.lysator.liu.se/~pen/piozone/"
+LICENSE="GPL-2"
+
+DEPEND="sys-devel/gcc"
+
+IUSE=""
+SLOT="0"
+KEYWORDS="~x86"
+S=${WORKDIR}/${P}
+SRC_URI="ftp://ftp.lysator.liu.se/pub/unix/${PN}/${P}.tar.gz"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${P}-gentoo.diff || die
+}
+
+src_compile() {
+ emake || die
+}
+
+src_install() {
+ dosbin piozone
+}