summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2010-11-11 12:49:52 +0000
committerPatrick Lauer <patrick@gentoo.org>2010-11-11 12:49:52 +0000
commitaa8328ee1ae2d9ecd3b0fad140f71e42eb14ff2a (patch)
treef484241297aa10833095fe188ff67cca1556e99b /app-benchmarks/stress
parentAutomated update of use.local.desc (diff)
downloadgentoo-2-aa8328ee1ae2d9ecd3b0fad140f71e42eb14ff2a.tar.gz
gentoo-2-aa8328ee1ae2d9ecd3b0fad140f71e42eb14ff2a.tar.bz2
gentoo-2-aa8328ee1ae2d9ecd3b0fad140f71e42eb14ff2a.zip
Bump
(Portage version: 2.2.0_alpha4/cvs/Linux x86_64)
Diffstat (limited to 'app-benchmarks/stress')
-rw-r--r--app-benchmarks/stress/ChangeLog7
-rw-r--r--app-benchmarks/stress/stress-1.0.4.ebuild45
2 files changed, 51 insertions, 1 deletions
diff --git a/app-benchmarks/stress/ChangeLog b/app-benchmarks/stress/ChangeLog
index b43f2fdb8f9f..3c3206f3e4bd 100644
--- a/app-benchmarks/stress/ChangeLog
+++ b/app-benchmarks/stress/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-benchmarks/stress
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/stress/ChangeLog,v 1.43 2010/02/26 20:58:51 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/stress/ChangeLog,v 1.44 2010/11/11 12:49:52 patrick Exp $
+
+*stress-1.0.4 (11 Nov 2010)
+
+ 11 Nov 2010; Patrick Lauer <patrick@gentoo.org> +stress-1.0.4.ebuild:
+ Bump
*stress-1.0.3 (26 Feb 2010)
diff --git a/app-benchmarks/stress/stress-1.0.4.ebuild b/app-benchmarks/stress/stress-1.0.4.ebuild
new file mode 100644
index 000000000000..f7b89d72852e
--- /dev/null
+++ b/app-benchmarks/stress/stress-1.0.4.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/stress/stress-1.0.4.ebuild,v 1.1 2010/11/11 12:49:52 patrick Exp $
+
+inherit autotools flag-o-matic
+
+MY_P="${PN}-${PV/_/}"
+S="${WORKDIR}/${MY_P}"
+DESCRIPTION="Imposes stressful loads on different aspects of the system."
+HOMEPAGE="http://weather.ou.edu/~apw/projects/stress"
+SRC_URI="http://weather.ou.edu/~apw/projects/stress/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="static"
+
+DEPEND="sys-apps/help2man"
+RDEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Force rebuild of the manpage.
+ rm -f doc/stress.1
+
+ # Honour Gentoo CFLAGS.
+ sed -i -e "/CFLAGS/s/-Werror//" \
+ -e "s/CFLAGS/AM_CFLAGS/" \
+ src/Makefile.am || die "sed cflags failed"
+
+ eautoreconf
+}
+
+src_compile() {
+ use static && append-ldflags -static
+ econf
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc ChangeLog AUTHORS README
+}