summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2011-01-19 01:06:34 +0000
committerMiroslav Šulc <fordfrog@gentoo.org>2011-01-19 01:06:34 +0000
commit0418635319c95c79c94ae148c7f1dd193e697d47 (patch)
treedce9cc982d948dfb1395164c3bb81781503df1f1 /app-benchmarks
parentBug #350641: Backported upstream patch to a^Cow multi-screen setups with libX... (diff)
downloadgentoo-2-0418635319c95c79c94ae148c7f1dd193e697d47.tar.gz
gentoo-2-0418635319c95c79c94ae148c7f1dd193e697d47.tar.bz2
gentoo-2-0418635319c95c79c94ae148c7f1dd193e697d47.zip
app-benchmarks/bootchart: fixed bug #348847
(Portage version: 2.1.9.33/cvs/Linux x86_64)
Diffstat (limited to 'app-benchmarks')
-rw-r--r--app-benchmarks/bootchart/ChangeLog8
-rw-r--r--app-benchmarks/bootchart/bootchart-0.9-r2.ebuild16
-rw-r--r--app-benchmarks/bootchart/bootchart-0.9-r3.ebuild16
-rw-r--r--app-benchmarks/bootchart/bootchart-0.9-r4.ebuild16
4 files changed, 39 insertions, 17 deletions
diff --git a/app-benchmarks/bootchart/ChangeLog b/app-benchmarks/bootchart/ChangeLog
index 0e0ab7d0f94c..87da98904af6 100644
--- a/app-benchmarks/bootchart/ChangeLog
+++ b/app-benchmarks/bootchart/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-benchmarks/bootchart
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/bootchart/ChangeLog,v 1.14 2010/04/27 13:10:55 caster Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/bootchart/ChangeLog,v 1.15 2011/01/19 01:06:34 fordfrog Exp $
+
+ 19 Jan 2011; Miroslav Šulc <fordfrog@gentoo.org> bootchart-0.9-r2.ebuild,
+ bootchart-0.9-r3.ebuild, bootchart-0.9-r4.ebuild:
+ Improved elog messages, bug #348847
*bootchart-0.9-r4 (27 Apr 2010)
diff --git a/app-benchmarks/bootchart/bootchart-0.9-r2.ebuild b/app-benchmarks/bootchart/bootchart-0.9-r2.ebuild
index cb81d5aa48b4..554a70e15411 100644
--- a/app-benchmarks/bootchart/bootchart-0.9-r2.ebuild
+++ b/app-benchmarks/bootchart/bootchart-0.9-r2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/bootchart/bootchart-0.9-r2.ebuild,v 1.6 2010/04/27 13:10:55 caster Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/bootchart/bootchart-0.9-r2.ebuild,v 1.7 2011/01/19 01:06:34 fordfrog Exp $
inherit multilib eutils java-pkg-opt-2 java-ant-2
@@ -109,13 +109,19 @@ pkg_postinst() {
if use java; then
elog "The chart will be saved as /var/log/bootchart.png"
else
- elog "Post the file /var/log/bootchart.tgz here:"
- elog " http://www.bootchart.org/download.html"
- elog "to render the chart"
+ elog "If you want to auto render chart of boot process, you"
+ elog "have to enable 'java' USE flag on bootchart. For details"
+ elog "see bootchart configuration file."
fi
elog
elog "For best results: "
+
+ if ! use acct ; then
+ elog " Enable 'acct' USE flag on bootchart to enable "
+ elog " process accounting support in bootchart"
+ fi
+
elog " Enable BSD process accounting v3 in the kernel"
elog " This will produce more accurate process trees"
elog " Set AUTO_RENDER_FORMAT to svg in /etc/bootchartd.conf"
diff --git a/app-benchmarks/bootchart/bootchart-0.9-r3.ebuild b/app-benchmarks/bootchart/bootchart-0.9-r3.ebuild
index c0e960633efe..05936f6ccacc 100644
--- a/app-benchmarks/bootchart/bootchart-0.9-r3.ebuild
+++ b/app-benchmarks/bootchart/bootchart-0.9-r3.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/bootchart/bootchart-0.9-r3.ebuild,v 1.2 2010/04/27 13:10:55 caster Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/bootchart/bootchart-0.9-r3.ebuild,v 1.3 2011/01/19 01:06:34 fordfrog Exp $
inherit multilib eutils java-pkg-opt-2 java-ant-2
@@ -110,13 +110,19 @@ pkg_postinst() {
if use java; then
elog "The chart will be saved as /var/log/bootchart.png"
else
- elog "Post the file /var/log/bootchart.tgz here:"
- elog " http://www.bootchart.org/download.html"
- elog "to render the chart"
+ elog "If you want to auto render chart of boot process, you"
+ elog "have to enable 'java' USE flag on bootchart. For details"
+ elog "see bootchart configuration file."
fi
elog
elog "For best results: "
+
+ if ! use acct ; then
+ elog " Enable 'acct' USE flag on bootchart to enable "
+ elog " process accounting support in bootchart"
+ fi
+
elog " Enable BSD process accounting v3 in the kernel"
elog " This will produce more accurate process trees"
elog " Set AUTO_RENDER_FORMAT to svg in /etc/bootchartd.conf"
diff --git a/app-benchmarks/bootchart/bootchart-0.9-r4.ebuild b/app-benchmarks/bootchart/bootchart-0.9-r4.ebuild
index a30509b3bb3f..0c92a1013f5a 100644
--- a/app-benchmarks/bootchart/bootchart-0.9-r4.ebuild
+++ b/app-benchmarks/bootchart/bootchart-0.9-r4.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/bootchart/bootchart-0.9-r4.ebuild,v 1.1 2010/04/27 13:10:55 caster Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/bootchart/bootchart-0.9-r4.ebuild,v 1.2 2011/01/19 01:06:34 fordfrog Exp $
EAPI="2"
JAVA_PKG_IUSE="source"
@@ -112,13 +112,19 @@ pkg_postinst() {
if use java; then
elog "The chart will be saved as /var/log/bootchart.png"
else
- elog "Post the file /var/log/bootchart.tgz here:"
- elog " http://www.bootchart.org/download.html"
- elog "to render the chart"
+ elog "If you want to auto render chart of boot process, you"
+ elog "have to enable 'java' USE flag on bootchart. For details"
+ elog "see bootchart configuration file."
fi
elog
elog "For best results: "
+
+ if ! use acct ; then
+ elog " Enable 'acct' USE flag on bootchart to enable "
+ elog " process accounting support in bootchart"
+ fi
+
elog " Enable BSD process accounting v3 in the kernel"
elog " This will produce more accurate process trees"
elog " Set AUTO_RENDER_FORMAT to svg in /etc/bootchartd.conf"