summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2013-03-25 20:51:50 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2013-03-25 20:51:50 +0000
commit0f724d7082cb32a5639ca4e72ff8f7a7747c6335 (patch)
tree274ee2ed673306f9167fcc952e95ac139d61dc27 /app-benchmarks
parentStable for x86, wrt bug #456614 (diff)
downloadgentoo-2-0f724d7082cb32a5639ca4e72ff8f7a7747c6335.tar.gz
gentoo-2-0f724d7082cb32a5639ca4e72ff8f7a7747c6335.tar.bz2
gentoo-2-0f724d7082cb32a5639ca4e72ff8f7a7747c6335.zip
Bump. Move from /usr/libexec/ to /opt/ because the runltp-path.patch is not easy to maintain. Also move away from /usr as it may be mounted RO but runltp writes to the ltp root directory (in this case /opt//)
(Portage version: 2.1.11.58/cvs/Linux x86_64, signed Manifest commit with key C2BA7F3C!)
Diffstat (limited to 'app-benchmarks')
-rw-r--r--app-benchmarks/ltp/ChangeLog10
-rw-r--r--app-benchmarks/ltp/ltp-20130109.ebuild82
-rw-r--r--app-benchmarks/ltp/metadata.xml5
3 files changed, 93 insertions, 4 deletions
diff --git a/app-benchmarks/ltp/ChangeLog b/app-benchmarks/ltp/ChangeLog
index b8dc869b3803..097cb16d09b7 100644
--- a/app-benchmarks/ltp/ChangeLog
+++ b/app-benchmarks/ltp/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-benchmarks/ltp
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/ltp/ChangeLog,v 1.21 2013/02/15 17:23:17 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/ltp/ChangeLog,v 1.22 2013/03/25 20:51:50 hwoarang Exp $
+
+*ltp-20130109 (25 Mar 2013)
+
+ 25 Mar 2013; Markos Chandras <hwoarang@gentoo.org> +ltp-20130109.ebuild,
+ metadata.xml:
+ Bump. Move from /usr/libexec/ to /opt/ because the runltp-path.patch is not
+ easy to maintain. Also move away from /usr as it may be mounted RO but runltp
+ writes to the ltp root directory (in this case /opt//)
15 Feb 2013; Pacho Ramos <pacho@gentoo.org> ltp-20120903.ebuild:
Don't show elog messages always (#457596)
diff --git a/app-benchmarks/ltp/ltp-20130109.ebuild b/app-benchmarks/ltp/ltp-20130109.ebuild
new file mode 100644
index 000000000000..df081ea057a7
--- /dev/null
+++ b/app-benchmarks/ltp/ltp-20130109.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/ltp/ltp-20130109.ebuild,v 1.1 2013/03/25 20:51:50 hwoarang Exp $
+
+EAPI="4"
+
+inherit autotools eutils readme.gentoo
+
+MY_PN="${PN}-full"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A testsuite for the linux kernel"
+HOMEPAGE="http://ltp.sourceforge.net/"
+SRC_URI="mirror://sourceforge/ltp/LTP%20Source/${P}/${MY_P}.bz2 -> ${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="expect perl pm open-posix python rt"
+
+DEPEND="expect? ( dev-tcltk/expect )
+ perl? ( dev-lang/perl )
+ python? ( dev-lang/python )"
+
+RESTRICT="test"
+
+S="${WORKDIR}"/${MY_P}
+
+pkg_setup() {
+ # Don't create groups
+ export CREATE=0
+
+ DOC_CONTENTS="LTP requires root access to run the tests.
+ The LTP root directory is located in /opt/${PN}.
+ For more information please read the ltp-howto located in
+ /usr/share/doc/${PF}"
+}
+
+src_prepare() {
+ # regenerate
+ AT_M4DIR="m4" eautoreconf
+}
+
+src_configure() {
+ # FIXME: improve me
+ local myconf=
+ use open-posix && myconf+="--with open-posix-testsuite "
+ use pm && mytconf+="--with-power-management-testsuite "
+ use rt && myconf+="--with-realtime-testsuite "
+ use perl && myconf+="--with-perl "
+ use python && myconf+="--with-python "
+ use expect && myconf+="--with-expect "
+
+ # Better put it into /opt/${PN} as everything needs to
+ # be under the same directory..
+
+ econf --prefix=/opt/${PN} ${myconf}
+}
+
+src_compile() {
+ # Posix testsuite does not seem to build with -j>1
+ # Is this maintained anymore?
+ if use open-posix; then
+ export MAKEOPTS="-j1"
+ fi
+ emake
+}
+
+src_install() {
+ default
+ dosym /usr/libexec/${PN}/runltp /usr/bin/runltp
+ # install docs
+ dodoc doc/MaintNotes
+ for txt in doc/*.txt; do
+ dodoc ${txt}
+ done
+ dodoc -r doc/examples doc/testcases
+ dohtml -r doc/automation-*.html
+ doman doc/man1/*.1
+ doman doc/man3/*.3
+ readme.gentoo_create_doc
+}
diff --git a/app-benchmarks/ltp/metadata.xml b/app-benchmarks/ltp/metadata.xml
index 30e3d2c35855..3ab3f2d99150 100644
--- a/app-benchmarks/ltp/metadata.xml
+++ b/app-benchmarks/ltp/metadata.xml
@@ -3,9 +3,8 @@
<pkgmetadata>
<herd>benchmarks</herd>
<maintainer>
- <email>hwoarang@gentoo.org</email>
- <name>Markos Chandras</name>
- <description>Maintainer</description>
+ <email>hwoarang@gentoo.org</email>
+ <name>Markos Chandras</name>
</maintainer>
<use>
<flag name="open-posix">Build and install the POSIX testsuite</flag>