summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2008-05-02 14:21:50 +0000
committerTiziano Müller <dev-zero@gentoo.org>2008-05-02 14:21:50 +0000
commit2c73ea4799db6eb9c1f57165552e98f98863c72c (patch)
treea93cb9d6d1b63e1d54e616b0206aa212c3df17ca /app-benchmarks
parentcorrect ChangeLog (diff)
downloadgentoo-2-2c73ea4799db6eb9c1f57165552e98f98863c72c.tar.gz
gentoo-2-2c73ea4799db6eb9c1f57165552e98f98863c72c.tar.bz2
gentoo-2-2c73ea4799db6eb9c1f57165552e98f98863c72c.zip
Added patch to fix compilation problems with gcc-4.3
(Portage version: 2.1.5_rc6)
Diffstat (limited to 'app-benchmarks')
-rw-r--r--app-benchmarks/bonnie++/ChangeLog8
-rw-r--r--app-benchmarks/bonnie++/bonnie++-1.93c.ebuild9
-rw-r--r--app-benchmarks/bonnie++/files/bonnie++-1.93c-missing_include.patch46
3 files changed, 57 insertions, 6 deletions
diff --git a/app-benchmarks/bonnie++/ChangeLog b/app-benchmarks/bonnie++/ChangeLog
index 8b66218c4bf3..5bb674ed8913 100644
--- a/app-benchmarks/bonnie++/ChangeLog
+++ b/app-benchmarks/bonnie++/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-benchmarks/bonnie++
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/bonnie++/ChangeLog,v 1.21 2007/09/17 21:03:36 phreak Exp $
+# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/bonnie++/ChangeLog,v 1.22 2008/05/02 14:21:50 dev-zero Exp $
+
+ 02 May 2008; Tiziano Müller <dev-zero@gentoo.org>
+ +files/bonnie++-1.93c-missing_include.patch, bonnie++-1.93c.ebuild:
+ Added patch to fix compilation problems with gcc-4.3
17 Sep 2007; Christian Heim <phreak@gentoo.org> metadata.xml:
Removing johnm from metadata.xml (see #186467 for reference).
diff --git a/app-benchmarks/bonnie++/bonnie++-1.93c.ebuild b/app-benchmarks/bonnie++/bonnie++-1.93c.ebuild
index c4c5b454eeac..af17d32ac654 100644
--- a/app-benchmarks/bonnie++/bonnie++-1.93c.ebuild
+++ b/app-benchmarks/bonnie++/bonnie++-1.93c.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/bonnie++/bonnie++-1.93c.ebuild,v 1.10 2006/05/21 09:16:36 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/bonnie++/bonnie++-1.93c.ebuild,v 1.11 2008/05/02 14:21:50 dev-zero Exp $
inherit eutils
@@ -17,8 +17,9 @@ DEPEND=""
src_unpack() {
unpack ${A}
- cd ${S}
- epatch ${FILESDIR}/${P}-64bit.patch
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-64bit.patch" \
+ "${FILESDIR}/${P}-missing_include.patch"
}
src_compile() {
diff --git a/app-benchmarks/bonnie++/files/bonnie++-1.93c-missing_include.patch b/app-benchmarks/bonnie++/files/bonnie++-1.93c-missing_include.patch
new file mode 100644
index 000000000000..2afe02b496bd
--- /dev/null
+++ b/app-benchmarks/bonnie++/files/bonnie++-1.93c-missing_include.patch
@@ -0,0 +1,46 @@
+diff -Naur bonnie++-1.93c.orig/bon_csv2html.cpp bonnie++-1.93c/bon_csv2html.cpp
+--- bonnie++-1.93c.orig/bon_csv2html.cpp 2008-05-02 14:12:19.000000000 +0200
++++ bonnie++-1.93c/bon_csv2html.cpp 2008-05-02 14:13:57.000000000 +0200
+@@ -3,6 +3,7 @@
+ #include <vector>
+ #include <string.h>
+ #include <math.h>
++#include <stdlib.h>
+
+ // Maximum number of items expected on a csv line
+ #define MAX_ITEMS 48
+diff -Naur bonnie++-1.93c.orig/getc_putc.cpp bonnie++-1.93c/getc_putc.cpp
+--- bonnie++-1.93c.orig/getc_putc.cpp 2008-05-02 14:12:19.000000000 +0200
++++ bonnie++-1.93c/getc_putc.cpp 2008-05-02 14:19:15.000000000 +0200
+@@ -12,6 +12,7 @@
+ #include <sys/types.h>
+ #include <sys/stat.h>
+ #include <fcntl.h>
++#include <string.h>
+ #include <vector>
+
+ #include "duration.h"
+diff -Naur bonnie++-1.93c.orig/getc_putc_helper.cpp bonnie++-1.93c/getc_putc_helper.cpp
+--- bonnie++-1.93c.orig/getc_putc_helper.cpp 2008-05-02 14:12:19.000000000 +0200
++++ bonnie++-1.93c/getc_putc_helper.cpp 2008-05-02 14:19:57.000000000 +0200
+@@ -7,6 +7,7 @@
+ #include <sys/types.h>
+ #include <sys/stat.h>
+ #include <fcntl.h>
++#include <string.h>
+ #include "duration.h"
+ #include <vector>
+ #include "getc_putc.h"
+diff -Naur bonnie++-1.93c.orig/zcav.cpp bonnie++-1.93c/zcav.cpp
+--- bonnie++-1.93c.orig/zcav.cpp 2008-05-02 14:12:19.000000000 +0200
++++ bonnie++-1.93c/zcav.cpp 2008-05-02 14:20:42.000000000 +0200
+@@ -9,6 +9,9 @@
+ #include "getopt.h"
+ #endif
+
++#include <stdlib.h>
++#include <string.h>
++
+ #define TOO_MANY_LOOPS 100
+
+ void usage()