summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2013-11-27 04:00:30 +0000
committerPatrick Lauer <patrick@gentoo.org>2013-11-27 04:00:30 +0000
commit6c8ad408f3e4ef84d4f353e2c6d03fcb27ae38cf (patch)
tree6f8a1893956bae7f7688089ae841dd2434964f4c /app-benchmarks
parentarm stable, bug #487332 (diff)
downloadgentoo-2-6c8ad408f3e4ef84d4f353e2c6d03fcb27ae38cf.tar.gz
gentoo-2-6c8ad408f3e4ef84d4f353e2c6d03fcb27ae38cf.tar.bz2
gentoo-2-6c8ad408f3e4ef84d4f353e2c6d03fcb27ae38cf.zip
Bump
(Portage version: 2.2.7/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'app-benchmarks')
-rw-r--r--app-benchmarks/siege/ChangeLog7
-rw-r--r--app-benchmarks/siege/siege-3.0.5.ebuild50
2 files changed, 56 insertions, 1 deletions
diff --git a/app-benchmarks/siege/ChangeLog b/app-benchmarks/siege/ChangeLog
index 05109db7a433..468c487752eb 100644
--- a/app-benchmarks/siege/ChangeLog
+++ b/app-benchmarks/siege/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-benchmarks/siege
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/siege/ChangeLog,v 1.60 2013/09/13 06:48:31 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/siege/ChangeLog,v 1.61 2013/11/27 04:00:30 patrick Exp $
+
+*siege-3.0.5 (27 Nov 2013)
+
+ 27 Nov 2013; Patrick Lauer <patrick@gentoo.org> +siege-3.0.5.ebuild:
+ Bump
*siege-3.0.3 (13 Sep 2013)
diff --git a/app-benchmarks/siege/siege-3.0.5.ebuild b/app-benchmarks/siege/siege-3.0.5.ebuild
new file mode 100644
index 000000000000..edad8e26ba87
--- /dev/null
+++ b/app-benchmarks/siege/siege-3.0.5.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/siege/siege-3.0.5.ebuild,v 1.1 2013/11/27 04:00:30 patrick Exp $
+
+EAPI=4
+
+#WANT_AUTOMAKE=1.9
+
+inherit eutils bash-completion-r1 libtool autotools
+
+DESCRIPTION="A HTTP regression testing and benchmarking utility"
+HOMEPAGE="http://www.joedog.org/JoeDog/Siege"
+SRC_URI="http://www.joedog.org/pub/siege/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~hppa ~mips ~ppc ~x86"
+SLOT="0"
+IUSE="ssl"
+
+RDEPEND="ssl? ( >=dev-libs/openssl-0.9.6d )"
+DEPEND="${RDEPEND}
+ sys-devel/libtool"
+
+src_prepare() {
+ # bundled macros break recent libtool
+ sed -i -e 's/AC_PROG_SHELL//' configure.ac || die
+ rm *.m4 || die "failed to remove bundled macros"
+ eautoreconf
+}
+
+src_configure() {
+ local myconf
+ use ssl && myconf="--with-ssl=/usr" || myconf="--without-ssl"
+ econf ${myconf}
+}
+
+src_install() {
+ make DESTDIR="${D}" install
+
+ dodoc AUTHORS ChangeLog INSTALL MACHINES README* KNOWNBUGS \
+ doc/siegerc doc/urls.txt
+
+ newbashcomp "${FILESDIR}"/${PN}.bash-completion ${PN}
+}
+
+pkg_postinst() {
+ echo
+ elog "An example ~/.siegerc file has been installed in"
+ elog "/usr/share/doc/${PF}/"
+}