summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2004-05-06 02:13:05 +0000
committerDaniel Black <dragonheart@gentoo.org>2004-05-06 02:13:05 +0000
commit039bc0104a7d377047c0a973be3ce68b3526f2e2 (patch)
treedd7df650d48fa282352f60926bb23c158dd41b38 /app-cdr/arson/arson-0.9.8_beta2.ebuild
parentstable on x86 (Manifest recommit) (diff)
downloadgentoo-2-039bc0104a7d377047c0a973be3ce68b3526f2e2.tar.gz
gentoo-2-039bc0104a7d377047c0a973be3ce68b3526f2e2.tar.bz2
gentoo-2-039bc0104a7d377047c0a973be3ce68b3526f2e2.zip
Version bump. Previous patches aren't applicable in this version
Diffstat (limited to 'app-cdr/arson/arson-0.9.8_beta2.ebuild')
-rw-r--r--app-cdr/arson/arson-0.9.8_beta2.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/app-cdr/arson/arson-0.9.8_beta2.ebuild b/app-cdr/arson/arson-0.9.8_beta2.ebuild
new file mode 100644
index 000000000000..ecd7a7f3d96c
--- /dev/null
+++ b/app-cdr/arson/arson-0.9.8_beta2.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-cdr/arson/arson-0.9.8_beta2.ebuild,v 1.1 2004/05/06 02:13:05 dragonheart Exp $
+
+inherit kde eutils
+need-kde 3
+
+MY_P=${P/_/}
+
+DESCRIPTION="A KDE frontend to CD burning and CD ripping tools."
+HOMEPAGE="http://arson.sourceforge.net/"
+SRC_URI="mirror://sourceforge/arson/${MY_P}.tar.bz2"
+LICENSE="GPL-2"
+IUSE="oggvorbis"
+
+DEPEND=">=media-sound/cdparanoia-3.9.8
+ >=media-sound/bladeenc-0.94.2
+ >=app-cdr/cdrtools-1.11.24
+ >=media-sound/normalize-0.7.4
+ oggvorbis? ( media-libs/libvorbis
+ media-libs/libogg )
+ >=media-sound/lame-3.92
+ >=app-cdr/cdrdao-1.1.5
+ >=media-libs/flac-1.1.0"
+
+# ldd ./usr/bin/arson | cut -f 3 -d ' ' | xargs -n1 qpkg -f | sort | uniq
+# app-admin/fam *
+# dev-libs/expat *
+# kde-base/kdelibs *
+# media-libs/flac *
+# media-libs/fontconfig *
+# media-libs/freetype *
+# media-libs/jpeg *
+# media-libs/libart_lgpl *
+# media-libs/libmng *
+# media-libs/libogg *
+# media-libs/libpng *
+# media-libs/libvorbis *
+# sys-devel/gcc *
+# sys-libs/glibc *
+# sys-libs/zlib *
+# x11-base/xfree *
+# x11-libs/qt *
+
+# Runtime programs.
+# media-video/vcdimager
+
+KEYWORDS="~x86 ~sparc ~amd64"
+S=${WORKDIR}/${PN}
+
+
+src_compile() {
+ use oggvorbis && myconf="$myconf --with-vorbis" || myconf="$myconf --without-vorbis"
+ myconf="$myconf --with-flac"
+ kde_src_compile
+}