summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-09-09 08:46:44 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-09-09 08:46:44 +0000
commitf62a0bd18dbf97637d469275ae3a3d385aab79c6 (patch)
treedefcf0398d82b09589bac2acb327cf00a5dfe5d3 /app-cdr/gcombust
parentemake->make (diff)
downloadgentoo-2-f62a0bd18dbf97637d469275ae3a3d385aab79c6.tar.gz
gentoo-2-f62a0bd18dbf97637d469275ae3a3d385aab79c6.tar.bz2
gentoo-2-f62a0bd18dbf97637d469275ae3a3d385aab79c6.zip
cdrtools in RDEPEND
Diffstat (limited to 'app-cdr/gcombust')
-rw-r--r--app-cdr/gcombust/ChangeLog8
-rw-r--r--app-cdr/gcombust/gcombust-0.1.52.ebuild25
2 files changed, 21 insertions, 12 deletions
diff --git a/app-cdr/gcombust/ChangeLog b/app-cdr/gcombust/ChangeLog
index 393754fda14c..4401d2ef0339 100644
--- a/app-cdr/gcombust/ChangeLog
+++ b/app-cdr/gcombust/ChangeLog
@@ -1,9 +1,15 @@
# ChangeLog for app-cdr/gcombust
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-cdr/gcombust/ChangeLog,v 1.7 2002/08/14 09:34:49 pvdabeel Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-cdr/gcombust/ChangeLog,v 1.8 2002/09/09 08:46:44 seemant Exp $
*gcombust-0.1.52 (08 Jul 2002)
+ 09 Sep 2002; Seemant Kulleen <seemant@gentoo.org> gcombust-0.1.52.ebuild :
+
+ Added cdrtools to RDEPEND, else this package is not useful by itself.
+ Thanks to: Pierre-Henri.Jondot@wanadoo.fr (Pierre-Henri Jondot) in bug
+ #7628
+
14 Aug 2002; Pieter Van den Abeele <pvdabeel@gentoo.org> :
Added ppc keyword
diff --git a/app-cdr/gcombust/gcombust-0.1.52.ebuild b/app-cdr/gcombust/gcombust-0.1.52.ebuild
index 97629559ab35..b2d9c7a6f05c 100644
--- a/app-cdr/gcombust/gcombust-0.1.52.ebuild
+++ b/app-cdr/gcombust/gcombust-0.1.52.ebuild
@@ -1,33 +1,36 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/app-cdr/gcombust/gcombust-0.1.52.ebuild,v 1.4 2002/08/16 02:31:09 murphy Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-cdr/gcombust/gcombust-0.1.52.ebuild,v 1.5 2002/09/09 08:46:44 seemant Exp $
+S=${WORKDIR}/${P}
DESCRIPTION="A GUI for mkisofs/mkhybrid/cdda2wav/cdrecord/cdlabelgen"
HOMEPAGE="http://www.abo.fi/~jmunsin/gcombust/"
-
-DEPEND="=x11-libs/gtk+-1.2*
- nls? ( sys-devel/gettext )"
+SRC_URI="http://www.abo.fi/~jmunsin/gcombust/${P}.tar.gz"
SLOT="0"
LICENSE="GPL-2"
-SRC_URI="http://www.abo.fi/~jmunsin/gcombust/${P}.tar.gz"
-S=${WORKDIR}/${P}
KEYWORDS="x86 ppc sparc sparc64"
+DEPEND="=x11-libs/gtk+-1.2*
+ nls? ( sys-devel/gettext )"
+
+RDEPEND="app-cdr/cdrtools"
+
src_compile() {
- local myopts
+ local myconf
if [ -z "`use nls`" ]
then
- myopts="${myopts} --disable-nls"
+ myconf="${myconf} --disable-nls"
touch intl/libintl.h
else
- myopts="${myopts} --enable-nls"
+ myconf="${myconf} --enable-nls"
fi
- ./configure --host=${CHOST} \
+ ./configure \
+ --host=${CHOST} \
--prefix=/usr \
- ${myopts} \
+ ${myconf} \
|| die
emake || die
}