summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIoannis Aslanidis <deathwing00@gentoo.org>2008-05-31 21:12:15 +0000
committerIoannis Aslanidis <deathwing00@gentoo.org>2008-05-31 21:12:15 +0000
commit975cf46f18ea161d1660f074080dbff2cd67497d (patch)
tree19bf14a5c6a2ce25a1bfef428c7f42b966244252 /app-cdr/k3b
parentBug #214152, version bump. Includes fw_conntrack fixes per bug 195964. (diff)
downloadgentoo-2-975cf46f18ea161d1660f074080dbff2cd67497d.tar.gz
gentoo-2-975cf46f18ea161d1660f074080dbff2cd67497d.tar.bz2
gentoo-2-975cf46f18ea161d1660f074080dbff2cd67497d.zip
Version bump.
(Portage version: 2.1.5.2)
Diffstat (limited to 'app-cdr/k3b')
-rw-r--r--app-cdr/k3b/ChangeLog8
-rw-r--r--app-cdr/k3b/files/k3b-1.0.5-eject_186173.patch90
-rw-r--r--app-cdr/k3b/k3b-1.0.5.ebuild152
3 files changed, 249 insertions, 1 deletions
diff --git a/app-cdr/k3b/ChangeLog b/app-cdr/k3b/ChangeLog
index 8cbebe2cf3e2..897fac734a50 100644
--- a/app-cdr/k3b/ChangeLog
+++ b/app-cdr/k3b/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-cdr/k3b
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-cdr/k3b/ChangeLog,v 1.205 2008/04/26 22:43:49 philantrop Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-cdr/k3b/ChangeLog,v 1.206 2008/05/31 21:12:14 deathwing00 Exp $
+
+*k3b-1.0.5 (31 May 2008)
+
+ 31 May 2008; Ioannis Aslanidis <deathwing00@gentoo.org>
+ +files/k3b-1.0.5-eject_186173.patch, +k3b-1.0.5.ebuild:
+ Version bump. Fixes bug #224179.
*k3b-1.0.4-r1 (26 Apr 2008)
diff --git a/app-cdr/k3b/files/k3b-1.0.5-eject_186173.patch b/app-cdr/k3b/files/k3b-1.0.5-eject_186173.patch
new file mode 100644
index 000000000000..c0543c22d62b
--- /dev/null
+++ b/app-cdr/k3b/files/k3b-1.0.5-eject_186173.patch
@@ -0,0 +1,90 @@
+diff -ur k3b-1.0.4/ChangeLog k3b-1.0.4-verification-always-reload/ChangeLog
+--- k3b-1.0.4/ChangeLog 2007-11-02 10:55:57.000000000 +0100
++++ k3b-1.0.4-verification-always-reload/ChangeLog 2007-12-07 19:33:18.000000000 +0100
+@@ -4,9 +4,6 @@
+ * Unmount medium before DVD formatting
+ * Silently (without introducing new strings for translation) allow the burning of files
+ bigger than 4 GB with appropriate versions of genisoimage or mkisofs.
+- * Do only reload the medium before verification if necessary, i.e. if the newly written
+- track cannot be read otherwise (many old drives depend on this). Hopefully this will
+- at least work around the aweful "DMA disabled" bug for many users.
+
+ 1.0.3
+ =====
+diff -ur k3b-1.0.4/libk3b/jobs/k3bverificationjob.cpp k3b-1.0.4-verification-always-reload/libk3b/jobs/k3bverificationjob.cpp
+--- k3b-1.0.4/libk3b/jobs/k3bverificationjob.cpp 2007-11-02 10:55:53.000000000 +0100
++++ k3b-1.0.4-verification-always-reload/libk3b/jobs/k3bverificationjob.cpp 2007-07-21 21:53:53.000000000 +0200
+@@ -84,8 +84,6 @@
+ K3bPipe pipe;
+
+ bool readSuccessful;
+-
+- bool mediumHasBeenReloaded;
+ };
+
+
+@@ -151,13 +149,11 @@
+ d->currentTrackIndex = 0;
+ d->alreadyReadSectors = 0;
+
+- emit newTask( i18n("Checking medium") );
++ // first we need to reload and mount the device
++ emit newTask( i18n("Reloading the medium") );
+
+- d->mediumHasBeenReloaded = false;
+- connect( K3bDevice::sendCommand( K3bDevice::DeviceHandler::DISKINFO, d->device ),
+- SIGNAL(finished(K3bDevice::DeviceHandler*)),
+- this,
+- SLOT(slotDiskInfoReady(K3bDevice::DeviceHandler*)) );
++ connect( K3bDevice::reload( d->device ), SIGNAL(finished(bool)),
++ this, SLOT(slotMediaReloaded(bool)) );
+ }
+
+
+@@ -169,8 +165,6 @@
+ K3bDevice::MEDIA_WRITABLE,
+ i18n("Unable to Close the Tray") );
+
+- d->mediumHasBeenReloaded = true;
+-
+ emit newTask( i18n("Checking medium") );
+
+ connect( K3bDevice::sendCommand( K3bDevice::DeviceHandler::DISKINFO, d->device ),
+@@ -191,6 +185,12 @@
+ d->toc = dh->toc();
+ d->totalSectors = 0;
+
++ if ( d->toc.isEmpty() ) {
++ emit infoMessage( i18n( "No tracks to verify found." ), ERROR );
++ jobFinished( false );
++ return;
++ }
++
+ // just to be sure check if we actually have all the tracks
+ int i = 0;
+ for( QValueList<K3bVerificationJobTrackEntry>::iterator it = d->tracks.begin();
+@@ -201,21 +201,9 @@
+ (*it).trackNumber = d->toc.count();
+
+ if( (int)d->toc.count() < (*it).trackNumber ) {
+- if ( d->mediumHasBeenReloaded ) {
+- emit infoMessage( i18n("Internal Error: Verification job improperly initialized (%1)")
+- .arg( "Specified track number not found on medium" ), ERROR );
+- jobFinished( false );
+- return;
+- }
+- else {
+- // many drives need to reload the medium to return to a proper state
+- emit newTask( i18n("Reloading the medium") );
+- connect( K3bDevice::reload( d->device ),
+- SIGNAL(finished(bool)),
+- this,
+- SLOT(slotMediaReloaded(bool)) );
+- return;
+- }
++ emit infoMessage( i18n("Internal Error: Verification job improperly initialized"), ERROR );
++ jobFinished( false );
++ return;
+ }
+
+ d->totalSectors += trackLength( i );
diff --git a/app-cdr/k3b/k3b-1.0.5.ebuild b/app-cdr/k3b/k3b-1.0.5.ebuild
new file mode 100644
index 000000000000..707c30d9cdf0
--- /dev/null
+++ b/app-cdr/k3b/k3b-1.0.5.ebuild
@@ -0,0 +1,152 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-cdr/k3b/k3b-1.0.5.ebuild,v 1.1 2008/05/31 21:12:14 deathwing00 Exp $
+
+inherit kde eutils
+
+MY_P=${P/_/}
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="K3b, KDE CD Writing Software"
+HOMEPAGE="http://www.k3b.org/"
+SRC_URI="mirror://sourceforge/k3b/${MY_P}.tar.bz2"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd"
+IUSE="alsa css dvdr dvdread encode ffmpeg flac hal mp3 musepack musicbrainz
+ sndfile vcd vorbis emovix"
+
+DEPEND="hal? ( dev-libs/dbus-qt3-old sys-apps/hal )
+ media-libs/libsamplerate
+ media-libs/taglib
+ >=media-sound/cdparanoia-3.9.8
+ sndfile? ( media-libs/libsndfile )
+ ffmpeg? ( media-video/ffmpeg )
+ flac? ( media-libs/flac )
+ mp3? ( media-libs/libmad )
+ musepack? ( media-libs/libmpcdec )
+ vorbis? ( media-libs/libvorbis )
+ musicbrainz? ( =media-libs/musicbrainz-2* )
+ encode? ( media-sound/lame )
+ alsa? ( media-libs/alsa-lib )
+ dvdread? ( media-libs/libdvdread )"
+
+RDEPEND="${DEPEND}
+ virtual/cdrtools
+ >=app-cdr/cdrdao-1.1.7-r3
+ media-sound/normalize
+ dvdr? ( >=app-cdr/dvd+rw-tools-7.0 )
+ css? ( media-libs/libdvdcss )
+ encode? ( media-sound/sox
+ media-video/transcode )
+ vcd? ( media-video/vcdimager )
+ emovix? ( media-video/emovix )"
+
+DEPEND="${DEPEND}
+ dev-util/pkgconfig"
+
+need-kde 3.5
+
+I18N="${PN}-i18n-${PV}"
+
+# Supported languages and translated documentation
+LANGS="af ar bg br bs ca cs cy da de el en_GB es et eu fa fi fr ga gl he hi hu is it ja ka lt mk ms nb nds nl nn pa pl pt pt_BR ru rw se sk sr sr@Latn sv ta tr uk uz zh_CN zh_TW"
+for X in ${LANGS}; do
+ SRC_URI="${SRC_URI} linguas_${X}? ( mirror://sourceforge/k3b/${I18N}.tar.bz2 )"
+ IUSE="${IUSE} linguas_${X}"
+done
+
+pkg_setup() {
+ if use hal && has_version '<sys-apps/dbus-0.91' && ! built_with_use sys-apps/dbus qt3; then
+ eerror "You are trying to compile ${CATEGORY}/${PF} with the \"hal\" USE flag enabled,"
+ eerror "but sys-apps/dbus is not built with Qt3 support."
+ die "Please, rebuild sys-apps/dbus with the \"qt3\" USE flag."
+ fi
+ if use encode && ! built_with_use media-video/transcode dvdread; then
+ eerror "You are trying to compile ${CATEGORY}/${PF} with the \"encode\""
+ eerror "USE flag enabled, however media-video/transcode was not built"
+ eerror "with libdvdread support. Also keep in mind that enabling"
+ eerror "the dvdread USE flag will cause k3b to use libdvdread as well."
+ die "Please, rebuild media-video/transcode with the \"dvdread\" USE flag."
+ fi
+
+ if use flac && ! built_with_use --missing true media-libs/flac cxx; then
+ eerror "To build ${PN} with flac support you need the C++ bindings for flac."
+ eerror "Please enable the cxx USE flag for media-libs/flac"
+ die "Missing FLAC C++ bindings."
+ fi
+
+ kde_pkg_setup
+}
+
+src_unpack() {
+ kde_src_unpack
+
+ # Makes k3b eject and re-load properly again. Fixes bug 186173.
+ epatch "${FILESDIR}/${P}-eject_186173.patch"
+
+ # Fix the desktop file. cf. bug 208777.
+ sed -i -e "/MimeType/s:$:;:" "${S}"/src/k3b.desktop \
+ || die "Fixing the desktop file failed."
+
+ if [ -d "${WORKDIR}/${I18N}" ]; then
+ cd "${WORKDIR}/${I18N}"
+ for X in ${LANGS}; do
+ use linguas_${X} || rm -rf "${X}"
+ done
+ rm -f configure
+ fi
+ rm -f "${S}/configure"
+}
+
+src_compile() {
+ local myconf="--enable-libsuffix= \
+ --with-external-libsamplerate \
+ --without-resmgr \
+ --without-cdrecord-suid-root \
+ --without-k3bsetup \
+ $(use_with hal) \
+ $(use_with encode lame) \
+ $(use_with ffmpeg) \
+ $(use_with flac) \
+ $(use_with vorbis oggvorbis) \
+ $(use_with sndfile) \
+ $(use_with mp3 libmad) \
+ $(use_with musepack) \
+ $(use_with musicbrainz) \
+ $(use_with alsa)"
+
+ # Build process of K3b
+ kde_src_compile
+
+ # Build process of K3b-i18n
+ if [ -d "${WORKDIR}/${I18N}" ]; then
+ KDE_S="${WORKDIR}/${I18N}" \
+ kde_src_compile
+ fi
+}
+
+src_install() {
+ kde_src_install
+ dodoc FAQ KNOWNBUGS PERMISSIONS
+
+ if [ -d "${WORKDIR}/${I18N}" ]; then
+ KDE_S="${WORKDIR}/${I18N}" \
+ kde_src_install
+ fi
+}
+
+pkg_postinst() {
+ echo
+ elog "We don't install k3bsetup anymore because Gentoo doesn't need it."
+ elog "If you get warnings on start-up, uncheck the \"Check system"
+ elog "configuration\" option in the \"Misc\" settings window."
+ echo
+
+ local group=cdrom
+ use kernel_linux || group=operator
+ elog "Make sure you have proper read/write permissions on the cdrom device(s)."
+ elog "Usually, it is sufficient to be in the ${group} group."
+ echo
+}