summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-10-23 10:39:36 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-10-23 10:39:36 +0000
commit60ba271ee006b102159ea9d62e71206573ea9601 (patch)
treefe3c8d24a29be29738714d77c5e3d85fc9012c46 /app-cdr
parentVersion bump. (diff)
downloadgentoo-2-60ba271ee006b102159ea9d62e71206573ea9601.tar.gz
gentoo-2-60ba271ee006b102159ea9d62e71206573ea9601.tar.bz2
gentoo-2-60ba271ee006b102159ea9d62e71206573ea9601.zip
Fix segmentation fault with empty directories wrt #331135 by "Vladimir"
(Portage version: 2.2.0_alpha70/cvs/Linux x86_64)
Diffstat (limited to 'app-cdr')
-rw-r--r--app-cdr/xfburn/ChangeLog8
-rw-r--r--app-cdr/xfburn/files/xfburn-0.4.3-empty_directory_segmentation_fault.patch51
-rw-r--r--app-cdr/xfburn/xfburn-0.4.3-r2.ebuild44
3 files changed, 102 insertions, 1 deletions
diff --git a/app-cdr/xfburn/ChangeLog b/app-cdr/xfburn/ChangeLog
index 42be65b37268..a4af8e18eba9 100644
--- a/app-cdr/xfburn/ChangeLog
+++ b/app-cdr/xfburn/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-cdr/xfburn
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-cdr/xfburn/ChangeLog,v 1.34 2011/04/27 20:24:50 angelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-cdr/xfburn/ChangeLog,v 1.35 2011/10/23 10:39:36 ssuominen Exp $
+
+*xfburn-0.4.3-r2 (23 Oct 2011)
+
+ 23 Oct 2011; Samuli Suominen <ssuominen@gentoo.org> +xfburn-0.4.3-r2.ebuild,
+ +files/xfburn-0.4.3-empty_directory_segmentation_fault.patch:
+ Fix segmentation fault with empty directories wrt #331135 by "Vladimir"
27 Apr 2011; Christoph Mende <angelos@gentoo.org> xfburn-0.4.3-r1.ebuild:
Fixed gstreamer slot deps
diff --git a/app-cdr/xfburn/files/xfburn-0.4.3-empty_directory_segmentation_fault.patch b/app-cdr/xfburn/files/xfburn-0.4.3-empty_directory_segmentation_fault.patch
new file mode 100644
index 000000000000..d80f98eff580
--- /dev/null
+++ b/app-cdr/xfburn/files/xfburn-0.4.3-empty_directory_segmentation_fault.patch
@@ -0,0 +1,51 @@
+http://bugs.gentoo.org/show_bug.cgi?id=331135
+http://bugzilla.xfce.org/show_bug.cgi?id=6805
+
+--- xfburn/xfburn-data-composition.c
++++ xfburn/xfburn-data-composition.c
+@@ -1874,26 +1874,29 @@
+ g_error ("Failed adding %s as a node to the image: code %X!", src, r);
+ }
+
+- basename = g_path_get_basename (src);
++ /* Check names only for items not manually created (#613563) */
++ if (type != DATA_COMPOSITION_TYPE_DIRECTORY || src != NULL) {
++ basename = g_path_get_basename (src);
++
++ /* check if the file has been renamed */
++ if (strcmp (basename, name) != 0) {
++ /* rename the iso_node */
++ r = iso_node_set_name (node, name);
++
++ if (r == 0) {
++ /* The first string is the renamed name, the second one the original name */
++ xfce_warn (_("Duplicate filename '%s' for '%s'"), name, src);
++
++ g_free (basename);
++ g_free (name);
++ g_free (src);
+
+- /* check if the file has been renamed */
+- if (strcmp (basename, name) != 0) {
+- /* rename the iso_node */
+- r = iso_node_set_name (node, name);
+-
+- if (r == 0) {
+- /* The first string is the renamed name, the second one the original name */
+- xfce_warn (_("Duplicate filename '%s' for '%s'"), name, src);
+-
+- g_free (basename);
+- g_free (name);
+- g_free (src);
+-
+- continue;
++ continue;
++ }
+ }
++ g_free (basename);
+ }
+
+- g_free (basename);
+ g_free (name);
+ g_free (src);
+
diff --git a/app-cdr/xfburn/xfburn-0.4.3-r2.ebuild b/app-cdr/xfburn/xfburn-0.4.3-r2.ebuild
new file mode 100644
index 000000000000..49e0e0d874cf
--- /dev/null
+++ b/app-cdr/xfburn/xfburn-0.4.3-r2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-cdr/xfburn/xfburn-0.4.3-r2.ebuild,v 1.1 2011/10/23 10:39:36 ssuominen Exp $
+
+EAPI=4
+inherit xfconf
+
+DESCRIPTION="GTK+ based CD and DVD burning application"
+HOMEPAGE="http://goodies.xfce.org/projects/applications/xfburn"
+SRC_URI="mirror://xfce/src/apps/${PN}/0.4/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="dbus debug gstreamer thunar"
+
+RDEPEND=">=dev-libs/libburn-0.4.2
+ >=dev-libs/libisofs-0.6.2
+ >=x11-libs/gtk+-2.10:2
+ x11-themes/hicolor-icon-theme
+ >=xfce-base/libxfcegui4-4.8
+ >=xfce-base/exo-0.6
+ dbus? ( >=dev-libs/dbus-glib-0.88 )
+ gstreamer? ( media-libs/gstreamer:0.10
+ >=media-libs/gst-plugins-base-0.10.20:0.10 )
+ thunar? ( xfce-extra/thunar-vfs )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ dev-util/intltool
+ sys-devel/gettext"
+
+pkg_setup() {
+ PATCHES=( "${FILESDIR}"/${P}-empty_directory_segmentation_fault.patch )
+
+ XFCONF=(
+ $(use_enable dbus)
+ $(xfconf_use_debug)
+ $(use_enable gstreamer)
+ --disable-hal
+ $(use_enable thunar thunar-vfs)
+ )
+
+ DOCS=( AUTHORS ChangeLog NEWS README TODO )
+}