summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-07-12 04:29:06 +0000
committerMike Frysinger <vapier@gentoo.org>2004-07-12 04:29:06 +0000
commit918d8b19a5df0e6bddef01b3d24d176f0ea2127f (patch)
treefb454492c31f4848c92a33bf833e0897ab8a29d8 /app-cdr
parenttypo fix (Manifest recommit) (diff)
downloadgentoo-2-918d8b19a5df0e6bddef01b3d24d176f0ea2127f.tar.gz
gentoo-2-918d8b19a5df0e6bddef01b3d24d176f0ea2127f.tar.bz2
gentoo-2-918d8b19a5df0e6bddef01b3d24d176f0ea2127f.zip
only use ghetto method with old 2.6.x
Diffstat (limited to 'app-cdr')
-rw-r--r--app-cdr/cdemu/cdemu-0.6_beta.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/app-cdr/cdemu/cdemu-0.6_beta.ebuild b/app-cdr/cdemu/cdemu-0.6_beta.ebuild
index fdfd0c00d83a..ac26a2ead1d1 100644
--- a/app-cdr/cdemu/cdemu-0.6_beta.ebuild
+++ b/app-cdr/cdemu/cdemu-0.6_beta.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-cdr/cdemu/cdemu-0.6_beta.ebuild,v 1.7 2004/06/25 03:20:31 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-cdr/cdemu/cdemu-0.6_beta.ebuild,v 1.8 2004/07/12 04:29:06 vapier Exp $
inherit gcc flag-o-matic python
@@ -17,10 +17,10 @@ DEPEND="virtual/kernel"
RDEPEND="dev-lang/python"
src_compile() {
- if [ "${KV:0:3}" == "2.6" ] ; then
+ if [ "${KV:0:3}" == "2.6" ] && [[ `KV_to_int ${KV}` -lt `KV_to_int 2.6.6` ]] ; then
emake KERN_DIR=/usr/src/linux BUILD_GHETTO=yes || die
else
- emake KERN_DIR=/usr/src/linux || die
+ env -u ARCH emake KERN_DIR=/usr/src/linux || die
fi
}