summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Weiler <pylon@gentoo.org>2006-11-11 13:01:30 +0000
committerLars Weiler <pylon@gentoo.org>2006-11-11 13:01:30 +0000
commitaab6f70d2b00fd02f30fe58e321465c464d55f76 (patch)
tree2216709df077f5a46a23789d05d8c11c33a3f31b /app-cdr
parentstable on amd64 (diff)
downloadgentoo-2-aab6f70d2b00fd02f30fe58e321465c464d55f76.tar.gz
gentoo-2-aab6f70d2b00fd02f30fe58e321465c464d55f76.tar.bz2
gentoo-2-aab6f70d2b00fd02f30fe58e321465c464d55f76.zip
Extended the cdrecord2wodim.patch so that it works with cdrkit-1.0_pre5.
(Portage version: 2.1.2_rc1-r5)
Diffstat (limited to 'app-cdr')
-rw-r--r--app-cdr/xcdroast/ChangeLog6
-rw-r--r--app-cdr/xcdroast/files/cdrecord2wodim.patch16
-rw-r--r--app-cdr/xcdroast/xcdroast-0.98_alpha15-r4.ebuild14
3 files changed, 24 insertions, 12 deletions
diff --git a/app-cdr/xcdroast/ChangeLog b/app-cdr/xcdroast/ChangeLog
index c8d355b91131..ffce2666b114 100644
--- a/app-cdr/xcdroast/ChangeLog
+++ b/app-cdr/xcdroast/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-cdr/xcdroast
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-cdr/xcdroast/ChangeLog,v 1.49 2006/11/11 04:51:57 pylon Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-cdr/xcdroast/ChangeLog,v 1.50 2006/11/11 13:01:30 pylon Exp $
+
+ 11 Nov 2006; Lars Weiler <pylon@gentoo.org> files/cdrecord2wodim.patch,
+ xcdroast-0.98_alpha15-r4.ebuild:
+ Extended the cdrecord2wodim.patch so that it works with cdrkit-1.0_pre5.
*xcdroast-0.98_alpha15-r4 (11 Nov 2006)
diff --git a/app-cdr/xcdroast/files/cdrecord2wodim.patch b/app-cdr/xcdroast/files/cdrecord2wodim.patch
index 8a9c486e7253..11668c540fe7 100644
--- a/app-cdr/xcdroast/files/cdrecord2wodim.patch
+++ b/app-cdr/xcdroast/files/cdrecord2wodim.patch
@@ -69,3 +69,19 @@ diff -urNad xcdroast-0.98alpha15.orig/src/xcdroast.h xcdroast-0.98alpha15/src/xc
#define CDDA2WAV "bin/cdda2wav"
#define READCD "bin/readcd"
#define MKISOFS "bin/mkisofs"
+diff -urNad xcdroast-0.98alpha15.orig/src/io.c xcdroast-0.98alpha15/src/io.c
+--- xcdroast-0.98alpha15.orig/src/io.c 2006-11-11 13:39:27.000000000 +0100
++++ xcdroast-0.98alpha15/src/io.c 2006-11-11 13:40:59.000000000 +0100
+@@ -348,6 +348,12 @@
+ return;
+ }
+
++ /* as of cdrkit-1.0_pre5 we need to test for wodim: as well */
++ strcpy(tmp,"wodim: ");
++ if (strncmp(line, tmp, strlen(tmp)) == 0) {
++ return;
++ }
++
+ /* a line with device-info found (by checking for ")")*/
+ p1 = index(line,')');
+ if (p1 != NULL && !strstr(line,")\"") &&
diff --git a/app-cdr/xcdroast/xcdroast-0.98_alpha15-r4.ebuild b/app-cdr/xcdroast/xcdroast-0.98_alpha15-r4.ebuild
index 6c694f7238f1..cdc0f41e8a3c 100644
--- a/app-cdr/xcdroast/xcdroast-0.98_alpha15-r4.ebuild
+++ b/app-cdr/xcdroast/xcdroast-0.98_alpha15-r4.ebuild
@@ -1,18 +1,18 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-cdr/xcdroast/xcdroast-0.98_alpha15-r4.ebuild,v 1.1 2006/11/11 04:51:57 pylon Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-cdr/xcdroast/xcdroast-0.98_alpha15-r4.ebuild,v 1.2 2006/11/11 13:01:30 pylon Exp $
inherit eutils
S=${WORKDIR}/${P/_/}
-DESCRIPTION="Menu based front-end to mkisofs and cdrecord"
+DESCRIPTION="Old-school menu based front-end for CD and DVD writing"
HOMEPAGE="http://www.xcdroast.org/"
SRC_URI="mirror://sourceforge/xcdroast/${P/_/}.tar.gz
mirror://gentoo/${P}_new_configure.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~x86 ~ppc ~sparc ~amd64"
-IUSE="nls dvdr"
+IUSE="nls"
DEPEND=">=x11-libs/gtk+-2.0.3
dev-util/pkgconfig"
@@ -58,11 +58,3 @@ src_install() {
make_desktop_entry xcdroast "X-CD-Roast" xcdroast "AudioVideo;DiscBurning"
}
-
-pkg_postinst() {
- if use dvdr; then
- einfo "As both cdrkit and cdrtools are capable of DVD writing they"
- einfo "can be used with xcdroast. But you have to start xcdroast"
- einfo "with the option '-n' to skip the version check."
- fi
-}