summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2013-06-15 22:19:08 +0000
committerAlon Bar-Lev <alonbl@gentoo.org>2013-06-15 22:19:08 +0000
commitf2bf2bac3a5dfac13e3821664f8b34da053c525e (patch)
tree14bf98ef12631f51b9a8ae614177d85472cb86ab /app-crypt/bsign
parentRemove old (diff)
downloadgentoo-2-f2bf2bac3a5dfac13e3821664f8b34da053c525e.tar.gz
gentoo-2-f2bf2bac3a5dfac13e3821664f8b34da053c525e.tar.bz2
gentoo-2-f2bf2bac3a5dfac13e3821664f8b34da053c525e.zip
fix flags issue bug#442650, malformed scripts bug#442656
(Portage version: 2.2.0_alpha179/cvs/Linux x86_64, signed Manifest commit with key BF20DC51)
Diffstat (limited to 'app-crypt/bsign')
-rw-r--r--app-crypt/bsign/ChangeLog8
-rw-r--r--app-crypt/bsign/bsign-0.4.5-r1.ebuild34
-rw-r--r--app-crypt/bsign/files/bsign-0.4.5-build.patch31
-rw-r--r--app-crypt/bsign/files/bsign-0.4.5-scripts.patch48
4 files changed, 120 insertions, 1 deletions
diff --git a/app-crypt/bsign/ChangeLog b/app-crypt/bsign/ChangeLog
index 6d940775b653..8d64f0c1c5df 100644
--- a/app-crypt/bsign/ChangeLog
+++ b/app-crypt/bsign/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-crypt/bsign
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/bsign/ChangeLog,v 1.16 2013/06/02 10:54:15 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/bsign/ChangeLog,v 1.17 2013/06/15 22:19:08 alonbl Exp $
+
+*bsign-0.4.5-r1 (15 Jun 2013)
+
+ 15 Jun 2013; Alon Bar-Lev <alonbl@gentoo.org> +bsign-0.4.5-r1.ebuild,
+ +files/bsign-0.4.5-build.patch, +files/bsign-0.4.5-scripts.patch:
+ fix flags issue bug#442650, malformed scripts bug#442656
02 Jun 2013; Pacho Ramos <pacho@gentoo.org> metadata.xml:
Cleanup due bug #328951
diff --git a/app-crypt/bsign/bsign-0.4.5-r1.ebuild b/app-crypt/bsign/bsign-0.4.5-r1.ebuild
new file mode 100644
index 000000000000..1e0804786880
--- /dev/null
+++ b/app-crypt/bsign/bsign-0.4.5-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/bsign/bsign-0.4.5-r1.ebuild,v 1.1 2013/06/15 22:19:08 alonbl Exp $
+
+EAPI=5
+inherit autotools flag-o-matic eutils toolchain-funcs
+
+DESCRIPTION="embed secure hashes (SHA1) and digital signatures (GNU Privacy Guard) into files"
+HOMEPAGE="http://packages.debian.org/sid/bsign"
+SRC_URI="mirror://debian/pool/main/b/${PN}/${PN}_${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc-macos ~x86 ~x86-linux"
+IUSE="static-libs"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-non-gnu.patch # for Darwin, BSD, Solaris, etc.
+ epatch "${FILESDIR}"/${P}-build.patch
+ epatch "${FILESDIR}"/${P}-scripts.patch
+ eautoreconf
+}
+
+src_configure() {
+ use static-libs && append-ldflags -static
+ default
+}
+
+src_install() {
+ dobin bsign_sign bsign_verify bsign_hash bsign_check
+ newbin o/bsign-unstripped bsign
+ doman bsign.1
+ dodoc README
+}
diff --git a/app-crypt/bsign/files/bsign-0.4.5-build.patch b/app-crypt/bsign/files/bsign-0.4.5-build.patch
new file mode 100644
index 000000000000..c6e40ada4cb2
--- /dev/null
+++ b/app-crypt/bsign/files/bsign-0.4.5-build.patch
@@ -0,0 +1,31 @@
+diff -urNp bsign-0.4.5/configure.in bsign-0.4.5.new/configure.in
+--- bsign-0.4.5/configure.in 2002-01-18 03:16:44.000000000 +0200
++++ bsign-0.4.5.new/configure.in 2013-06-16 00:54:36.470673947 +0300
+@@ -14,12 +14,8 @@ AC_PROG_LN_S
+ AC_PROG_MAKE_SET
+ AC_PROG_INSTALL
+
+-CFLAGS=-g
+-CXXFLAGS=-g
+-
+ if test "${GXX}" = "yes" ; then
+ CFLAGS_W=" -Wall -Wno-parentheses -Wno-unused"
+- CFLAGS="${CFLAGS}"
+ fi
+
+ dnl Checks for header files.
+diff -urNp bsign-0.4.5/Makefile.in bsign-0.4.5.new/Makefile.in
+--- bsign-0.4.5/Makefile.in 2002-01-27 22:56:56.000000000 +0200
++++ bsign-0.4.5.new/Makefile.in 2013-06-16 00:56:30.254676986 +0300
+@@ -56,9 +56,8 @@ CFLAGS=@CFLAGS@ @DEFS@
+ #CFLAGS_O=-O2 -fomit-frame-pointer
+ #CFLAGS_P=$(CFLAGS) -pg
+ CFLAGS_=-g $(CFLAGS_I)@CFLAGS_W@ $(CFLAGS_O) $(CFLAGS_P)
+-CXXFLAGS=$(CFLAGS)
+-CXXFLAGS_=$(CFLAGS_)
+-LFLAGS=-g -static @LDFLAGS@ @LIBS@
++CXXFLAGS=@CXXFLAGS@ @DEFS@
++LFLAGS=-g @LDFLAGS@ @LIBS@
+ #LFLAGS=-g @LDFLAGS@ @LIBS@
+ #LFLAGS=-pg ${LFLAGS}
+ DEPEND=depend.m
diff --git a/app-crypt/bsign/files/bsign-0.4.5-scripts.patch b/app-crypt/bsign/files/bsign-0.4.5-scripts.patch
new file mode 100644
index 000000000000..97f79e68e29c
--- /dev/null
+++ b/app-crypt/bsign/files/bsign-0.4.5-scripts.patch
@@ -0,0 +1,48 @@
+diff -urNp bsign-0.4.5/bsign_check bsign-0.4.5.new2/bsign_check
+--- bsign-0.4.5/bsign_check 2002-01-27 22:49:04.000000000 +0200
++++ bsign-0.4.5.new2/bsign_check 2013-06-16 01:00:55.862655310 +0300
+@@ -9,7 +9,7 @@
+ # LOCATIONS gives the path includes and excludes that guide where
+ # bsign looks for input files.
+
+-LOCATIONS=-i / -e /boot -e /cdrom -e /dev -e /proc -e $BASE_PATH
++LOCATIONS="-i / -e /boot -e /cdrom -e /dev -e /proc -e $BASE_PATH"
+
+ # MAIL_TO is the list of email addresses that will receive email when
+ # this script terminates. The mail will contain the output of
+diff -urNp bsign-0.4.5/bsign_hash bsign-0.4.5.new2/bsign_hash
+--- bsign-0.4.5/bsign_hash 2002-01-27 22:49:04.000000000 +0200
++++ bsign-0.4.5.new2/bsign_hash 2013-06-16 01:00:43.543657092 +0300
+@@ -9,7 +9,7 @@
+ # LOCATIONS gives the path includes and excludes that guide where
+ # bsign looks for input files.
+
+-LOCATIONS=-i / -e /boot -e /cdrom -e /dev -e /proc
++LOCATIONS="-i / -e /boot -e /cdrom -e /dev -e /proc"
+
+ # --- End of customization macros
+
+diff -urNp bsign-0.4.5/bsign_sign bsign-0.4.5.new2/bsign_sign
+--- bsign-0.4.5/bsign_sign 2002-01-27 20:44:09.000000000 +0200
++++ bsign-0.4.5.new2/bsign_sign 2013-06-16 01:00:17.737660680 +0300
+@@ -23,7 +23,7 @@ KEY_PATH=$BASE_PATH
+ # LOCATIONS gives the path includes and excludes that guide where
+ # bsign looks for input files.
+
+-LOCATIONS=-i / -e /boot -e /cdrom -e /dev -e /proc -e $BASE_PATH
++LOCATIONS="-i / -e /boot -e /cdrom -e /dev -e /proc -e $BASE_PATH"
+
+ # --- End of customization macros
+
+diff -urNp bsign-0.4.5/bsign_verify bsign-0.4.5.new2/bsign_verify
+--- bsign-0.4.5/bsign_verify 2002-01-27 20:44:09.000000000 +0200
++++ bsign-0.4.5.new2/bsign_verify 2013-06-16 01:00:28.114659254 +0300
+@@ -23,7 +23,7 @@ KEY_PATH=$BASE_PATH
+ # LOCATIONS gives the path includes and excludes that guide where
+ # bsign looks for input files.
+
+-LOCATIONS=-i / -e /boot -e /cdrom -e /dev -e /proc -e $BASE_PATH
++LOCATIONS="-i / -e /boot -e /cdrom -e /dev -e /proc -e $BASE_PATH"
+ #LOCATIONS=-i /bin -i /sbin -i /usr/bin -i /usr/sbin
+
+ # MAIL_TO is the list of email addresses that will receive email when