summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2004-08-07 08:18:25 +0000
committerDaniel Black <dragonheart@gentoo.org>2004-08-07 08:18:25 +0000
commitf54fec0793a3465386b137ff802b44d5aaea4915 (patch)
tree22be272a6576a02987aef31b996a33f90bd1d62b /app-crypt/gpgme/gpgme-0.3.14-r1.ebuild
parentsee bug #57193 for the transition plan (diff)
downloadgentoo-2-f54fec0793a3465386b137ff802b44d5aaea4915.tar.gz
gentoo-2-f54fec0793a3465386b137ff802b44d5aaea4915.tar.bz2
gentoo-2-f54fec0793a3465386b137ff802b44d5aaea4915.zip
versions gpgme-0.3.14-r1 and gpgme-0.9.0-r1 commited as per bug #57193. Will unmask once dependancies are fixed
Diffstat (limited to 'app-crypt/gpgme/gpgme-0.3.14-r1.ebuild')
-rw-r--r--app-crypt/gpgme/gpgme-0.3.14-r1.ebuild94
1 files changed, 94 insertions, 0 deletions
diff --git a/app-crypt/gpgme/gpgme-0.3.14-r1.ebuild b/app-crypt/gpgme/gpgme-0.3.14-r1.ebuild
new file mode 100644
index 000000000000..2021f8ed60da
--- /dev/null
+++ b/app-crypt/gpgme/gpgme-0.3.14-r1.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/gpgme/gpgme-0.3.14-r1.ebuild,v 1.1 2004/08/07 08:18:25 dragonheart Exp $
+
+DESCRIPTION="GnuPG Made Easy (GPGME) is a library designed to make access to GnuPG easier for applications."
+HOMEPAGE="http://www.gnupg.org/gpgme.html"
+SRC_URI="ftp://ftp.gnupg.org/gcrypt/gpgme/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0.3"
+KEYWORDS="-*"
+IUSE="nls doc smime"
+
+DEPEND=">=sys-libs/zlib-1.1.3
+ >=app-crypt/gnupg-1.0.7
+ sys-apps/gawk
+ sys-devel/libtool
+ sys-devel/gcc
+ sys-devel/autoconf
+ sys-devel/automake
+ >=sys-apps/sed-4
+ nls? ( sys-devel/gettext )
+ >=app-crypt/gnupg-1.2.0
+ smime? ( >=app-crypt/newpg-0.9.2 )"
+
+RDEPEND="virtual/libc"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ find . -name Makefile -o -name Makefile.in -exec rm {} \;
+
+ sed -i -e 's:libgpgme:libgpgme3:g' \
+ `find . -name Makefile.am` doc/gpgme.info
+
+ sed -i -e 's:gpgme-config:gpgme3-config:g' \
+ configure.ac gpgme/Makefile.am doc/gpgme.texi \
+ ./doc/gpgme.info-1 gpgme/gpgme-config.in
+
+ sed -i -e 's:gpgme\.info:gpgme3.info:g' \
+ -e 's:gpgme\.texi:gpgme3\.texi:g' \
+ doc/Makefile.am doc/gpgme.info
+
+ sed -i -e 's:-lgpgme:-lgpgme3:g' \
+ gpgme/gpgme-config.in doc/gpgme.info-1 \
+ doc/gpgme.texi configure.ac
+
+ sed -i -e 's:gpgme\.m4:gpgme3.m4:g' \
+ -e 's:gpgme\.h:gpgme3.h:g' \
+ gpgme/Makefile.am configure.ac doc/gpgme.texi
+
+ sed -i -e 's:gpgme\.info:gpgme3.info:' doc/gpgme.texi
+
+ mv doc/gpgme{,3}.texi
+ mv gpgme/gpgme{,3}-config.in
+ mv gpgme/gpgme{,3}.m4
+ mv gpgme/gpgme{,3}.h
+}
+
+
+src_compile() {
+ local myconf
+
+ use doc \
+ && myconf="${myconf} --enable-maintainer-mode"
+
+ if [ -x ${ROOT}usr/bin/gpg2 ]; then
+ myconf="${myconf} --with-gpg=${ROOT}usr/bin/gpg2"
+ else
+ myconf="${myconf} --with-gpg=${ROOT}usr/bin/gpg2"
+ fi
+
+ aclocal
+ autoconf
+ automake
+
+ econf \
+ --enable-gpgmeplug \
+ --includedir=/usr/include/gpgme3 \
+ $(use_with smime gpgsm /usr/bin/gpgsm) \
+ `use_enable nls` \
+ --with-gpg=$GPGBIN \
+ ${myconf} \
+ || die "econf failed"
+
+
+ econf ${myconf} || die "econf failed"
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc AUTHORS ChangeLog INSTALL NEWS README README-alpha THANKS TODO VERSION
+}