summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRick Farina <zerochaos@gentoo.org>2012-08-06 03:20:47 +0000
committerRick Farina <zerochaos@gentoo.org>2012-08-06 03:20:47 +0000
commit26ca5475a7cc723fb2129d521aa02feed7ba2eae (patch)
treeb6265285c4db3f39913c2d4333e61dd127f17220 /app-crypt/hashcat-bin
parentEAPI bumped to 4 and included prefix patches (diff)
downloadgentoo-2-26ca5475a7cc723fb2129d521aa02feed7ba2eae.tar.gz
gentoo-2-26ca5475a7cc723fb2129d521aa02feed7ba2eae.tar.bz2
gentoo-2-26ca5475a7cc723fb2129d521aa02feed7ba2eae.zip
version bump to 0.40 and MacOSX (prefix) support
(Portage version: 2.1.11.9/cvs/Linux x86_64)
Diffstat (limited to 'app-crypt/hashcat-bin')
-rw-r--r--app-crypt/hashcat-bin/ChangeLog7
-rw-r--r--app-crypt/hashcat-bin/hashcat-bin-0.40.ebuild79
2 files changed, 85 insertions, 1 deletions
diff --git a/app-crypt/hashcat-bin/ChangeLog b/app-crypt/hashcat-bin/ChangeLog
index b898cba3e078..fa722b7910a6 100644
--- a/app-crypt/hashcat-bin/ChangeLog
+++ b/app-crypt/hashcat-bin/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-crypt/hashcat-bin
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/hashcat-bin/ChangeLog,v 1.4 2012/07/04 17:48:59 zerochaos Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/hashcat-bin/ChangeLog,v 1.5 2012/08/06 03:20:47 zerochaos Exp $
+
+*hashcat-bin-0.40 (06 Aug 2012)
+
+ 06 Aug 2012; Rick Farina <zerochaos@gentoo.org> +hashcat-bin-0.40.ebuild:
+ version bump to 0.40 and MacOSX (prefix) support
04 Jul 2012; Rick Farina <zerochaos@gentoo.org> hashcat-bin-0.39.ebuild:
minor QA for ebuild
diff --git a/app-crypt/hashcat-bin/hashcat-bin-0.40.ebuild b/app-crypt/hashcat-bin/hashcat-bin-0.40.ebuild
new file mode 100644
index 000000000000..2b7df40fb14d
--- /dev/null
+++ b/app-crypt/hashcat-bin/hashcat-bin-0.40.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/hashcat-bin/hashcat-bin-0.40.ebuild,v 1.1 2012/08/06 03:20:47 zerochaos Exp $
+
+EAPI=4
+
+MY_P="hashcat-${PV}"
+
+inherit eutils pax-utils
+DESCRIPTION="An multi-threaded multihash cracker"
+HOMEPAGE="http://hashcat.net/hashcat/"
+
+SRC_URI="http://hashcat.net/files/${MY_P}.7z"
+
+#license applies to this version per http://hashcat.net/forum/thread-1348.html
+LICENSE="hashcat"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~amd64-linux ~x64-macos ~x86 ~x86-linux"
+
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ app-arch/p7zip"
+
+S="${WORKDIR}/${MY_P}"
+
+RESTRICT="strip"
+QA_PREBUILT="opt/${PN}/hashcat-cli*.bin
+ opt/${PN}/hashcat-cli64.app"
+
+src_install() {
+ dodoc docs/*
+ rm -r *.exe docs || die
+ use x86 || { rm hashcat-cli32.bin || die; }
+ use amd64 || { rm hashcat-cli64.bin || die; }
+ use x64-macos || { rm hashcat-cli64.app || die; }
+
+ #I assume this is needed but I didn't check
+ pax-mark m hashcat-cli*.bin
+
+ insinto /opt/${PN}
+ doins -r "${S}"/*
+
+ dodir /opt/bin
+ if [ -f "${ED}"/opt/${PN}/hashcat-cli32.bin ]
+ then
+ fperms +x /opt/${PN}/hashcat-cli32.bin
+ cat <<-EOF > "${ED}"/opt/bin/hashcat-cli32.bin
+ #! /bin/sh
+ cd "${EPREFIX}"/opt/${PN}
+ echo "Warning: hashcat-cli32.bin is running from ${EPREFIX}/opt/${PN} so be careful of relative paths."
+ exec ./hashcat-cli32.bin $@
+ EOF
+ fperms +x /opt/bin/hashcat-cli32.bin
+ fi
+ if [ -f "${ED}"/opt/${PN}/hashcat-cli64.bin ]
+ then
+ fperms +x /opt/${PN}/hashcat-cli64.bin
+ cat <<-EOF > "${ED}"/opt/bin/hashcat-cli64.bin
+ #! /bin/sh
+ cd "${EPREFIX}"/opt/${PN}
+ echo "Warning: hashcat-cli64.bin is running from ${EPREFIX}/opt/${PN} so be careful of relative paths."
+ exec ./hashcat-cli64.bin $@
+ EOF
+ fperms +x /opt/bin/hashcat-cli64.bin
+ fi
+ if [ -f "${ED}"/opt/${PN}/hashcat-cli64.app ]
+ then
+ fperms +x /opt/${PN}/hashcat-cli64.app
+ cat <<-EOF > "${ED}"/opt/bin/hashcat-cli64.app
+ #! /bin/sh
+ cd "${EPREFIX}"/opt/${PN}
+ echo "Warning: hashcat-cli64.app is running from ${EPREFIX}/opt/${PN} so be careful of relative paths."
+ exec ./hashcat-cli64.app $@
+ EOF
+ fperms +x /opt/bin/hashcat-cli64.app
+ fi
+}