summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2013-04-05 06:32:55 +0000
committerTim Harder <radhermit@gentoo.org>2013-04-05 06:32:55 +0000
commit62d88e17d53360807fbd0355903b5c6ee6c0fe4a (patch)
tree5792c9c53f1bd0c02a14e4467ad4e7a397be4563 /app-crypt/p11-kit
parentRemove unused eutils inherit. (diff)
downloadgentoo-2-62d88e17d53360807fbd0355903b5c6ee6c0fe4a.tar.gz
gentoo-2-62d88e17d53360807fbd0355903b5c6ee6c0fe4a.tar.bz2
gentoo-2-62d88e17d53360807fbd0355903b5c6ee6c0fe4a.zip
Version bump.
(Portage version: 2.2.0_alpha171/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'app-crypt/p11-kit')
-rw-r--r--app-crypt/p11-kit/ChangeLog7
-rw-r--r--app-crypt/p11-kit/p11-kit-0.18.0.ebuild33
2 files changed, 39 insertions, 1 deletions
diff --git a/app-crypt/p11-kit/ChangeLog b/app-crypt/p11-kit/ChangeLog
index 614152e07c8b..227b32aaa47f 100644
--- a/app-crypt/p11-kit/ChangeLog
+++ b/app-crypt/p11-kit/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-crypt/p11-kit
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/p11-kit/ChangeLog,v 1.41 2013/03/31 07:07:06 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/p11-kit/ChangeLog,v 1.42 2013/04/05 06:32:55 radhermit Exp $
+
+*p11-kit-0.18.0 (05 Apr 2013)
+
+ 05 Apr 2013; Tim Harder <radhermit@gentoo.org> +p11-kit-0.18.0.ebuild:
+ Version bump.
*p11-kit-0.17.5 (31 Mar 2013)
diff --git a/app-crypt/p11-kit/p11-kit-0.18.0.ebuild b/app-crypt/p11-kit/p11-kit-0.18.0.ebuild
new file mode 100644
index 000000000000..8543313d6001
--- /dev/null
+++ b/app-crypt/p11-kit/p11-kit-0.18.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/p11-kit/p11-kit-0.18.0.ebuild,v 1.1 2013/04/05 06:32:55 radhermit Exp $
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="Provides a standard configuration setup for installing PKCS#11."
+HOMEPAGE="http://p11-glue.freedesktop.org/p11-kit.html"
+SRC_URI="http://p11-glue.freedesktop.org/releases/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~arm-linux ~x86-linux"
+IUSE="+asn1 debug +trust"
+REQUIRED_USE="trust? ( asn1 )"
+
+RDEPEND="asn1? ( >=dev-libs/libtasn1-2.14 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_configure() {
+ econf \
+ $(use_enable trust trust-module) \
+ $(use_enable debug) \
+ $(use_with asn1 libtasn1)
+}
+
+src_install() {
+ default
+ prune_libtool_files --modules
+}