summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBryan Østergaard <kloeri@gentoo.org>2004-06-21 00:01:38 +0000
committerBryan Østergaard <kloeri@gentoo.org>2004-06-21 00:01:38 +0000
commitb6a978dfb7b49ad7cea0e87f2c19eedae757b46f (patch)
treef8ecc172e591ec5148332d1454e653f9cbb086bd /app-crypt/pinentry/pinentry-0.7.1-r1.ebuild
parentAdded ~amd64 keyword. (Manifest recommit) (diff)
downloadgentoo-2-b6a978dfb7b49ad7cea0e87f2c19eedae757b46f.tar.gz
gentoo-2-b6a978dfb7b49ad7cea0e87f2c19eedae757b46f.tar.bz2
gentoo-2-b6a978dfb7b49ad7cea0e87f2c19eedae757b46f.zip
Add qt compile fix submitted by Sebastian Trueg <trueg@informatik.uni-freiburg.de> in bug #54225. Also use emake and einstall.
Diffstat (limited to 'app-crypt/pinentry/pinentry-0.7.1-r1.ebuild')
-rw-r--r--app-crypt/pinentry/pinentry-0.7.1-r1.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/app-crypt/pinentry/pinentry-0.7.1-r1.ebuild b/app-crypt/pinentry/pinentry-0.7.1-r1.ebuild
new file mode 100644
index 000000000000..87e14646cc9d
--- /dev/null
+++ b/app-crypt/pinentry/pinentry-0.7.1-r1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/pinentry/pinentry-0.7.1-r1.ebuild,v 1.1 2004/06/21 00:01:38 kloeri Exp $
+
+inherit eutils
+
+DESCRIPTION="collection of simple PIN or passphrase entry dialogs which utilize the Assuan protocol"
+HOMEPAGE="http://www.gnupg.org/aegypten/"
+SRC_URI="ftp://ftp.gnupg.org/gcrypt/pinentry/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~amd64"
+IUSE="qt gtk ncurses"
+
+DEPEND="gtk? ( x11-libs/gtk+ )
+ ncurses? ( sys-libs/ncurses )
+ qt? ( x11-libs/qt )
+ !gtk? ( !qt? ( !ncurses? ( sys-libs/ncurses ) ) )"
+
+src_unpack() {
+ unpack ${A}
+ epatch ${FILESDIR}/qt-compile-fix.diff
+}
+
+src_compile() {
+ local myconf=""
+ if ! use qt && ! use gtk && ! use ncurses ; then
+ myconf="--enable-pinentry-curses --enable-fallback-curses"
+ fi
+ econf \
+ `use_enable qt pinentry-qt` \
+ `use_enable gtk pinentry-gtk` \
+ `use_enable ncurses pinentry-curses` \
+ `use_enable ncurses fallback-curses` \
+ --disable-dependency-tracking \
+ ${myconf} \
+ || die
+ emake || die
+}
+
+src_install() {
+ einstall || die
+ dodoc AUTHORS ChangeLog NEWS README THANKS TODO
+
+ # The other two pinentries don't spit out an insecure memory warning when
+ # not suid root, and gtk refuses to start if pinentry-gtk is suid root.
+ fperms +s /usr/bin/pinentry-qt
+}
+
+pkg_postinst() {
+ einfo "pinentry-qt is installed SUID root to make use of protected memory space"
+ einfo "This is needed in order to have a secure place to store your passphrases,"
+ einfo "etc. at runtime but may make some sysadmins nervous"
+}