summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2010-01-02 21:46:50 +0000
committerBen de Groot <yngwin@gentoo.org>2010-01-02 21:46:50 +0000
commit406ca9a6990d20992cafc9ea4417192a073e9094 (patch)
treed2c71088597525e40e93b6ae9f806eeedeb859d6 /app-crypt/pinentry
parentDrop no longer present qt4 use dep (diff)
downloadgentoo-2-406ca9a6990d20992cafc9ea4417192a073e9094.tar.gz
gentoo-2-406ca9a6990d20992cafc9ea4417192a073e9094.tar.bz2
gentoo-2-406ca9a6990d20992cafc9ea4417192a073e9094.zip
Drop qt3 support
(Portage version: 2.2_rc61/cvs/Linux x86_64)
Diffstat (limited to 'app-crypt/pinentry')
-rw-r--r--app-crypt/pinentry/ChangeLog8
-rw-r--r--app-crypt/pinentry/pinentry-0.7.5-r1.ebuild26
-rw-r--r--app-crypt/pinentry/pinentry-0.7.5.ebuild21
-rw-r--r--app-crypt/pinentry/pinentry-0.7.6.ebuild20
4 files changed, 33 insertions, 42 deletions
diff --git a/app-crypt/pinentry/ChangeLog b/app-crypt/pinentry/ChangeLog
index d5f62d2b668d..2bef1f0e02de 100644
--- a/app-crypt/pinentry/ChangeLog
+++ b/app-crypt/pinentry/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-crypt/pinentry
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/pinentry/ChangeLog,v 1.96 2009/07/15 21:04:10 arfrever Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/pinentry/ChangeLog,v 1.97 2010/01/02 21:46:50 yngwin Exp $
+
+ 02 Jan 2010; Ben de Groot <yngwin@gentoo.org> pinentry-0.7.5.ebuild,
+ pinentry-0.7.5-r1.ebuild, pinentry-0.7.6.ebuild:
+ Drop qt3 support
15 Jul 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
pinentry-0.7.6.ebuild:
diff --git a/app-crypt/pinentry/pinentry-0.7.5-r1.ebuild b/app-crypt/pinentry/pinentry-0.7.5-r1.ebuild
index 239b21866303..7fa83d9051af 100644
--- a/app-crypt/pinentry/pinentry-0.7.5-r1.ebuild
+++ b/app-crypt/pinentry/pinentry-0.7.5-r1.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/pinentry/pinentry-0.7.5-r1.ebuild,v 1.2 2009/05/02 20:33:05 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/pinentry/pinentry-0.7.5-r1.ebuild,v 1.3 2010/01/02 21:46:50 yngwin Exp $
EAPI="1"
-inherit qt3 multilib eutils flag-o-matic
+inherit multilib eutils flag-o-matic
DESCRIPTION="Collection of simple PIN or passphrase entry dialogs which utilize the Assuan protocol"
HOMEPAGE="http://www.gnupg.org/aegypten/"
@@ -13,14 +13,13 @@ SRC_URI="mirror://gnupg/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
-IUSE="gtk ncurses qt3 caps static"
+IUSE="gtk ncurses caps static"
DEPEND="static? ( sys-libs/ncurses )
!static? (
gtk? ( x11-libs/gtk+:2 )
ncurses? ( sys-libs/ncurses )
- qt3? ( x11-libs/qt:3 )
- !gtk? ( !qt3? ( !ncurses? ( sys-libs/ncurses ) ) )
+ !gtk? ( !ncurses? ( sys-libs/ncurses ) )
)
caps? ( sys-libs/libcap )"
RDEPEND="${DEPEND}"
@@ -28,10 +27,9 @@ RDEPEND="${DEPEND}"
pkg_setup() {
use static && append-ldflags -static
- if use static && ( use gtk || use qt3 )
- then
+ if use static && use gtk; then
ewarn
- ewarn "The static USE flag is only supported with the ncurses USE flags, disabling the gtk and qt3 USE flags."
+ ewarn "The static USE flag is only supported with the ncurses USE flags, disabling the gtk USE flag."
ewarn
fi
}
@@ -47,7 +45,7 @@ src_unpack() {
src_compile() {
local myconf=""
- if ! ( use qt3 || use gtk || use ncurses )
+ if ! ( use gtk || use ncurses )
then
myconf="--enable-pinentry-curses --enable-fallback-curses"
elif use static
@@ -55,20 +53,16 @@ src_compile() {
myconf="--enable-pinentry-curses --enable-fallback-curses --disable-pinentry-gtk2 --disable-pinentry-qt"
fi
- # Issues finding qt on multilib systems
- export QTLIB="${QTDIR}/$(get_libdir)"
-
econf \
--disable-dependency-tracking \
--enable-maintainer-mode \
--disable-pinentry-gtk \
$(use_enable gtk pinentry-gtk2) \
- $(use_enable qt3 pinentry-qt) \
+ --disable-pinentry-qt \
$(use_enable ncurses pinentry-curses) \
$(use_enable ncurses fallback-curses) \
$(use_with caps libcap) \
- ${myconf} \
- || die "econf failed"
+ ${myconf}
emake || die "emake failed"
}
diff --git a/app-crypt/pinentry/pinentry-0.7.5.ebuild b/app-crypt/pinentry/pinentry-0.7.5.ebuild
index 6e5f0f6e44b7..d21eef1544b0 100644
--- a/app-crypt/pinentry/pinentry-0.7.5.ebuild
+++ b/app-crypt/pinentry/pinentry-0.7.5.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/pinentry/pinentry-0.7.5.ebuild,v 1.11 2009/05/02 20:34:01 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/pinentry/pinentry-0.7.5.ebuild,v 1.12 2010/01/02 21:46:50 yngwin Exp $
EAPI=1
-inherit qt3 multilib eutils
+inherit multilib eutils
DESCRIPTION="Collection of simple PIN or passphrase entry dialogs which utilize the Assuan protocol"
HOMEPAGE="http://www.gnupg.org/aegypten/"
@@ -13,12 +13,11 @@ SRC_URI="mirror://gnupg/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd"
-IUSE="gtk ncurses qt3 caps"
+IUSE="gtk ncurses caps"
DEPEND="gtk? ( x11-libs/gtk+:2 )
ncurses? ( sys-libs/ncurses )
- qt3? ( x11-libs/qt:3 )
- !gtk? ( !qt3? ( !ncurses? ( sys-libs/ncurses ) ) )
+ !gtk? ( !ncurses? ( sys-libs/ncurses ) )
caps? ( sys-libs/libcap )"
RDEPEND="${DEPEND}"
@@ -33,25 +32,21 @@ src_unpack() {
src_compile() {
local myconf=""
- if ! ( use qt3 || use gtk || use ncurses )
+ if ! ( use gtk || use ncurses )
then
myconf="--enable-pinentry-curses --enable-fallback-curses"
fi
- # Issues finding qt on multilib systems
- export QTLIB="${QTDIR}/$(get_libdir)"
-
econf \
--disable-dependency-tracking \
--enable-maintainer-mode \
--disable-pinentry-gtk \
$(use_enable gtk pinentry-gtk2) \
- $(use_enable qt3 pinentry-qt) \
+ --disable-pinentry-qt \
$(use_enable ncurses pinentry-curses) \
$(use_enable ncurses fallback-curses) \
$(use_with caps libcap) \
- ${myconf} \
- || die "econf failed"
+ ${myconf}
emake || die "emake failed"
}
diff --git a/app-crypt/pinentry/pinentry-0.7.6.ebuild b/app-crypt/pinentry/pinentry-0.7.6.ebuild
index 922cbb570a81..a5cc8de98e47 100644
--- a/app-crypt/pinentry/pinentry-0.7.6.ebuild
+++ b/app-crypt/pinentry/pinentry-0.7.6.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/pinentry/pinentry-0.7.6.ebuild,v 1.3 2009/07/15 21:04:10 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/pinentry/pinentry-0.7.6.ebuild,v 1.4 2010/01/02 21:46:50 yngwin Exp $
EAPI="1"
-inherit qt3 multilib eutils flag-o-matic
+inherit multilib eutils flag-o-matic
DESCRIPTION="Collection of simple PIN or passphrase entry dialogs which utilize the Assuan protocol"
HOMEPAGE="http://www.gnupg.org/aegypten/"
@@ -13,15 +13,14 @@ SRC_URI="mirror://gnupg/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
-IUSE="gtk ncurses qt3 qt4 caps static"
+IUSE="gtk ncurses qt4 caps static"
DEPEND="static? ( sys-libs/ncurses )
!static? (
gtk? ( x11-libs/gtk+:2 )
ncurses? ( sys-libs/ncurses )
- qt3? ( x11-libs/qt:3 )
qt4? ( >=x11-libs/qt-gui-4.4.1 )
- !gtk? ( !qt4? ( !qt3? ( !ncurses? ( sys-libs/ncurses ) ) ) )
+ !gtk? ( !qt4? ( !ncurses? ( sys-libs/ncurses ) ) )
)
caps? ( sys-libs/libcap )"
RDEPEND="${DEPEND}"
@@ -29,10 +28,9 @@ RDEPEND="${DEPEND}"
pkg_setup() {
use static && append-ldflags -static
- if use static && { use gtk || use qt3 || use qt4; }
- then
+ if use static && { use gtk || use qt4; }; then
ewarn
- ewarn "The static USE flag is only supported with the ncurses USE flags, disabling the gtk, qt3 and qt4 USE flags."
+ ewarn "The static USE flag is only supported with the ncurses USE flags, disabling the gtk and qt4 USE flags."
ewarn
fi
}
@@ -54,7 +52,7 @@ src_unpack() {
src_compile() {
local myconf=""
- if ! { use qt3 || use qt4 || use gtk || use ncurses; }
+ if ! { use qt4 || use gtk || use ncurses; }
then
myconf="--enable-pinentry-curses --enable-fallback-curses"
elif use static
@@ -70,7 +68,7 @@ src_compile() {
--enable-maintainer-mode \
--disable-pinentry-gtk \
$(use_enable gtk pinentry-gtk2) \
- $(use_enable qt3 pinentry-qt) \
+ --disable-pinentry-qt \
$(use_enable ncurses pinentry-curses) \
$(use_enable ncurses fallback-curses) \
$(use_enable qt4 pinentry-qt4) \