summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWulf Krueger <philantrop@gentoo.org>2008-01-13 17:59:12 +0000
committerWulf Krueger <philantrop@gentoo.org>2008-01-13 17:59:12 +0000
commit2732ab97718e70b3c989cbc5cb446ef67aa5b84e (patch)
treef024b527bfb93fbf71cb3784b23fd0adaf14a08c /app-crypt/qca-ossl/qca-ossl-2.0.0_beta3.ebuild
parentInitial import to the tree as per bug 129536. (diff)
downloadgentoo-2-2732ab97718e70b3c989cbc5cb446ef67aa5b84e.tar.gz
gentoo-2-2732ab97718e70b3c989cbc5cb446ef67aa5b84e.tar.bz2
gentoo-2-2732ab97718e70b3c989cbc5cb446ef67aa5b84e.zip
Initial import to the tree as per bug 129536.
(Portage version: 2.1.4)
Diffstat (limited to 'app-crypt/qca-ossl/qca-ossl-2.0.0_beta3.ebuild')
-rw-r--r--app-crypt/qca-ossl/qca-ossl-2.0.0_beta3.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/app-crypt/qca-ossl/qca-ossl-2.0.0_beta3.ebuild b/app-crypt/qca-ossl/qca-ossl-2.0.0_beta3.ebuild
new file mode 100644
index 000000000000..1d3655e74aa7
--- /dev/null
+++ b/app-crypt/qca-ossl/qca-ossl-2.0.0_beta3.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/qca-ossl/qca-ossl-2.0.0_beta3.ebuild,v 1.1 2008/01/13 17:59:11 philantrop Exp $
+
+inherit eutils qt4
+
+MY_P="${P/_/-}"
+QCA_VER="${PV%.*}"
+
+DESCRIPTION="TLS, S/MIME, PKCS#12, crypto algorithms plugin for QCA"
+HOMEPAGE="http://delta.affinix.com/qca/"
+SRC_URI="http://delta.affinix.com/download/qca/${QCA_VER}/plugins/${MY_P}.tar.bz2"
+RESTRICT="mirror"
+
+LICENSE="LGPL-2"
+SLOT="2"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+DEPEND=">=app-crypt/qca-${QCA_VER}
+ >=dev-libs/openssl-0.9.6"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ if use debug && ! built_with_use ">=app-crypt/qca-${QCA_VER}" debug; then
+ echo
+ eerror "You are trying to compile ${PN} with USE=\"debug\""
+ eerror "while qca is built without this flag. It will not work."
+ echo
+ eerror "Possible solutions to this problem are:"
+ eerror "a) install ${PN} without debug USE flag"
+ eerror "b) re-emerge qca with debug USE flag"
+ echo
+ die "can't emerge ${PN} with debug USE flag"
+ fi
+}
+
+src_compile() {
+ # cannot use econf because of non-standard configure script
+ ./configure \
+ --qtdir=/usr \
+ $(use debug && echo "--debug" || echo "--release") \
+ --no-separate-debug-info \
+ || die "configure failed"
+
+ eqmake4 ${PN}.pro
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install || die "emake install failed"
+}