summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2004-12-19 20:42:48 +0000
committerDaniel Black <dragonheart@gentoo.org>2004-12-19 20:42:48 +0000
commit70eb2c577f9aaf44fe0633e3af5de76a848be7b3 (patch)
tree5751857cc02e161c19f8307c97b6c7772b20dbf8 /app-crypt/seahorse/files
parentdebug support, minor fixes (diff)
downloadgentoo-2-70eb2c577f9aaf44fe0633e3af5de76a848be7b3.tar.gz
gentoo-2-70eb2c577f9aaf44fe0633e3af5de76a848be7b3.tar.bz2
gentoo-2-70eb2c577f9aaf44fe0633e3af5de76a848be7b3.zip
Added gnupg-1.4 support as per bug #74931.
Diffstat (limited to 'app-crypt/seahorse/files')
-rw-r--r--app-crypt/seahorse/files/seahorse-0.6.3-gpg1.4.patch82
1 files changed, 82 insertions, 0 deletions
diff --git a/app-crypt/seahorse/files/seahorse-0.6.3-gpg1.4.patch b/app-crypt/seahorse/files/seahorse-0.6.3-gpg1.4.patch
new file mode 100644
index 000000000000..2c412ec51bd4
--- /dev/null
+++ b/app-crypt/seahorse/files/seahorse-0.6.3-gpg1.4.patch
@@ -0,0 +1,82 @@
+--- configure.in.orig 2004-12-19 20:51:41.771221552 +0930
++++ configure.in 2004-12-19 21:02:59.005777288 +0930
+@@ -42,13 +42,17 @@
+ micro=`echo $gnupg_version | \
+ sed 's/^gpg (GnuPG) \([[0-9]]*\)\.\([[0-9]]*\)\.\([[0-9]]*\).*/\3/'`
+
+- if test "$major" -eq "$req_major"; then
+- if test "$minor" -eq "$req_minor"; then
+- if test "$micro" -ge "$req_micro"; then
+- ok="yes"
+- fi
++ if test "$major" -gt "$req_major"; then
++ ok="yes"
++ elif test "$major" -eq "$req_major"; then
++ if test "$minor" -gt "$req_minor"; then
++ ok="yes"
++ elif test "$minor" -eq "$req_minor"; then
++ if test "$micro" -ge "$req_micro"; then
++ ok="yes"
+ fi
+- fi
++ fi
++ fi
+ fi
+
+ if test "$ok" = "yes"; then
+@@ -83,8 +87,12 @@
+ micro=`echo $gpgme_config_version | \
+ sed 's/\([[0-9]]*\)\.\([[0-9]]*\)\.\([[0-9]]*\).*/\3/'`
+
+- if test "$major" -eq "$req_major"; then
+- if test "$minor" -eq "$req_minor"; then
++ if test "$major" -gt "$req_major"; then
++ ok="yes"
++ elif test "$major" -eq "$req_major"; then
++ if test "$minor" -gt "$req_minor"; then
++ ok="yes"
++ elif test "$minor" -eq "$req_minor"; then
+ if test "$micro" -ge "$req_micro"; then
+ ok="yes"
+ fi
+--- configure.orig 2004-12-19 22:26:34.407687640 +0930
++++ configure 2004-12-19 22:27:24.973368792 +0930
+@@ -7881,13 +8124,17 @@
+ micro=`echo $gnupg_version | \
+ sed 's/^gpg (GnuPG) \([0-9]*\)\.\([0-9]*\)\.\([0-9]*\).*/\3/'`
+
+- if test "$major" -eq "$req_major"; then
+- if test "$minor" -eq "$req_minor"; then
+- if test "$micro" -ge "$req_micro"; then
+- ok="yes"
+- fi
++ if test "$major" -gt "$req_major"; then
++ ok="yes"
++ elif test "$major" -eq "$req_major"; then
++ if test "$minor" -gt "$req_minor"; then
++ ok="yes"
++ elif test "$minor" -eq "$req_minor"; then
++ if test "$micro" -ge "$req_micro"; then
++ ok="yes"
+ fi
+- fi
++ fi
++ fi
+ fi
+
+ if test "$ok" = "yes"; then
+@@ -7962,8 +8209,12 @@
+ micro=`echo $gpgme_config_version | \
+ sed 's/\([0-9]*\)\.\([0-9]*\)\.\([0-9]*\).*/\3/'`
+
+- if test "$major" -eq "$req_major"; then
+- if test "$minor" -eq "$req_minor"; then
++ if test "$major" -gt "$req_major"; then
++ ok="yes"
++ elif test "$major" -eq "$req_major"; then
++ if test "$minor" -gt "$req_minor"; then
++ ok="yes"
++ elif test "$minor" -eq "$req_minor"; then
+ if test "$micro" -ge "$req_micro"; then
+ ok="yes"
+ fi