summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2004-12-19 13:13:44 +0000
committerDaniel Black <dragonheart@gentoo.org>2004-12-19 13:13:44 +0000
commit7267bd5044e8b928d0fc6a3d505a6423979cd410 (patch)
tree68fb8eaf2ea56c87758620b1620d9780261623f3 /app-crypt/seahorse/files
parentStable on alpha. (Manifest recommit) (diff)
downloadgentoo-2-7267bd5044e8b928d0fc6a3d505a6423979cd410.tar.gz
gentoo-2-7267bd5044e8b928d0fc6a3d505a6423979cd410.tar.bz2
gentoo-2-7267bd5044e8b928d0fc6a3d505a6423979cd410.zip
Add patch to correctly detect gnupg-1.4.0
Diffstat (limited to 'app-crypt/seahorse/files')
-rw-r--r--app-crypt/seahorse/files/seahorse-0.7.5-gpg1.4.patch82
1 files changed, 82 insertions, 0 deletions
diff --git a/app-crypt/seahorse/files/seahorse-0.7.5-gpg1.4.patch b/app-crypt/seahorse/files/seahorse-0.7.5-gpg1.4.patch
new file mode 100644
index 000000000000..6917a7a45644
--- /dev/null
+++ b/app-crypt/seahorse/files/seahorse-0.7.5-gpg1.4.patch
@@ -0,0 +1,82 @@
+--- configure.in.orig 2004-11-01 03:24:04.000000000 +0930
++++ configure.in 2004-12-19 21:11:35.832207728 +0930
+@@ -52,13 +52,17 @@
+ micro=`echo $gnupg_version | \
+ sed 's/^gpg (GnuPG) \([[0-9]]*\)\.\([[0-9]]*\)\.\([[0-9]]*\).*/\3/'`
+
+- if test "$major" -eq "$req_major"; then
+- if test "$minor" -eq "$req_minor"; then
+- if test "$micro" -ge "$req_micro"; then
+- ok="yes"
+- fi
++ if test "$major" -gt "$req_major"; then
++ ok="yes"
++ elif test "$major" -eq "$req_major"; then
++ if test "$minor" -gt "$req_minor"; then
++ ok="yes"
++ elif test "$minor" -eq "$req_minor"; then
++ if test "$micro" -ge "$req_micro"; then
++ ok="yes"
+ fi
+- fi
++ fi
++ fi
+ fi
+
+ if test "$ok" = "yes"; then
+@@ -93,8 +97,12 @@
+ micro=`echo $gpgme_config_version | \
+ sed 's/\([[0-9]]*\)\.\([[0-9]]*\)\.\([[0-9]]*\).*/\3/'`
+
+- if test "$major" -eq "$req_major"; then
+- if test "$minor" -eq "$req_minor"; then
++ if test "$major" -gt "$req_major"; then
++ ok="yes"
++ elif test "$major" -eq "$req_major"; then
++ if test "$minor" -gt "$req_minor"; then
++ ok="yes"
++ elif test "$minor" -eq "$req_minor"; then
+ if test "$micro" -ge "$req_micro"; then
+ ok="yes"
+ fi
+--- configure.orig 2004-12-19 22:17:26.301178104 +0930
++++ configure 2004-12-19 22:17:42.260751880 +0930
+@@ -19341,13 +19341,17 @@
+ micro=`echo $gnupg_version | \
+ sed 's/^gpg (GnuPG) \([0-9]*\)\.\([0-9]*\)\.\([0-9]*\).*/\3/'`
+
+- if test "$major" -eq "$req_major"; then
+- if test "$minor" -eq "$req_minor"; then
+- if test "$micro" -ge "$req_micro"; then
+- ok="yes"
+- fi
++ if test "$major" -gt "$req_major"; then
++ ok="yes"
++ elif test "$major" -eq "$req_major"; then
++ if test "$minor" -gt "$req_minor"; then
++ ok="yes"
++ elif test "$minor" -eq "$req_minor"; then
++ if test "$micro" -ge "$req_micro"; then
++ ok="yes"
+ fi
+- fi
++ fi
++ fi
+ fi
+
+ if test "$ok" = "yes"; then
+@@ -19422,8 +19426,12 @@
+ micro=`echo $gpgme_config_version | \
+ sed 's/\([0-9]*\)\.\([0-9]*\)\.\([0-9]*\).*/\3/'`
+
+- if test "$major" -eq "$req_major"; then
+- if test "$minor" -eq "$req_minor"; then
++ if test "$major" -gt "$req_major"; then
++ ok="yes"
++ elif test "$major" -eq "$req_major"; then
++ if test "$minor" -gt "$req_minor"; then
++ ok="yes"
++ elif test "$minor" -eq "$req_minor"; then
+ if test "$micro" -ge "$req_micro"; then
+ ok="yes"
+ fi